Unable to login to gmail using my phone


Last Updated: 2011-10-10 21:13:32
  1. dwightwilbanks

    dwightwilbanks New Member

    I have a real live gmail account, (not an apps account) that is unable to log into gmail, for using the market, google maps, contact sync and of course gmail.

    I am able to log into via my computer, and I have even changed my gmail password, hoping that would resolve it.

    The message I get is:

    Google sign-in:
    There was a network error while trying to sign into ***@gmail.com. Retry now or press the Back button to cancel.

    [Try again]

    If I take the message on its word, then the issue is the network. I am in China, using China Unicom, and I've also tried several wifi networks. The problem has persisted for 24 hours.

    In addition, I have a Hong Kong sim that is unable to log in (roaming)

    I'm not positive that the network error is accurate, I do have access to skype and web browsing including google.com

    Phone is a Motorola XT701 running 2.1, the XT701 is a milestone derivative (from what I understand)

    Does anyone have any thoughts? Any suggestions of other things I can do?

    Thanks in advance

    Advertisement
  2. Gazman

    Gazman Member

    Hi

    I'm having a similar issue with my HTC Desire. I'm on China Mobile and frequently swap between my UK SIM (so I can install paid for apps over VPN).

    I used to get this message after swapping SIMs and re-entering my password would sort it out.

    However, I've just returned from a trip to the US where I used my UK SIM (and installed some apps from the US market over WiFi).

    Now I can't sign-in at all. I thought I'd remove my account and re-input the details but it won't let me saying this can only be done by a factory reset - searching some other forums indicates this may be the only way.

    If anyone finds a better solution, I'd appreciate it.

    Thanks

    *** UPDATE ***

    After much fiddling around it eventually signed back in.

    I first put my UK SIM back in and connected to VPN over WiFi. I opened the market and entered my password there, after which things started to sync.

    After putting my Chinese SIM back in and connecting to VPN over WiFi, after several tries it worked (password in the market didn't work at first but it eventually did when entered using the sign-in error notification a the top). I then had to re-enter my password in the market but now all is fine.

    I am not sure what the key step is but I think it is some mismatch between the market and google sign-in. I noticed the market has changed appearance which may have caused issues. VPN may also be factor.
  3. dwightwilbanks

    dwightwilbanks New Member

    Now I'm really in trouble, I've done a factory reset on the phone, it still won't let me sign in.
  4. Gazman

    Gazman Member

    Have you tried connecting over VPN? Google services frequently get blocked in China.
  5. Mr.Wrong

    Mr.Wrong Member

    I guess you shall be sure that the password you typed in is right and maybe you can call the service provider, or follow the instructions by Gazman. Good luck and please let me know if you figure that out.
  6. dwightwilbanks

    dwightwilbanks New Member

    UPDATE: I have connected via VPN and successfully logged in, sure wish I knew to do this before I wiped my phone, but, later is better than never.
  7. Gazman

    Gazman Member

    Glad it works. Looks like VPN is the main requirement which is good to know!
  8. Gazman

    Gazman Member

Share This Page