1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Unable to mount SD cardSupport


Last Updated:

  1. n8man1068

    n8man1068 Member This Topic's Starter

    Joined:
    Nov 5, 2009
    Messages:
    22
    Likes Received:
    0
    I started having this problem today. When I connect the phone to my pc, the sd card does not mount. I've tried rebooting the phone, unplugging/replugging the usb from the computer and phone, debugging mode on/off on the phone, and clearing all of the device entries from the Windows registry. The error in event viewer shows:
    Event id 11:
    The driver detected a controller error on \Device\Harddisk2\DR27.

    Error I get is 'please insert a disk into removable drive (drive letter)'.

    thanks
     

    Advertisement
  2. SeanStick

    SeanStick Well-Known Member

    Joined:
    Apr 30, 2009
    Messages:
    87
    Likes Received:
    0
    Have you tried going into settings and then unmount the SD card then restart the phone?
     
  3. pastafarian

    pastafarian P√Ętes avec votre foie Moderator

    Joined:
    Nov 4, 2009
    Messages:
    5,621
    Likes Received:
    4,618
    Maybe basic but...
    After connecting with USB, did you pull down the notification menu select USB connected and mount the sd card?
     
  4. Edaze55

    Edaze55 Well-Known Member

    Joined:
    Aug 26, 2009
    Messages:
    973
    Likes Received:
    1
    It may be basic, but better to ask now, rather than find out later that was the issue. :D
     
  5. justpastfinish

    justpastfinish Well-Known Member

    Joined:
    Oct 26, 2009
    Messages:
    71
    Likes Received:
    11
    I have this problem too... and I dont get a notification in the tray. It just makes the sound on my pc that something connected...

    Nothing on my android device...
     
  6. tphone

    tphone Active Member

    Joined:
    Nov 9, 2009
    Messages:
    30
    Likes Received:
    0
    What worked for me was to power cycle the phone. Note that it had previously worked, then didn't. So I power cycled the phone, and now it works again.
     
  7. Adrift

    Adrift Well-Known Member

    Joined:
    Nov 1, 2009
    Messages:
    716
    Likes Received:
    104
  8. roberto.coreas

    roberto.coreas New Member

    Joined:
    Sep 11, 2010
    Messages:
    1
    Likes Received:
    0
  9. MarcoPon

    MarcoPon New Member

    Joined:
    Sep 17, 2010
    Messages:
    1
    Likes Received:
    0
    roberto, the link you posted seems to point to the AppBrain website, not a specific page.
    Can you tell us the name of the App you are referring to?

    Thanks,
    Bye!
     

Share This Page

Loading...