Unable to move app to the internal USB storageSupport

Last Updated:

  1. aj246

    aj246 New Member

    Hey, I have a weird problem with my S2 (I9100G) with the ICS update.

    Whenever I try to move any application to SD (in this case the internal 11 odd GB USB memory) I get a popup saying "Couldn't move app. Not enough storage space". So I obviously go check my storage, and I find I have 236MB on the internal (2GB) storage and 1.3 GB on the internal USB (11 GB) storage.

    I have attached screenshots of the error and storage screens.

    Please help

    Attached Files:

    Ghost Matter likes this.
  2. Ghost Matter

    Ghost Matter Member

    I have the exact same issue! Very frustrating! I have to remove some apps to even be able to install new ones (which was the original issue which made me reset my phone and SD to factory). I only started having this problem since the upgrade to ICS. I tried the two applications called App2SD but they just point me to the same spot as the parameters.

    From the French forums, I gather we might have to root the phone. But I don't really want that! It's fine how it is apart from this issue.
  3. Russell Ng

    Russell Ng Well-Known Member

    In MOST cases the move to SD requires you to have an external microSD in place. It will put most of the app files in a folder Android_secure which can only be viewed in PC. Try to move after inserting a microSD into the phone.
  4. naith_kk

    naith_kk Well-Known Member

    Russell is correct, App2SD requires you have an external SD card.

    I encountered the same issue with "storage space issue" with a upgrade to ICS from Gingerbread. The temporary workaround was to uninstall the troubled app, reboot, reinstall the app and then proceed to App2SD to SD card.

    ... but I had too many apps encountering the error... and moreover, sometimes the workaround worked, sometimes it didnt.

    If you still have problems of "space" even if you have an SD card in place, it would be better to factory reset your phone... backup your data, apps, music, etc. move your backups to your PC, format usb storage and sd card, followed by a factory reset of ICS.

    Done that, and to this day I've yet to receive a space issue error with ICS.
  5. Ghost Matter

    Ghost Matter Member

    As I said before, I did that already and my original issue (errors when installing or updating software) creeped back. :(
  6. naith_kk

    naith_kk Well-Known Member

    Most likely its a flash gone bad, and, it does happen (there are many casualties both in XDA and this forum seeking help for an upgrade gone wrong - even my first upgrade through KIES for GingerBread ended up a softbrick and I was just a 2 month S2 user that knew little about Android) if your phone is still with warranty, either get flashing support online from Samsung through their Emergency Firmware recovery which they provide the code for you to proceed with guidance, or take it to the official service centers... and have them do it quite quickly (which was what I did for my case).

    if you're up to the risk factor, and you don't mind the adventure - you can flash it on your own... but you'll need to really do some serious reading in flashing before you take the plunge to do it yourself. Many cases, manual flashing succeeds, many times people flash badly - its because they don't read enough. (and if you still fail flashing manually, don't tell the service center you flashed it using Odin... say its KIES fault. They'll understand. haha)
  7. Ghost Matter

    Ghost Matter Member

    No, that error comes from my phone memory being full... Unfortunately, looks like I won't be able to transfer to SD until I buy an external card. Really ridiculous!

    Thanks for the help,.
  8. deadpool25

    deadpool25 New Member

    I dont have an external SD card, can I still use something to install the apps in the internal USB storage
  9. Hammerpgh

    Hammerpgh Well-Known Member

    I also started getting this message recently. Tried installing an app yesterday and it failed due to insufficient storage even though there was over 200mb free and the app download was only around 30mb. I did move as many apps as I could and although it then allowed me to install the app it was still not showing as much memory as I expected. The task manager was showing around 250mb while the app manager had it as around 700mb.. confused as to why they are showing different.
  10. meldroid42

    meldroid42 New Member

    On your keypad, enter *#9900#
    This will bring you to the (hidden) SysDump menu.
    Select the "Delete dumpstate/logcat" option.

    This clears out all of the unrequired, accumulated dump files.
    Pulled back 1Gb for me.....
  11. trankillooo

    trankillooo New Member

    thx so much for this info meldroid42, concerning the amount of space, you nailed it !!

    9900 is a great but mysterious resource though... :smokingsomb:

    However it still refuses to move to SD... bummer!


Share This Page