Unable to Scan for NetworksSupport


  1. simian340

    simian340 New Member

    I rooted my Moment as well but there is no /wifi folder within my /data folder in order for me to delete the file specified in this thread. Is it possible it is located somewhere else?
  2. kb9hgi

    kb9hgi Member

    My Samsung Moment finds my router then says obtaning IP address from my router then it keeps say unsucccessful touch to try again and never connects. This is my 2nd moment the first one was Android 1.5 and it locked up flashing it then sprint sent me this one a week ago with the latest android software and it still will not connect wifi. Is it my router maybe i should try it at a wifi hot spot.
  3. Gunnarson

    Gunnarson Member

    On my Intercept, this process fails at step #4. The DDMS app comes up but does not connect to my phone. Nothing listed under Name. :confused:
  4. Zibeck

    Zibeck New Member

    Hi,

    I had the same problem (Samsung i5800).
    New phone, wifi works and after a while when I turned off and on the wifi and I received the same messages.
    Went back to the store and received a new phone.
    Wifi works but after a while same problem ?!??!
    I did a factory reset and the problem was gone, wifi works again.

    The only thing I can think of that could cause this is the Samsung Kies software. After I had both phones connected to it, the problem occured.
    Kies didn't install any updates (as far as I know).
    It can't be that both phones have the same hardware failure, that's why I think it must be the software.
    Or it must be one of the apps I installed.

    Let me know what you think about this.

    Best, Ziggy
  5. robinoet

    robinoet New Member

    I had the same wifi problem on my I5800, did the rooting solution, and it worked!!
    Wifi is back!

    Thanks for the help guys!

    However, I hope samsung does something about it!! It is not normal at all!!
    I never use the kies software! The only thing that I changed was on my router the WPA2 key...earlier I always used WPA....
    Since I used wpa2, my wifi connection was very very weak, and after a week I had the wifi problem....don't know if it had anything to do with it....just a thought...
  6. shauggy

    shauggy New Member

    I used rghv65c's directions, but it still didn't work for me - YMMV. Here's what I had to enter into the terminal for step 3 (the file's in a different location on the Moment than the Galaxy):
    su
    cd /
    cd data
    cd misc (this is the extra step)
    cd wifi
    ls (you should see a file named "bcm_supp.conf")
    rm bcm_supp.conf

    I've tried it through the terminal app and the SDK command line...argh, still won't work. Anybody else had better results?
  7. airik

    airik New Member

    I have done all of the steps successfully until step 6, at this point I try to click on the data section in the file explorer and it wont expand or do anything really. I can view files in all of the other sections though......urg:confused:
  8. airik

    airik New Member

    Ok, update. I did figure the process out, I had to root before being able to enter the data folder....not sure why. I did successfully remove the file and rebooted but as soon as I try to enable wifi the same problem occurs and in the same folder reappears the unwanted file......
  9. geek_girl

    geek_girl New Member

    I had this issue for the last few weeks on my Samsung Captivate. I've used the phone for over 6 months without a problem. I thought it was one of the WI-FI apps on the phone and removed all of them, but this did not resolve the problem. Only after upgrading to Android 2.2 did the problem get resolved.

    Make sure you backup your phone before upgrading.

    Follow the instructions at http://ars.samsung.com/customer/usa/jsp/faqs/faqs_view_us.jsp?SITE_ID=22&PG_ID=2&PROD_SUB_ID=557&PROD_ID=558&AT_ID=304008
  10. nismospec

    nismospec Well-Known Member

    reviving this thread as it started happening to me recently.
    does anyone know what causes it? was it a bad app that messed something up?

    i'm a total noob and don't care to try rooting my phone for the risk that i may mess something up.

    would this be considered a hardware issue that may aid me in haggling sprint for a new phone?
  11. trinione

    trinione New Member

    Step 1: Install Ghost Commander file manager program (available via Marketplace) OR if you cannotr connect to internet as you do this via WiFi (like I do, read the NOTE below)

    Step 2: Open Ghost Commander and go to 'root:/data/wifi' folder

    Step 3: Rename or Delete 'bcm_supp.conf' file

    THAT'S IT! My WiFi is working again. Good luck!

    -----------
    NOTE for those who cannot install Ghost Commander due to lack of WiFi to connect to MarketPlace via the internet.

    Go to: Ghost Commander and click on the 'Downloads' link.

    -----------
    AN ADDITIONAL NOTE for users with Install Locked phones such as AT&T's Galaxy S. Install via the .

    Go to: Settings | Applications | Development | USB Debugging

    (this ought to work in general - I have installed other apps this way, not this one as I already had it on my phone)

    HOPE THIS HELPS. Of course the normal disclaimers apply. I guarantee nothing, just posting what worked for me.
    Zlarty, tokenwelshman and joshuas1320 like this.
  12. 240phil

    240phil Well-Known Member

    Yes, It has become a very common problem. Many times, the Sprint tech will "fix it" and within a day or two, it will not work again, and then the phone will be replaced.
    So if you don't want to root it or get too "technical" with it, then I'd just start the haggle with Sprint to get a new phone.

    I could be wrong, but I thought ghost commander required root access to be able to work?
    The general talk on the forums is that This is very similar to what the Sprint tech does when you take the phone in (using a sprint program, not a market app) but for many, it is a temporary fix. Whatever cause that file to become corrupted in the first place is still an issue. So ultimately, most people end up getting their phone replaced.
    If it works for you and has continued to work, then awesome. If not, then hit up sprint.
  13. joshuas1320

    joshuas1320 New Member

    I have the same problem with this phone infact i have had so many problems with this phone like always force closing things and stuff like that but i would reall know what i can do to fix this problem. !
  14. joshuas1320

    joshuas1320 New Member

    when you system reset did it work?
  15. regervin

    regervin New Member

    I had the same problem with my HTC EVO. My workaround is: disable the mobile network. My phone connects to the wifi and then I re-enable the mobile network. Works everytime.
    apainter, gfromnyc and sjksjy like this.
  16. tokenwelshman

    tokenwelshman Member

    Thank you hugely for this tip. I've been struggling with my Dell Streak to resolve this issue, lots of other suggestions haven't worked (eg using other file explorer apps like ES File Explorer, Dual File Manager; via a terminal emulator which is given SU access; or going into the phone using SDK Manager from the PC) but this one did it. :D

    I rooted the phone using an older version of SuperOneClick, the current version doesn't seem to work with the Streak, you need to go back to a version which uses the rageagainstthecage approach. v1.5.5 I think.

    A final quirk for the Streak is that the file you need delete or rename is different to any other information I've seen - it isn't bcm_supp.conf or wpa_supplicant.conf, but simply wpa.conf, and is found in data/misc/wifi on this device.
  17. ravidroid

    ravidroid New Member

    I had same problem when I tried to connect wifi at a new location. It did not connect first so I tried "Forget" network option and after that my phone was unable to scan for wifi networks. I tried steps you listed above but my "data" folder is empty. I could not find the file so I tried Factory Reset method. It fixed my problem.
  18. Torstein

    Torstein New Member

    Hi

    I would like to inform that I have been struggeling with the issue "unable to scan for networks" for some time. Problem is that sometimes a factory reset works, sometimes not. From day to day, its been working, and thes suddently not working.

    When not working : 3x "uanble to scan for networks" the wifi shuts off.
    Sometimes the phone says "settings not responding", and sends an error report to HTC (I have a Desire HD).

    Now I have done numerous factory resets, and installed / uninstalled apps to try and fix issues... no avail....

    I sent the phone to the shop the second time, and this time they actually did something (other than factory reset ... blah..).

    I've yet to recieve the phone (its in the snail-mail), but the Fault explanation from repair shop : "WiFi antenne loose, fastened ant tested OK" ...

    So This may help others with this annoying problem : "Your wifi antenna may be loose".

    I really hope that this really IS the source to my problems ...
    I'll edit this post if this is is not true ..
  19. Charlie Quidnu

    Charlie Quidnu New Member

    This worked for me today.
  20. sjksjy

    sjksjy New Member

    Thank you so much for posting this! I really didn't want to root my phone and mess it up, nor did I want to take it to Sprint and wait in line for an hour. This worked perfectly for me
  21. apainter

    apainter New Member


    Thank you, I too have the HTC EVO and the same problem. Thanks for sharing.
  22. Zlarty

    Zlarty New Member

    Thanks so much - worked for me on a GT-I5800

    Just wish I'd read this bit first (before I tried rooting, SDK.... etc)
  23. TallyGlenn

    TallyGlenn New Member

    I have done this twice over the last couple of weeks. Have not determined what triggers it, but works great for now.
  24. ALEX6

    ALEX6 New Member

    • Hi! I have a tablet [FONT=&quot]([FONT=&quot]7" Android 2.2 Google PC Tablet VIA 8650 epad flash10.1[/FONT][FONT=&quot]BUILD IN (WIFI) FLASH 4GB RAM 512MB BUILT IN CAMERA[/FONT][FONT=&quot]) [/FONT] but have a problem with the wifi. When i turn it on this appears "Unable to scan for networks" and then wifi turn off. I read in the forums that i must delete or rename this file "wpa_supplicant.conf". I tried with Super Manager, Ghost Commander and AndExplorer but the file wasn't deleted nor renamed. Somebody to have other ideas?[/FONT]
  25. momentoid

    momentoid Well-Known Member

    Welcome to the forum.
    You need root access to delete this file. Find your device in this list which may be able to help you: Android Tablets & MIDs - Android Forums
Loading...

Share This Page