Unable to send picture texts (MMS). Culprit: Quick Settings AppSupport


  1. zenman

    zenman Well-Known Member

    I installed the Quick Settings App a while back because my brother said it was a good app. I didn't really use it so I uninstalled it. But now I can't send picture texts (MMS). He can't either. I found a thread which talks about a fix but the fix doesn't work. I started this thread because the title of that thread isn't very clear and it keeps getting buried. Here's the other thread:
    http://androidforums.com/htc-incred...ck-settings-bug-mobile-data-switch-issue.html

    Any ideas how to fix this without doing a hard reset? I would really like to avoid a hard reset.

    Advertisement
    :
    mantel34 likes this.
  2. mantel34

    mantel34 New Member

    I feel for ya zenman and hope that someone on this forum has an answer.

    I have the exact same issue, meaning I also installed Quick Settings.. and can't send or receive picture texts. I've subsequently removed Quick Settings. To be fair, I didn't try sending pic/text messages prior to installing Quick Settings.

    I worked with a Vz tech to try and fix this.. to no avail. He reset the phone (not sure how), assured the phone settings and account info were ok. After that (over 1 hour on the phone) they had no more ideas.

    Thanks for starting a specifc thread to resolve this.
  3. zenman

    zenman Well-Known Member

    Ok, I fixed it. I followed the directions below which I got from the thread started by the great "INTREPID-NY" that I linked to above. It didn't work at first so I made a slight modification to his instructions and now I can send/receive MMS. Follow his directions first. If that doesn't work, you can substitute my Step 5 below instead of his Step 5. Good luck, no guarantees this will work for you. (Again, the culprit is the Quick Settings App so I suggest deleting it after you fix this. I'm not sure if Quick Settings must be installed on your phone for this fix to work. I reinstalled it before doing this fix.)

    Before you Begin: You must have a MicroSD card installed. You MUST have Windows configured to show extensions of known file types! Do not proceed until you're sure you can see extensions of files. See here for simple instructions on how to show extensions in Windows: http://www.tacktech.com/display.cfm?ttid=193

    1) Install APN Backup and Restore from the Market (free)
    2) Run the App and select Backup. Name the file: apns-broken.xml
    3) Plug Incredible into USB (or remove card) and copy the file on your phone's sdcard from folder called APNBackupRestore to your pc.
    4) Open the file on your pc in a text editor such as notepad.
    5) Remove the 2 occurrences of [disabled] - see below for example.

    My Step 5: Erase everything you see in the file and then cut & paste the "APN After Editing" sequence seen below. (Click on File and then Save, not sure if this makes a difference but I did it.)

    6) Save the edited file as: apns-fixed.xml
    7) Verify your can see the file extension of the file as .xml
    8) Copy the file back to your sdcard into the same folder called APNBackupRestore.
    9) Run APN Backup again and click Restore. Select the file to restore: apns-fixed.xml - When prompted to search for all instances, answer: NO
    10) Unplug your phone from USB and reboot your phone.


    APN Before Editing
    bolded entries will be removed
    ==============

    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns>
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="1[disabled]" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.vtext.com/servlets/mms" type="mms[disabled]" />
    </apns>

    APN After Editing
    ==============

    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns>
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="1" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.vtext.com/servlets/mms" type="mms" />
    </apns>

    =============
    Note: If the word "null" is missing after your restore and check the apn again, that is ok. For example: password="null" and Password="" are both acceptable. Sometimes Android will remove the word "null" when restoring.
  4. mantel34

    mantel34 New Member

    Nice work zenman, I got my picture messaging going as well.. but I took a different route.

    After the third looooong call with a Vz tech, and doing everything but a hard reboot, he decided the most likely culprit was an app interferring with normal communication. He suggested doing a "hard reboot" to kill all the apps and re-set everything to stock.

    After saving my contacts to the SD card, I did a full system restore. The entire process took about 5 minutes. Picture messaging works perfect now.

    I was amazed that after the "reboot", all the contact information was instantly accessable as well as all the photos on the SD card.. I didn't have to do a thing to restore the data.. really love this phone.

    I did have to reinstall the apps and rebuild the "home pages" but I see this as a good thing.. because I surely went crazy at first down loading everything... this time I only downloaded the few I actually used.

    I have no idea which app caused the issue.. I did install Quick Settings.. but still had issues after uninstalling it. This time I plan on testing the picture/text function before and after each app l download.

    hope this helps someone.. as this forum has surely helped me.
  5. zenman

    zenman Well-Known Member

    Yea Mantel, my brother took the full reboot route too. That's nice to know you can save all the contacts and pics on the card. Like you, I also went crazy the first two weeks and downloaded and then uninstalled a bunch of crap. I might just do a fully reboot if I start noticing lag.
  6. scudder

    scudder Well-Known Member

    Hey guys...

    I'm a new EVO user and have a problem not being able to send MMS files but through the 3rd party Handcent app. MMS/picts can be sent with NO PROBLEM through the stock "Messaging" app.

    So I followed the information above because I also installed the Quick Settings app and though I might have the EXACT same issue as above. I backed up and looked at the xml file, however, my xml file does NOT have an instances of "[disabled]" in the text of the file. In other words, the text of the file ALREADY is PRECISELY what you have suggested it look like for restore.

    So, I still have the problem with my EVO...with the Handcent 3rd party app. Any thoughts?? THANKS!!

    Scott
  7. v8dreaming

    v8dreaming Well-Known Member

    I am having this problem also, except it's not sending mms with the stock app or with chomp. I downloaded apn backup and checked and mms is not disabled...

    I have a Dinc.
  8. cubebuddha

    cubebuddha Member

    I just fixed mine on my EVO its the same process as above but the url for Verizons MMS network is different for the Evo because its on sprint
  9. Velocd

    Velocd Well-Known Member

    So your evo had the disabled in the APN file?
  10. scudder

    scudder Well-Known Member

    Don't know if anyone cares about this issue but as a FOLOW UP...now having 2.2 installed and REINSTALLING Quick Settings, I have NOT have a problem sending MMS messages. I AM, however, using ChompSMS as my message app. I do NOT use the stock HTC app.
  11. JSS12

    JSS12 Well-Known Member

    tried this... DIDNT work...

    please anyone???

    do not want to hard reset!!
  12. JSS12

    JSS12 Well-Known Member

    Anyone?
  13. teshastar

    teshastar New Member

    I was unable to send picture messages after flashing Synergy ROM on an HTC Evo. I did a full wipe and after trying several different things, this was the only thing that worked.

    Use root explorer, and make sure it is set to R/W mode (read/write). Navigate to /data/data/com.android.providers.telephony/databases/telephony.db and delete that file, then restart your phone. After the restart, you should be able to send and receive MMS messages.
  14. EvoImage

    EvoImage Member

    I created an account just to say thank you for this post!! I have been trying to get my MMS/pic messaging working for a month now. I have tried EVERY resolution and ROM I could think of to resolve it. This simple deleting of the 2 files in this directory have fixed it and I can now use ALL of my phone capabilities on MetroPcs!! I was actually going to go spend 350 on the esteem and now I wont have to!

    Thank you so much for this life saving post I can now rest knowing I have accomplished what I ALMOST gave up on.....You are the man!!:D:D:D
  15. evienyc

    evienyc New Member

    Have tried all the suggestions in this & other forums, short of a factory reset, but nothing is working.

    ~ I'm using the standard messaging service that came with the phone, do not have Quick Setting, Handcent or any other messaging apps.
    ~ Having this error when receiving messages both on 3G and Wireless.
    ~ Issue is with receiving regular text messages, not just pictures or videos
    ~ Do not have the APN setting under Mobile Networks, so no changing, adding or fixing that.
    ~ On the Verizon network (they say it's not a network issue but HTC)
    ~ Tried APN Backup, Clear Data in Manage Applications, remove battery & reboot
    ~ Not receiving a "Force Close" message
    ~ When I click on "Download" for the message it won't download & I'll just get the error again. Keep getting errors until I finally choose "Decline" instead

    Does anyone have any other ideas that might help? This issue has only started for me over the past week... I haven't downloaded any apps or done anything to the phone recently.

    Please help! I'm going out of my mind! :eek:

    Thank you!
Loading...

Share This Page