1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Unable to send text (SMS) messagesSupport


Last Updated:

  1. lotus49

    lotus49 Well-Known Member This Topic's Starter

    Joined:
    May 9, 2011
    Messages:
    1,513
    Likes Received:
    230
    Phone: rooted GT-i9505 running CM11 on 3 UK network

    For the last few days I have been unable to send any SMS messages. When I try to using Handcent (my default SMS app), there is just a rotating progress wheel that sits there rotating (for several days in some cases). There is no error message.

    At first I thought it was because the recipient's phone was off but it's now clear that is not the case. I wondered whether it was something to do with Handcent so I tried using the stock SMS app. When I tried to send a text using that, it says "SENDING..." but nothing else happens. There is a message saying "Sending disabled" at the bottom of the screen. Setting the stock SMS app as the default and trying again made no difference except the "Sending disabled" message disappeared.

    I only installed CM11 a few days before this started happening but I'm fairly sure I have sent texts successfully since then. I cannot remember exactly when I installed it so if anyone knows how to check the installation date that might help.

    I am not a big texter (which is why it took several days to notice the problem) but I have never had problems before. Consequently, I have no idea where to start diagnosing this problem.

    Any ideas?
     

    Advertisement
  2. lotus49

    lotus49 Well-Known Member This Topic's Starter

    Joined:
    May 9, 2011
    Messages:
    1,513
    Likes Received:
    230
    Being the resourceful chap I am, I have figured this out now. I probably ought to have looked more carefully than I did before posting here but since I have solved it, I shall post what I did in case anyone else has the same problem.

    This appears to be caused by having the incorrect (or missing) SMSC number. To fix, follow the following steps:

    1. Install GO SMS Pro
    2. Open it, go to Menu -> Settings -> MESSAGING: Send&Receive -> ADVANCED: SMS/MMS Advanced settings -> MESSAGE CENTER: Enable customised SMSC -> ON
    3. MESSAGE CENTER: Customised SMSC number
    4. Enter +447782000800, OK
    This did the trick for me. The pending messages weren't sent but new messages are now sending fine.

    If anyone knows a more elegant way of setting the SMSC (i.e. one that doesn't involve installing an app I don't otherwise want) I'd be interested to know. I did used to use GO SMS Pro but I seem to recall that I got fed up of adverts for other GO products so I uninstalled it. Still, props to GO SMS for having the option to change the SMSC number, which Handcent doesn't appear to have.
     
  3. nugroho2

    nugroho2 Member

    Joined:
    Mar 3, 2010
    Messages:
    5
    Likes Received:
    0
    Had the same problem using Go SMS with two SIM cards. Both failed to send to certain numbers; so it's not an issue with providers. Solved this way: Go SMS settings, More tools, SMS blocker, Settings, disable all black list and white lists. The app runs normally again. The developers should take note of this.
     

Share This Page

Loading...