Unable to sync with Google calendarSupport


Last Updated:

  1. GeneralSunTzu

    GeneralSunTzu Member This Topic's Starter

    Joined:
    Jul 15, 2011
    Messages:
    5
    Likes Received:
    0
    Have reviewed all posts on this matter (most are pretty old, few refer to the SII).

    My provisional conclusions are:

    1. there is a local calendar hardwired into the SII; unfortunately it cannot be deleted nor disregarded;
    2. the programmer who wrote it is not exactly a genius, for a number of reasons;
    3. no other programme available on Android Market is able to sync with my Google calendar (i.e. events entered on the phone do not register onto the Google calendar);
    4. the various tips, deletions, maneuvers suggested in a number of posts seem all unfounded and are all, without exception, ineffective in my case;
    5. there is no trivial parameter (sync, calendars, etc.) able to fix this.

    Am I overlooking something perhaps quite obvious?

    Thank you.
     

    Advertisement
  2. trick202

    trick202 Well-Known Member

    Joined:
    Aug 26, 2009
    Messages:
    949
    Likes Received:
    49
    So are you talking about the google calendar or a third party samsung calendar?

    Try settings/sync etc
     
  3. pcbms

    pcbms Well-Known Member

    Joined:
    Apr 9, 2010
    Messages:
    123
    Likes Received:
    13
    Calendar pad - free - from the android market does exactly what you want
     
  4. Slug

    Slug Check six! Moderator

    Joined:
    Aug 1, 2009
    Messages:
    20,154
    Likes Received:
    15,836
    To sync your Google Calendar you have to add it to the Calendar app on the GS2. Open Calendar, then Menu/More/Calendars and add those you wish to sync.
     
    GeneralSunTzu likes this.
  5. GeneralSunTzu

    GeneralSunTzu Member This Topic's Starter

    Joined:
    Jul 15, 2011
    Messages:
    5
    Likes Received:
    0
    Actually I am trying to sync with a Google calendar, by using either the samsung calendar on the GS2 or an alternative Android calendar.
    I tried already, as I said, the obvious, as you suggest, but it does not work, that is entries I make on the GS2 after a while disappear, though my Google calendar is in the list of calendars to be sync'ed.
    Thank you anyway.
     
  6. friedbeef

    friedbeef New Member

    Joined:
    Jul 30, 2011
    Messages:
    1
    Likes Received:
    0
    I have this exact same problem. Have you been able to fix it yet?
     
  7. doc1964

    doc1964 Well-Known Member

    Joined:
    Oct 13, 2010
    Messages:
    258
    Likes Received:
    60
    I use Gemini calendar free version and it syncs perfectly with Google calendar. As mentioned above you go into preferences and select which calendars you wish phone to display. In my case i only choose the google calendar and eveything moves between phone and google seamlessly. Gemini has a lot more options for regularity of events than the stock calendar.

    Coincidentally, there seems to be a recent problem that arose whereby all of the entries from google calendar disappear off the phone. This happened to me the other day. To fix this, go into settings, applications, manage applications, select all, then scroll to calendar storage and clear data. Then when you sync with google all of your entries will be back.
    Hope this helps.
     
  8. steslatt

    steslatt Well-Known Member

    Joined:
    Jul 20, 2010
    Messages:
    1,145
    Likes Received:
    303
    I had this problem, the ONLY thing that fixed it was a factory reset for me, clearing data did not work. A pain but i had tried everything else.
     
  9. carol1247

    carol1247 New Member

    Joined:
    Jul 31, 2011
    Messages:
    1
    Likes Received:
    0
    I lost the ability to see my calendar updates on my home computer. It worked fine until yesterday and today the calendar is just dead. :( Someone mentioned a "factory reset" to fix it. How do you do that?

    Thanks.
     
  10. GeneralSunTzu

    GeneralSunTzu Member This Topic's Starter

    Joined:
    Jul 15, 2011
    Messages:
    5
    Likes Received:
    0
    Yes, and here is what I did:

    1. via a browser on my Mac, and not on the Galaxy S2, I checked my calendars and deleted all "extraneous" calendars from what Google calls the "favorite" calendars; I added those to the calendars I view, however;
    2. I cleared the calendar data on the Galaxy;
    3. still on the Galaxy, I then asked to sync.

    The calendar programme on the Galaxy is written by a quintessential idiot I would fire within 24 hours if he or she worked for me, as all this implies that the idiot does not perform a number of consistency checks which would have avoided all this crap...

    However, by doing all this I did not need to do a factory reset and yes, now when I enter a date on the Galaxy, it will no longer lose it.

    Cheers
     
  11. chestnuttree

    chestnuttree New Member

    Joined:
    Jun 10, 2011
    Messages:
    3
    Likes Received:
    0
    Resolved --- CalenGoo fixes these problems


    Found an App called CalenGoo from the Android Market. Its a Calendar App, which enables syncing of Google Calendars sub calendars.

    I was previously looking everywhere for a way around the Google Calendar sync problems and this app sorts these out nicely.

    Its a pretty good calendar application in general - simple to suit the majority of users, but also has lots of advanced options if you feel like customising things a bit.

    The guy who designed the app, Dominique, is also really quick to answer emails and address any questions you might have. HIghly recommended - spread the word
     

Share This Page

Loading...