Unable to turn off mobile data

Last Updated:

  1. Applejack77

    Applejack77 Member


    I have a sim free Hero on 3UK that I recently upgraded to 2.1. Since doing so, I have noticed that the data turns itself on every so often.

    I normally use the htc widget to turn on/off the mobile data as I don't use it while at work/at home. Occaisionally, I notice that it is switched on and when I try to switch it back off, it restarts itself. I've noticed this on quite a few days now over the last couple of weeks and once it starts doing it, I can't stop it!

    I can only think it is down to either some app that I have installed or the synch settings, but I have checked for running processes and killed anything that looks like one of my apps.
    I have also disabled:
    Settings>about phone>system software updates>Scheduled check
    Settings>Synch settings>Background data
    Settings>Wireless & Networks>Mobile networks>Enable always-on mobile data
    I would like any apps just to use data if I switch it on and am unsure what the best settings are for the above.

    I don't really know what else to do to stop it. Has anyone got any ideas?


  2. SchOX

    SchOX Active Member

    I've noticed the same behavior since the 2.1 upgrade (Nordic HTC Hero). I'll have to reboot the phone to turn of mobile data. quite annoying, and potentially expensive if abroad...
  3. robogo

    robogo Well-Known Member

    I, too, have noticed that sometimes (after uninstalling SwitchPro) data is impossible to turn off until a reboot.
  4. Applejack77

    Applejack77 Member

    Yes, I forgot to mention, have to reboot to stop it.
  5. robogo

    robogo Well-Known Member

    Well, I guess then it IS a bug :D
  6. Applejack77

    Applejack77 Member

    Just thought I would update this. The mobile data switches itself on when I send or receive a text message with picture attached (MMS).

    When I receive it, the data switches on and the attachment downloads, but the data is left on and switches itself back on if I try to switch it off.

    this is really annoying as I don't really want to reboot every time I am sent a picture.

    Is anyone else noticing this?
    Maybe it's specific to the 3 network?
  7. Sad Droid

    Sad Droid New Member

    Ive had this problem. Go to the market and download the free CurveFish APN OnOff widget. Junk the HTC widget and use the CurveFish one. Problem solved.
  8. itandy

    itandy Well-Known Member

    Just to share some of my experience on handling APN on/off in Hero. I've noticed sometime if the cellular reception is bad, the H sign will disappear and the phone will be unable to acquire a data connection again. And I'll be unable to disable APN with neither HTC widget nor through settings. Then the trick is to switch on airplane mode. As soon as airplane mode is on, switch it off. Then normally the phone will reconnect everything again. Hope this help.
  9. Sad Droid

    Sad Droid New Member

    Thats what I used to have to do, but enabling wifi. It didnt matter if I had good or bad reception. Since using the CurveFish APN widget its not been a problem, it turns on and off as it should.
  10. Applejack77

    Applejack77 Member

    Thanks Sad droid, I'll give this a go.
  11. croc9968

    croc9968 Active Member

    Just thought I'd add my thoughts.

    This (in my experience) only happens when you receive a MMS, the mobile stays on and the widget becomes non compliant. I have tried to turn on wifi when one is in range and this seems to cure it...any thoughts from anyone else?
  12. Sad Droid

    Sad Droid New Member

    This did seem to be the problem for me, though occasionally it wouldnt turn off even with no messages.

Share This Page