Unbranded Sony Xperia Z1 ROMGeneral


Last Updated:

  1. liverpoolfan

    liverpoolfan Well-Known Member

    Hi Guys,

    I am getting a new Sony Xperia Z1 on Monday as part of an upgrade. The ROM on it will be branded (Three Ireland).

    I would like to put the official Sony Xperia Z1 unbranded ROM on it.

    Is this possible without rooting?

    I believe Sony has instructions for unlocking bootloader, do I even have to do that?

    Sorry for all the questions. I am reading through a lot of threads here and just thought I'd post at the same time.

    Thanks in advance for replies.

    Advertisement
  2. breadnatty08

    breadnatty08 pain rustique VIP Member

    I'm not familiar with Sony phones but I imagine swapping the ROM out would definitely require rooting (and unlocking if need be).
    liverpoolfan likes this.
  3. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    It's very easy to unbrand without rooting, you can use something called Flashtool and flash an unbranded FTF file to put any official Sony ROM on there, no need to unlock the bootloader either.

    There's a list of ftf files here: [FTF] C6902 & C6903 & C6906 & C6943 FTF Mega Collection - xda-developers

    The latest UK unbranded is called "C6903 14.2.A.0.290 Generic UK 1276-0875 MIRROR".

    You should then be able to OTA to the latest version after installing that.

    Flashtool can be downloaded here: Flashtool | Xperia device flashing

    Instructions for Flashtool here: xda-developers - View Single Post - [TOOL][HOWTO]Flashtool 0.9.14.0 XZU + Guide + restore soft bricked devices
    nuffz and liverpoolfan like this.
  4. liverpoolfan

    liverpoolfan Well-Known Member

    Thanks very much - might give it a go.

    Final question...do I need to worry about radios ? Meaning Three Ireland may have particular radio for use with their network - if I flash that generic UK ROM will the phone still have the original radio flashed? Thanks.
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Radio/Baseband is included in the ftf file so you should be good to go.

    From what I can gather, all UK ftf's contain the same radio anyway so I don't think you'll have any problems.

    I've used a generic European FTF on my EE branded handset and it's made little or no impact on signal so I don't think it matters much.

    One thing to be careful of is not to include the TA partition in the flash (just add it as an exclusion in the exclude box).

    It's a relatively easy process, but shout if you get stuck.
    liverpoolfan likes this.
  6. liverpoolfan

    liverpoolfan Well-Known Member

    My Z1 is due to arrive today (the case from Roxfit arrived this morning)...can't wait.

    One more question.

    I've heard that unlocking the bootloader will stop the camera from working - is this true?

    Can I assume if I simply flash the UK unbranded ROM using the flashtool I should have no issues in this regard?

    Thanks in advance.
  7. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    It used to, but I think that was sorted when the 4.3 update was released. Kinda moot anyway as you can't unlock the bootloader on network branded handsets.

    Unless you want to install Cyanogen or an AOSP ROM, there's no real need to unlock the bootloader anyway.
    liverpoolfan likes this.
  8. liverpoolfan

    liverpoolfan Well-Known Member

    Happy to go with unbranded. Do I still need to exclude the TA partition? Even when flashing official Sony unbranded (no unlockbootloader and no root) ?
  9. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Yeah, restoring another TA partition on your handset is a pretty bad thing apparently.

    I always exclude it and I've never had any issues. :)
    liverpoolfan likes this.
  10. liverpoolfan

    liverpoolfan Well-Known Member

    Hi

    I followed the flashing procedure as indicated (for the UK unbranded ROM).

    However, my Z1 won't turn on now.

    I've tried the following

    1. Reset button in SIM tray.
    2. Pressing the power button with vol-down and then power button with vol-up.

    Is there anything else I can try?

    Flashtool does not recognise the phone when I connect with usb + vol-down/vol-up (it does not detect the phone).

    BTW the phone did reboot itself twice today for no apparent reason and also the battery was around 15% before I tried the flashtool.

    Any help would be appreciated.

    Thanks.
  11. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Does it register as charging when you plug it in to a wall outlet? Does the LED come on?

    Do you know what software version the handset was on before you used Flashtool?
  12. liverpoolfan

    liverpoolfan Well-Known Member


    I have it charging (or so I hope) but there is no LED.

    Not sure what software version, all I know is it is Android 4.2.2.

    Prior to flashing I excluded FOTA in the flashtool (I was doing this on a Mac).
  13. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    You can try charging overnight, but in most instances where the flashtool doesn't pick up the device, it needs to go back to the retailer/Sony. :(

    I wonder if the FOTA exclusion was the issue? TA and FOTA are 2 different things.

    Here's a screen shot from my flashtool below -

    Was there no TA option, just FOTA?

    [​IMG]

    Unless it was a bad ftf? I've done this 5 or 6 times and never had a problem so it's hard to say what went wrong.
  14. liverpoolfan

    liverpoolfan Well-Known Member

    Only FOTA, no TA option.
  15. liverpoolfan

    liverpoolfan Well-Known Member

    If it does have to go back to Mobile Operator and/or Sony...will they be able to see that an attempt at flashing with unbranded rom was made ?
  16. liverpoolfan

    liverpoolfan Well-Known Member

    Might try the following thread
  17. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    No, not as far as I'm aware. If they can't turn the device on, there's no real way of them telling you've done anything to the device.
  18. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

  19. liverpoolfan

    liverpoolfan Well-Known Member

    LED is flashing/blinking red while charging, plug into wall socket as opposed to extension lead (earlier).
  20. liverpoolfan

    liverpoolfan Well-Known Member

    Morning.

    After night on charge during vwhich led blinks red, the phone still won't turn on.

    Nothing with power + volume up/down either.

    Bricked?
  21. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Yep, by the sounds of things.

    Sorry. :(

    Like I say, I've done this numerous times without issue so no idea where the problem is.
  22. liverpoolfan

    liverpoolfan Well-Known Member

    Sent it off to be looked at. Guy shop could not power it on either (oh surprise).
    Said no visible damage so if cannot be fix then a replacement handset out to me next week.

    Think I'll leave the flashing alone for a bit.
  23. liverpoolfan

    liverpoolfan Well-Known Member

    New handset on the way.
  24. liverpoolfan

    liverpoolfan Well-Known Member

  25. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    I've never used the official Sony tool, but it looks as though you need an unlocked bootloader for it to work.
    liverpoolfan likes this.

Share This Page