Unbrick Phone from LG Screen


Last Updated: 2014-01-11 21:26:41
  1. dajonsworld

    dajonsworld New Member

    joneidy,
    u friiggin r.o.c.k. !!!!!!! let me explain ......about five days ago i was tweaking (fine tunning, overclocking) my optimus m i was running a custom rom and just finishing up cleaning my sd card and userspace on the phone when i decided to see if i could get just a lil more outa her and decided to raise the cpu speed in 15 mghz intervals when it just shut down Like a brick with lights .........i actually cried it was my baby i llovrd that phone but not one to give up i started scouring xda and andforums and there it was and here i am 4.5 hours later yeeahaa.....oh and just a lil cross eyed .........luv it ,luv it, luv it, thank you soo much and as soon as i find a job i will be donating ........not the first time you and others on this site have saved my arse. THANK YOU FOR ALL YOUVE DONE......signed " theearth"

    Advertisement
    blueberryms likes this.
  2. Animegamer612

    Animegamer612 Member

    I was stuck with brick at LG logo screen. I followed the post up to the point of running lgspt. I get the dll in and the bin in but once 60% is complete it errors out. It says erase fail. I cant it any further than that what can I do. I tried removing sd card, i tried rebooting the lgspt system. Please help phone is still bricked and I dont have another one.
  3. 209carlos

    209carlos Member

    Can someone please Please PLEASE!!! make a video on how to do this. Im such a noob, and am more of a visual learner. Ill greatly appreciate it.
  4. gonzalezebra

    gonzalezebra New Member

    You are the best! It worked like a charm! I'm saved!
  5. 209carlos

    209carlos Member

    Nvrmind i got it, after several attempts and uninstalls an reinstalls i finally got it. For those who are running Windows 7 or Vista and are having trouble in finding and selecting the MS690.dll on LGNTPS, make sure that when your installing LGNTPS and get to the point to register the MS690.dll that you first right click on the Reggie.exe go to properties and under the Compatibility tab Check the "Run this program in compatibilty mode for" box and select "Windows XP (Service Pack 3)" Hit Apply and OK and that should do it. Thank you so much Joneidy for this post .
    olo Malice olo, nemo510 and MissD like this.
  6. j4mes_3ondoo7

    j4mes_3ondoo7 New Member

    Thanks alot Joneidy once again your the bomb :) restored my phone back from a paperweight now to restore service to it :)
  7. papichulo916

    papichulo916 Well-Known Member

    so everytime i try to register the ms690.dll this comes up:

    HRESULT == 0X80020009
    Exception occurred.

    so when i go ahead and try to select the ms690.dll file from the dll in lgnpst it's not there except for C:\LG Electronics\LGNPST\Components 2.0\LGNPST_Utility2.dll

    what am i doing wrong?
    aiwass13 likes this.
  8. papichulo916

    papichulo916 Well-Known Member

    oh thank you! that's what i was missing
  9. maller

    maller New Member

    hi
    as i was in emergency mode for quite some time, i unplugged the phone and since then it's completely dead..
    it doesn't even charge..
    any ideas???
  10. So i bricked the phone using that damned "rom manager" (if i ever get this phone to work im writing him a scolding review) so i get to the part where i select the dll...well it wont let me recover the phone it only lets me "phonebook recovery" so im in need of some help before my gf finds out i bricked my phone and hers.


    sorry wrong about that. it asks for the dll but not the bin. its looking for a PB file......dude im with mikekelso421 and about to just shoot this phone.
  11. younggoon727

    younggoon727 Member

    ok i tried rootin my phone and took out my normal sms that came with the phone bcuz i only use handcent but now my pic msg wont work cant send or receive if u can help younggoon727@gmail.com
  12. derrabe

    derrabe Well-Known Member

    Ok Im stuck and really could use some help, I called metro pcs and got my mdn, min and sid numbers and have them programmed. Then my esn and meid was all 0's so I went to the link posted earlier and used qpst to input those. I now have all the information appears to be correct but I am stuck in searching for service mode still. When I go into phone in menu I get
    Code (Text):
    1.  
    2. sw version ms690zv4
    3. PRL Version 65535 (which I am pretty sure is supposed to be 3019 or 3020)
    4. ERI Version is 1003
    5. STATUS MENU
    6. Mobile Network Type - Unknown
    7. Service State - Out of Service
    8. Roaming - Not roaming
    9. Mobile Network State - Disconnected
    10.  
    Any help on getting this to work would be great
  13. derrabe

    derrabe Well-Known Member

    Ok I got it to work I just used the same too that I did to flash it to upload the latest prl file and then used the all 0's guide and everything is fully functional again.
  14. AndroidHogs

    AndroidHogs Well-Known Member

    Does anyone have the full lgnpst.executive and driver download for ms690??
  15. tripdoc79

    tripdoc79 Well-Known Member

    just some info.. maybe something to try b4 using the lgnpst method.. i recently helped a guy unbrick his phone in this method.. granted.. this is really only helpful if ur planning on flashing a rom or have flashed a rom and have a backup.. but when ur phone is stuck on the lg screen, plug it into ur computer and see if it is listed as a fastboot device in your device manager.. if so you and u can copy either joneidys recovery or the getitnowmoarketing recovery to your sd card if not already there, via a microsd card reader, or another phone with sd.. you can use fastboot to flash the recovery image to your phone and then reboot into recovery.. if you have a backup you can restore it.. if not u can flash to a new rom.. this will however not do anything for people on stock and trying to get back to stock. you first have to download fastboot and then using the command prompt navigate to the fastboot folder and the command is: fastboot flash recovery recoveryimagenamehere.img when thats done.. pull your battery and hold home+vol down and power to boot to recovery

    this will get you to recovery mode

    EDIT: if your phone doesnt show up in the device manager as a fastboot device, make sure u have the phones drivers installed.. also if still not showing as a fastboot device,, try holding back+vol down and power to force it into bootloader mode from power off
  16. toke_

    toke_ Well-Known Member

    hi i had bricked my phone using rom manager and i ended up buying another one but now i read this thread so i figure i might as well see if itll work. so this is what ive done so far. downloaded the lg drivers (even tho when i plug my working phone in to the computer is doesnt show up in LGNPST) then i let my battery die at boot logo screen. now i pressed all the buttons and pluged it in and its at the s/w upgrade screen, then i plugged it in to the computer and the computer tries to install driver from windows and it says "instert disk" which i dont have cuz neither one of my phones came with a disk. and the LGNPST isnt showing up the phone under emergency. Please help
  17. derrabe

    derrabe Well-Known Member

    I would just point it to the location of where you put the drivers you downloaded and see what happens
  18. toke_

    toke_ Well-Known Member


    just tried that, still said "could not find drivers" or whatever. im uninstalling all lg drivers and installing agian. hopefully it'll work
  19. toke_

    toke_ Well-Known Member

    okay so i got the LGNPST to recognize the phone under emergency and i selected the .bin file but i cant find MS690.dll . The only .dll file that appears is LGNPST_Utility2.dll . Do i need to download MS690.dll or how do i find it?

    *note- i already tried with LGNPST_Utility2.dll and it said error, so i guess i NEED the MS690.dll.

    *edit - i found MS690.dll. But its under Model/MTP . when i click to add a .dll in LGNPST this .dll doesnt show up. still need help being able to select MS690.dll in LGNPST
  20. joneidy

    joneidy Well-Known Member

    You need to register the .dll file. Just drop it on top of reggie.exe. And it will be visible on LGNPST.

    PS Make sure to have Adminitrator rights when dropping the .dll on top of reggie.exe.
  21. toke_

    toke_ Well-Known Member

    i dropped it on reggie.exe and i got this


    HRESULT == 0x80020009

    Exception occurred.


    And the only thing i can click is Okay. After i click Okay , a couple new things pop up in the MTP folder. And the .dll is still not available in LGNPST


    *edit - I dont know if this helps you at all but when i hover my mouse over MS690.dll it says "File description: LGNPST_MS690 Module" If LGNPST is under the file description I would think it would be registered in LGNPST but it still doesn't show up
  22. joneidy

    joneidy Well-Known Member

    You are getting that error because you don't have full admin privileges. BTW what windows are you running?
  23. toke_

    toke_ Well-Known Member

    im not sure what you mean by full admin, but im running windows vista, and i am the administrator user. What do i need to do for it to work?
  24. macjay420

    macjay420 Well-Known Member

    Thanx joneidy.....I just had to do my phone up with this....


    ...o yea two things. You dnt have to hold down the camera just the other 3....and also you dnt have to wait for the battery to die. Pull the battery out hold the buttons then plug it in....pop the battery back in un plug and plug into the computer....thanx agin you just saved my phone
  25. toke_

    toke_ Well-Known Member

    Still need help getting MS690.dll registered so I can select it on LGNPST

Share This Page