Unfortunately, Google Play has stopped.Support


Last Updated:

  1. CargoMatatu

    CargoMatatu Well-Known Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    148
    Likes Received:
    16
    Upgraded my S2 from ICS to JB last night.

    Since then the pop up warning "Unfortunately Google Play Store has stopped. Okay." keeps appearing and the phone is sort of frozen for the next ten to fifteen seconds.

    Anybody know what this is all about?

    Thanks,
    John
     

    Advertisement
  2. superflyguy

    superflyguy Member

    Joined:
    Feb 22, 2013
    Messages:
    10
    Likes Received:
    2
    Try removing your google account then adding it again
     
  3. CargoMatatu

    CargoMatatu Well-Known Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    148
    Likes Received:
    16
    How do I do that?

    Sorry, but you're talking to a techno-moron here!
     
  4. scotty001

    scotty001 Well-Known Member

    Joined:
    Nov 20, 2010
    Messages:
    59
    Likes Received:
    16
    Before you do make sure you remember your google password !!!! you will need it to re add the account.

    On the home screen click the left hand hardware button (next to the middle home button)

    On the pop-up press settings

    Scroll down to "personal" Accounts and Sync and press that
    now you will see your accounts and you should see one that has the Google symbol and you Google user name

    Press that icon and then it will show the options for the account, right at the bottom right you will see "Remove account" (next to Sync now) click on remove account.

    You will have another pop-up with remove account and cancel, click on remove account.

    To add the account again i personally restart the phone then re go through the steps to get into the accounts and sync page.

    this time press "Add account"

    scroll down to google icon and press that icon

    now press Existing

    enter your user name and password followed by sign in .
     
    CargoMatatu likes this.
  5. CargoMatatu

    CargoMatatu Well-Known Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    148
    Likes Received:
    16
    Thanks, Scotty.
    I have followed those steps and will see what happens.

    Funny thing, I got that same pop-up warning about two thirds of the way through the process, but I reckoned it was appropriate!
     
  6. CargoMatatu

    CargoMatatu Well-Known Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    148
    Likes Received:
    16
    It seemed to be okay for about four hours, but has just done it again! Aaargh!
     
  7. CargoMatatu

    CargoMatatu Well-Known Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    148
    Likes Received:
    16
    So I tried the same process again, but this time slightly differently.

    First, delete account; wait five minutes; shut-down phone.

    Second, wait five minutes.

    Third, start phone; wait for it to stabilise; add account; wait five minutes; shut-down phone.

    Wait five minutes, restart phone.

    Problem still there! :-(((
     
  8. kelis32

    kelis32 Well-Known Member

    Joined:
    Dec 25, 2012
    Messages:
    303
    Likes Received:
    64
    Are you on a custom ROM ? how did you upgrade ?

    Try installing the latest apk

    com.android.vending-3.10.14.apk | by Android Police for Generic Device
     
  9. CargoMatatu

    CargoMatatu Well-Known Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    148
    Likes Received:
    16
    No custom ROM, no rooting, nothing. As I said earlier I am a techno-moron so everything is basic with me!

    I got a push notification from Samsung that a firmware upgrade was available, so I connected my phone to Kies via my pc and the update then took place in the normal Kies way.

    My firmware is Hong Kong as I bought it from the duty free while passing through there eighteen months ago.

    The previous upgrade from GB to ICS was done the same way and went absolutely smoothly.

    My phone's details:

    Model number
    GT-I9100

    Android version
    4.1.2

    Baseband version
    I9100XXLS8

    Kernel version
    3.0.31-863962
    SMP PREEMPT Wed Jan 30
    22:39:02 KST 2013

    Build number
    JZO54K.I9100ZSLSH
     
  10. kelis32

    kelis32 Well-Known Member

    Joined:
    Dec 25, 2012
    Messages:
    303
    Likes Received:
    64
    You could try to see if you can uninstall the updates to the store, it should go back to the market app and then reinstall the updates

    Settings > App Manager >All >Select Google Play Store and Click on Uninstall Updates Button

    Clear data while you are there as well
     
    CargoMatatu likes this.
  11. CargoMatatu

    CargoMatatu Well-Known Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    148
    Likes Received:
    16
    That worked! :)))

    Thanks, all, for your help.
     
  12. SailorShadow

    SailorShadow New Member

    Joined:
    Apr 19, 2013
    Messages:
    1
    Likes Received:
    0
    Ty Man You Were Really helpful <3
     
  13. amitv08

    amitv08 New Member

    Joined:
    Apr 25, 2013
    Messages:
    1
    Likes Received:
    0
    I have SGS-I9000.
    Android Ver- 4.0.3
    Baseband - I9000XXJVT
    CyanogenMod - 9.0.0-RC0-galaxysmts-KANG

    Tried
    1. Uninstalling Play update
    2. Removing and adding back the a/c

    Nothing worked

    Please suggest
     
  14. Mrpapagiorgio

    Mrpapagiorgio New Member

    Joined:
    Jun 16, 2013
    Messages:
    1
    Likes Received:
    0
    I had the same issue. What I did was uninstall the play store updates and than it worked fine again after it updated itself again
     
  15. targaid

    targaid New Member

    Joined:
    Oct 27, 2011
    Messages:
    3
    Likes Received:
    0
    I got the same thing, apparently it's very common. Unfortunately I had to factory reset to get it to stop :-(
    It seems very odd that Google allowed an update to their os that was incompatible with some of their apps. I actually had several that were crashing, not just the Play store.
    Glad you found a simple solution.
     

Share This Page

Loading...