uninstall superuser


Last Updated:

  1. itsferny09

    itsferny09 Member This Topic's Starter

    Joined:
    Sep 10, 2011
    Messages:
    18
    Likes Received:
    2
    can not seem to uninstall the superuser app
    my phone is no longer rooted but i cannot seem to uninstall the logo
    and its in my application settings i have tried a factory reset and no luck
    any help?
     

    Advertisement
  2. DaddyZap

    DaddyZap Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    263
    Likes Received:
    27
    did you check too see if your still rooted ? does SU still open ?
     
  3. sik00

    sik00 Well-Known Member

    Joined:
    Dec 17, 2011
    Messages:
    276
    Likes Received:
    135
    From another site, maybe it will help..

    Use root explorer and delete superuser.apk from the /system/app folder. Go to the Android market and download and install super user. Use root explorer again and delete su from /system/bin. Go to the market and uninstall super user.

    Do a factory reset & you will be back to square one.

    Link:
    How to Root Sprint LG Marquee - LG Cell Phones Blog
     
    FloRida1999 likes this.
  4. itsferny09

    itsferny09 Member This Topic's Starter

    Joined:
    Sep 10, 2011
    Messages:
    18
    Likes Received:
    2
    i rerooted be phone and now i need to unroot it to send it back
    i used root unistaller
    and still didnt work
     
  5. itsferny09

    itsferny09 Member This Topic's Starter

    Joined:
    Sep 10, 2011
    Messages:
    18
    Likes Received:
    2
    did all of that but stuck on uninstalling superuser
     
  6. itsferny09

    itsferny09 Member This Topic's Starter

    Joined:
    Sep 10, 2011
    Messages:
    18
    Likes Received:
    2
    i did it
    this is what i did:

    Use root explorer and delete superuser.apk from the /system/app folder. Go to the Android market and download and install super user. Use root explorer again and delete su from /system/bin. Go to the market and uninstall super user. (if it keeps saying uninstalling for 1 min or more restart phone and it should be gone)
     
  7. sik00

    sik00 Well-Known Member

    Joined:
    Dec 17, 2011
    Messages:
    276
    Likes Received:
    135
    Glad to hear it worked :)
     
  8. agentc13

    agentc13 Daleks Über Alles VIP Member

    Joined:
    Aug 31, 2011
    Messages:
    7,916
    Likes Received:
    5,482
    Moved this to the All Things Root sub-section ;).

    Also added to the All Things Root Guide :D. Thanks sik00 for the tip!
     
  9. DaddyZap

    DaddyZap Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    263
    Likes Received:
    27
    Correct me if I'm not wrong, but you need to be rooted in order to use root explorer. Hence your still rooted. I'm not sure about about LG but I have sent rooted phones with custom roms on them to Samsung for warranty service which they have provided with no problems.
     
  10. sik00

    sik00 Well-Known Member

    Joined:
    Dec 17, 2011
    Messages:
    276
    Likes Received:
    135
    Root explorer does require root. The problem I think is that superuser is not able to be uninstalled if it's installed during the root process, as opposed to being installed seperately. I think this is even stated in the market description for superuser.

    If I'm understanding it right..it seems like superuser is being deleted while root privileges are still active, then it is being installed "seperately" from the root when downloaded from market. After that, you should be able to delete it, then do the factory reset to erase traces of it.

    I've never had to send a phone into LG, so I'm not sure about their policies on rooted phones. If I ever had to take mine in, though, I would more than likely uninstall superuser myself, so there would be no questions.
     
  11. DaddyZap

    DaddyZap Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    263
    Likes Received:
    27
    How did you go about unrooting this phone ?
     
  12. m7nba

    m7nba Active Member

    Joined:
    Mar 13, 2012
    Messages:
    40
    Likes Received:
    0
    I did what people say deleted the superuser.apk and su.apk then did a factory and master reset but when i go to google movies it says this wont work because your device is rooted?
     
  13. LordDarkness

    LordDarkness New Member

    Joined:
    Jul 2, 2012
    Messages:
    2
    Likes Received:
    0
    Hey guys I don't mean to make this go on and on, I will admit to this I am a noob, but I been trying to uninstall the superuser, I have both looked on this forum as well XDA and you both seem to have the same instructions for deleting it. I will be honest, in no way able to purchase the root explorer at this time, but I did download Astro File Manager.

    What happen was I followed a video on youtube of someone who reviews all of boostmobiles phones listed here:

    How to ROOT Boost Mobile LG Marquee note: since I am cannot post links due to being new user I will just say go to youtube, and in the address bar after dot com. type /watch?v=xOtRkNgRnKg and it should take you there. I promise I am not posting spam.


    So when I rooted the phone, I checked it and it was rooted. About a month after that there was an update, and well before I knew it, supposedly if this makes sense to anyone, it was not rooted anymore, but google movie said it was since I could not get it to function right.

    I was having issues with my phone and was to through support factory reset twice two different times. well supposedly google movies works, and the checker shows its not rooter, but yet superuser is there still, cannot uninstall the normal way.

    Another step I took was to use the Astro File Manager, in which I navigate to documents/system/app folder I begin to look for the superuser.apk In astro I touch and hold then options on left come up to copy, move, rename, delete, and so forth, I choose to delete and then confirm it, problem is it is in process to delete their I get an this message "error deleting files" I go to try and reinstall is maybe thinking that is the issue, still can not get rid of it.

    I am wondering what other options are possible at this point. Any advice would be appreciated. Thing is from what LG told me rooted phones are not covered in warranty, with that stated, I wanting to make sure my phone is not rooted for when I send it in, due to the battery over heating time to time.

     
  14. 175805

    175805 New Member

    Joined:
    Jun 26, 2012
    Messages:
    1
    Likes Received:
    0
    when i try to delete super user from the system/app folder with root explorer i get and message saying delete failed what should i do?
     
  15. Tim Swann

    Tim Swann New Member

    Joined:
    Dec 5, 2011
    Messages:
    4
    Likes Received:
    0
    This worked like a charm. Thanks!
     
  16. yajur1995

    yajur1995 New Member

    Joined:
    Aug 20, 2012
    Messages:
    2
    Likes Received:
    0
    even im facing the same problem...as soon as i hold su and press delete it says that it cannot be deleted cause the file is ready only...help
     
  17. sik00

    sik00 Well-Known Member

    Joined:
    Dec 17, 2011
    Messages:
    276
    Likes Received:
    135
    Mount /system as r/w
     
  18. yajur1995

    yajur1995 New Member

    Joined:
    Aug 20, 2012
    Messages:
    2
    Likes Received:
    0
    deleting superuser from root manager did not help me...but instead i tried downloading apps to sd pro...after that try to uninstall superuser by that [NOTE:- DOING THIS WILL NOT DELETE THE ICON FROM THE APP DRAWER...]
    then try unrooting your phone...the su icon should have been gone by now (it did in my case)...you can try factory reset just to be sure..


    I REALLY HOPE IT HELPS YOU :)
     
  19. Perseus71

    Perseus71 New Member

    Joined:
    Oct 21, 2012
    Messages:
    1
    Likes Received:
    0
    Sik00, first off thanks for posting this method. I will keep it in mind next time I run into this issue.

    In my case, I have a Android Tablet running Jellybean 4.0.4. What happened was that I installed most recent version from the Market available. Lo and behold! I immediately lost root. I know for a fact I had it rooted before. Root Checker confirmed before and after. Later XDA threads and threads here confirmed it.

    So I tried different things but finally flashed my ROM image again to get my root back.

    My point here is this. Like you said, if you still have root then the method you posted works. But I had installed the SuperUser separately from the market. I couldn't uninstall it. I did not try Root Explorer but tried ES Explorer instead. Since it was not able to get root privileges, I was not able to delete superuser.apk from /app/bin let alone su from /system/bin.

    On a separate discussion, people did admit Superuser has a issue with Jellybean. Some suggested, going into Superuser's preferences and clicking auto response approval helps. I tried and didn't work.

    Anyway I reflashed and now good. Warning for others. If you have ICS or Jellybean, don't use Superuser unless it came with the image. If possible make a NAND backup before installing Superuser.
     
  20. ChickenMonkee

    ChickenMonkee Well-Known Member

    Joined:
    Jan 11, 2012
    Messages:
    171
    Likes Received:
    15
    Worked for me!!! Only thing is 2nd step: Delete su from /system/xbin not /system/bin
     
  21. pH2Oville

    pH2Oville New Member

    Joined:
    Apr 22, 2013
    Messages:
    1
    Likes Received:
    0
  22. obzilla

    obzilla Member

    Joined:
    May 19, 2013
    Messages:
    7
    Likes Received:
    1
    Hi all, first time poster and first time messing with android rooting (please be kind!)

    I recently purchased a second hand Galaxy S3. The previous user had root access. Stupidly; on getting the phone I went into super user and selected unroot and uninstalled Superuser after performing a factory reset thinking it was just as easy as that to unroot the device. Then I went to update software and got told my device is modified.

    I reinstalled super user but then get told the SU bin is not found. I got the SU bin but cant put it in the bin folder as I don't have permission (ES file explorer says its read only folder).

    I have 3 options in my head:

    1 - Get SU working then remove all root access then update to android 4.2 (currently on 4.1.2)

    2 - Switch to a Cyanogenmod or something based on 4.2 (not sure if this is possible with the current level of root access I have/don't have I can boot in recovery mode and it says install from zip but I'm reluctant to do this then get halfway through and not have the permission I need and get stuck with a useless brick).

    3 - live with the phone as is (it crashes randomly)

    CWM is installed but cannot run as it says SU is not installed.

    thanks for any help or understanding you can provide.
     
  23. dip2326

    dip2326 New Member

    Joined:
    Aug 30, 2013
    Messages:
    1
    Likes Received:
    0
    hi guys,
    usinstall superuser using RootAppDelete application...go to system app and uninstall super user....it really works....
     
  24. drawolf2001

    drawolf2001 New Member

    Joined:
    Nov 6, 2013
    Messages:
    1
    Likes Received:
    0
    I cant find the su folder in my system data.
     

Share This Page

Loading...