"Unkown artist" for some of my albums


Last Updated:

  1. Jeffery

    Jeffery Well-Known Member This Topic's Starter

    Joined:
    Nov 7, 2009
    Messages:
    526
    Likes Received:
    61
    I have about 13GB of music on my SD card. A few of the albums show up as "Unkown artist" (everything else is correct: song name, album name, album art). It is kind of annoying.

    Anyone else have this problem. I have spent a lot of time tagging my music. I know my music is tagged correctly b/c it works just fine in Winamp, iTunes, iPod, Songbird, etc.

    Please Help!
     

    Advertisement
  2. istolvampire

    istolvampire Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    503
    Likes Received:
    35
    I had this problem with a few albums also. Finally bit the bullet and got the app ALBUM ART GRABBER. Solved all my problems in seconds.
     
  3. Jeffery

    Jeffery Well-Known Member This Topic's Starter

    Joined:
    Nov 7, 2009
    Messages:
    526
    Likes Received:
    61
    Thank you istolvampire, but I had already tried that. This evening I d/l mp3tagger for Droid. When I used the program and loaded a song it displayed the correct artist. So, I tried saving that song without ANY modifications. I then went back to the Music player and now that song was correctly listed under the artist with the rest of the album under unknown artist.

    I don't understand what the deal is. I really don't want to waste time loading and saving all of the songs that are showing "unknown artist" using the phone, especially when there should be no problem.

    aarghh...
     

Share This Page

Loading...