Unlock Using HTCDev.Com?

Last Updated:

  1. 1st_Paladin

    1st_Paladin Well-Known Member


    Had a go using HTCDev.Com to unlock my Desire S. However go an error message and was unable to get the OEM token. Has anyone encountered this issue and managed to resolve it? As I understand it, the took will unlock unlock the phone and keep it as S-On but will allow flashing of recovery, HBoot and ROM. I could be wrong on this.

    Many thanks.

  2. notebook

    notebook Well-Known Member

    Is there a chance your IP address changes during the bootloader process? It needs a constant IP address throughout.

    Make sure you DO NOT enter the INFO or prefix string for your token.

    Some HBOOT versions aren't compatible with the tool. For the Desire S, the bootloader will currently only work with versions 2.*, not lower.

    You're correct in that, if successful, the phone will remain S-ON, but will be flashable and allow root, etc, although, to change the radio, you'll need to install an S-OFF HBOOT.
  3. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks notebook. The error message I'm getting is

    (bootloader) [ERR] Command error !!!

    As mentioned, I'm not able to get the token. Just the above error message. My IP address is stable as I'm using static IP.

    Are there any advantages of S-On versus S-Off?
  4. notebook

    notebook Well-Known Member

    I don't know what that error refers to in the context of your phone. Can you give us the software version and the first 4-5 lines of your HBOOT screen?

    Ordinarily with S-ON, you can't do anything to your phone's ROM as it's fully locked down (except use an RUU). But, with the bootloader provided by HTC, you can then go on to change the HBOOT, recovery, ROM and gain root with other tools. As far as I know, the radio will remain locked unless you change to an S-OFF HBOOT version.
  5. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks notebook. Here you go.

    Mar 30 2011, 17:29:31

    This the error message I get
    C:\android\tools>fastboot oem get_identifier_token
    ... INFO[ERR] Command error !!!
    OKAY [ 0.016s]
    finished. total time: 0.016s

    I've also tried it with USB Debugging on and off.

    Many thanks for your help.
  6. FoX777

    FoX777 Well-Known Member

    To my understanding it will only work with hboots that are v2 and up. anyone else can any confirm 100%?
    1st_Paladin likes this.
  7. notebook

    notebook Well-Known Member


    As Fox777 says, the HTC bootloader will only work on HBOOT 2.* versions, hence the error.
    1st_Paladin likes this.
  8. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks notebook. Is there a way to upgrade to HBoot 2.*? Any pitfalls to note? No pun intended
  9. notebook

    notebook Well-Known Member

    Yes, it's possible to upgrade to 2.* from any other HBOOT, but the process is not quite straightforward, i.e. you need 'adb'. Apart from it being the most recent version, I'm unsure as to the benefits of HBOOT 2.*.

    It has a different partition table, but I think this is only useful with the stock ROM at the moment. It was also the case you needed the 2.* HBOOT to access the new Sense 3.0 and 3.5 kernels, but that can now be done with older HBOOTs. Maybe there's more compatibility with the Sense 3.0/3.5 ROMS/kernels, but I haven't seen anything that suggests this yet. Perhaps developers will figure out the advantages of the HBOOT 2.* and build a ROM to exploit them.
    1st_Paladin likes this.
  10. edwardbp

    edwardbp New Member

    Hi folks, I'm running 2.4 and getting the same error message. I've wasted my entire day trying to unlock my Desire Z and only now found out that HTC has made it so easy for us. But now, this darn error at command. I should note that I've been trying to run the HTC token search from the platform-tools folder in SDK, rather than moving the items to a different folder (seemed pointless). Could this be the problem? Thanks so much for your help with this!

Share This Page