Unlocking Question

Discussion in 'Android Apps & Games' started by cyberbob25, Jul 8, 2009.

  1. cyberbob25

    cyberbob25 Well-Known Member
    38

    Feb 16, 2009
    183
    11
    38
    I know that this probably isn't the best forum to ask this, but I've seen from my lurking about that everybody here is very friendly and helpful.

    To start, I have a G1 in the US with TMobile, running the JesusFreke 1.51 firmware.

    I found out today that I need to leave for Europe later this afternoon. I've read in several places that TMobile will unlock the G1 so that a SIM card from a different carrier can be used after a certain time frame of having the phone, but I can't remember what that time frame is. My first question is, do I even need to get it unlocked, or does the JesusFreke firmware in essence already do this? If not, I'm assuming that I need to physically visit a TMobile store to have this done?

    Also, as long as I am typing up a new post, I will bring up another issue that I've been having (I can break this out into a separate thread if it is so desired). For some reason, the vibrator on the phone stopped working for notifications. It still vibrates on an incoming call, it still vibrates with the alarm, it even vibrates sometimes in a couple of games, but I cannot get it to vibrate when I receive a new email or SMS. For email, I am using K9, and for SMS, I'm using SMS Popup and ChompSMS. I've tried the vibration settings in both SMS programs (hell, I've even tried using the stock messaging application) with no luck. In fact, it doesn't even vibrate when you go into the vibrate pattern menus and scroll through the different patterns (I know it used to).

    This stopped suddenly as well...there were no updates performed at that time, and as far as I remember, no other applications were installed either. Any ideas?

    Sorry for the long windedness.
     

    Advertisement
  2. justjimjpc

    justjimjpc Premium Member
    VIP Member
    653

    Nov 3, 2008
    10,543
    210
    653
    Washington DC, USA
    Re: Your vibration issues ....
    Sounds like you probably have a conflict from running two SMS programs at the same time ...so neither is properly able to control ...
    Uninstall both and Power off phone ... Restart the phone and confirm that the Default vib works on Notification of SMS ..
    Then reinstall SMS PopUp and Power off phone ... and enable vib and try again ... if all goes well then and Power off phone ... re-install Chomp and try yet again ... if you dont get vib ..then you have found your problem ...

    I run SMS and have no problem ... so it is probably trying to run both at the same time ... or both or trying to get contol ... if you can set only one to do the Vib notification...
     
  3. cyberbob25

    cyberbob25 Well-Known Member
    38

    Feb 16, 2009
    183
    11
    38
    In my troubleshooting, I have not yet tried to uninstall both applications, so I will do that next. I do currently only have SMS Popup set to provide notifications: both the built-in messaging application and ChompSMS have notifications disabled (I had only enabled them temporarily in my troubleshooting). What's strange is that this setup was working fine for several months...no idea why it stopped.

    I will try uninstalling next and see where that takes me. Thanks!
     
  4. justjimjpc

    justjimjpc Premium Member
    VIP Member
    653

    Nov 3, 2008
    10,543
    210
    653
    Washington DC, USA
    When you power down ... even pull the battery for about a minute as well this has been know to clear many funky issues ...
     
  5. cyberbob25

    cyberbob25 Well-Known Member
    38

    Feb 16, 2009
    183
    11
    38
    Well, to answer my original question, using the JesusFreke firmware does not get around the TMobile simlock. However, getting this removed was as simple as calling Tmobile and having them send an email with the unlock code, no questions or problems.

    Haven't had a chance to play around with the vibrate problem any further yet.
     

Share This Page

Loading...