Unregistered Sim Problem - afraid that it might be stolen (Rogers)Support

Last Updated:

  1. Dusk992

    Dusk992 New Member This Topic's Starter

    Aug 14, 2013
    Likes Received:
    Hello there,
    So I got a USED Galaxy S4 from someone on kijiji
    The phone is from rogers, and still locked to rogers/chatr

    Iv been using the phone for about two weeks with no issues at all.
    Last week, just in the middle of the day
    I was taking the phone out of my pocket, and I noticed that it says ' unregistered sim'
    On the lock screen and status bar
    Tried to restart the phone and pull out the battery, nothing happened. Tried a NEW chatr sim card- no luck.
    Went to rogers yesterday, tried 4 different sim cards
    Didnt work.
    I stuck with the "unregistered sim" msg, which not allows me to use the phone.
    I tried to look for an answer around the net, and couldnt really find someone who have a similar issue.
    Any ideas?
    Is the phone might be stolen?
    Is therr anything to do about it?
    Thank you!

  2. SebaKL

    SebaKL Well-Known Member

    Oct 4, 2011
    Likes Received:
    Could you check your network setting and make sure it's not set to certain network mode only?

    System Settings - Connections - More Networks - Network Mode.

Share This Page