Unrevoked 3.3 worked, got S-OFF, but no "su"


  1. DAE51D

    DAE51D Well-Known Member

    New Evo user here (from PalmOS).

    I ran Unrevoked 3.3 and all went well. I installed Titanium backup, Move2SD (unlock for root), a WiFi Tether app and a few others that would require "root" and they all work fine. :D

    Then I tried to remove the Sprint bloatware, and am unable to get "su" from 'adb'. It tells me "Operation not permitted". :confused: What's the deal? How do I fix this? (I am linux savvy BTW)

    I did NOT run unrevoked_forever.zip -- should I? I've booted into the HBOOT a few times and it always says S-OFF, so does that mean I'm already rooted forever?

    Advertisement
  2. DAE51D

    DAE51D Well-Known Member

    I got impatient and installed unrevoked_forever.zip. This also ran flawlessly and without any errors.

    I then "adb kill-server" and restarted it. Ran "adb shell" and got the same "Permission denied" error. THEN I swiped the lock screen down on my Evo and noticed there is a prompt to give super user access. I re-ran "adb shell" and this time I got the lovely "#" prompt! WOOO HOO!!! :D

    So I post this to help other "newbs" like me. I think the instructions make an assumption that people know to check/confirm ON THE PHONE the prompt. The instructions make no mention of this as a step to do.

    Note - it's entirely possible this root "#" prompt could have been prompting me BEFORE "unrevoked_forever.zip" install too

    ...now to remove all the Sprint crapware! YEAH!
  3. akazabam

    akazabam Well-Known Member

    Hehe, it's always the simple things, isn't it? Had you not figured it out, I would have suggested you try to get su from a terminal emulator on your phone. You would have gotten the prompt right away that way, too.

    Just to confirm your unrevoked-forever question, s-off is full root, which you already had. There was no harm in rerunning unrevoked-forever (which ran as a part of unrevoked3), though.

    I have no idea how much reading you've done on removing bloatware, but I will say, you should consider freezing them with titanium backup, first. If you really want to remove it, instead of completely deleting it, you should move what you want to the sdcard in case a) you want it back later or b) you remove something you shouldn't have. Also, make sure you only remove stuff on the list of safe bloatware to remove from the rooting for dummies thread.

    One last thing - I assume you like the idea of using the terminal from your computer. If you'd like an easier solution than adb (even though you obviously already have it set up), I use quick sshd running on the phone with putty on my computer. It works really well.
    DAE51D likes this.
  4. ovrrdrive

    ovrrdrive Well-Known Member

    I took the easy way out and flashed a rom that had it already removed. End result is the same. :)
  5. DAE51D

    DAE51D Well-Known Member

    I don't see "quick ssh" on quick ssh - Search Android Apps on AppBrain can you tell me where you got it.
  6. akazabam

    akazabam Well-Known Member

  7. chrischoi

    chrischoi Well-Known Member

    Just download the Super User app. Or flash a ROM, like above said. Works fine.
  8. ftumph

    ftumph New Member

    This is brilliant! Thanks for posting the solution. I've been googling off and on all afternoon trying to figure this out. You are correct that you don't need to install Unrevoked Forever. I simply have Unrevoked 3 on my Incredible, and I now have su working thanks to your tip.

    I just ran the Superuser Permissions app, hit menu, opened Preferences, and enabled Notification. The next time I tried su it prompted me on the phone to allow it.

    Now to remove all the Verizon crapware! YEAH! :)

Share This Page