unrEVOked error: "am reported error starting service"


Last Updated:

  1. marker580

    marker580 Member This Topic's Starter

    Joined:
    Jan 1, 2011
    Messages:
    5
    Likes Received:
    3
    So I picked up an HTC Aria yesterday, my first Android. Naturally, the first thing I want to do is root it.

    I found the instructions for rooting via unrevoked and followed them to the letter. Running unrevoked goes perfectly until the end, however, where I get this error:

    Internal error: am reported error starting service

    I looked around, but haven't found anything on this (besides this).

    Any ideas?
     

    Advertisement
  2. baelinc

    baelinc New Member

    Joined:
    Jan 1, 2011
    Messages:
    1
    Likes Received:
    0
    I am having the same problem. I followed all the instructions and when android restarts I get the internal error: am reporting error starting service as well.
     
  3. mpc05

    mpc05 New Member

    Joined:
    Jan 1, 2011
    Messages:
    2
    Likes Received:
    0
    I am using Desire and having the same message in the unrevoke windows, any one know how to solve it? I have tried a few time but the same result.
     
  4. jabuzan

    jabuzan New Member

    Joined:
    Jun 22, 2010
    Messages:
    2
    Likes Received:
    0
    I think this happened because I changed the default install location for apps to sd card. I suspect this causes the unrevoked service (called "zyspkloit") to be installed to SD. As the SD card is unavailable immediately after boot, the service is unable to start.

    The solution that worked for me:

    1. Set your default app install location to "phone"

    2. Use "manage applications" to uninstall "zyspkloit"

    3. Re-run unrevoked

    :D
     
  5. mpc05

    mpc05 New Member

    Joined:
    Jan 1, 2011
    Messages:
    2
    Likes Received:
    0
    Wow. it's finally work. Thanks for your help :)
     
  6. marker580

    marker580 Member This Topic's Starter

    Joined:
    Jan 1, 2011
    Messages:
    5
    Likes Received:
    3
    AWESOME. Thanks!

    Now I just need to find where to change the default install location...
     
  7. marker580

    marker580 Member This Topic's Starter

    Joined:
    Jan 1, 2011
    Messages:
    5
    Likes Received:
    3
    Hmm, I'm not sure this fixed the problem for me.

    Seeing as how the Aria comes with 2.1 installed, I don't know how I could have set the default install location for apps to the SD card. There's nothing in the Settings to change it back either.

    Any other suggestions?
     
  8. marker580

    marker580 Member This Topic's Starter

    Joined:
    Jan 1, 2011
    Messages:
    5
    Likes Received:
    3
    Mr. Ed, carterzn and ShooterMcGavin like this.
  9. carterzn

    carterzn Member

    Joined:
    Jan 4, 2011
    Messages:
    6
    Likes Received:
    0
  10. Ogbassist182

    Ogbassist182 Well-Known Member

    Joined:
    Nov 17, 2010
    Messages:
    77
    Likes Received:
    0
    I have this same problem using HTC Desire. I know its not the same phone but i thought it was appropriate. I am running 2.1 so I don't think I can change install location of apps. Maybe another version of Unrevoked? I am running 3.31 and i'm getting the: Internal errror: am reported error starting service. Anyone know anything else to try?
     
  11. tpbklake

    tpbklake Well-Known Member

    Joined:
    Jun 22, 2010
    Messages:
    225
    Likes Received:
    46
    Try using Unrevoked 3.21. It seems that the current 3.31 has some issues with phones running Android 2.1
     
  12. tward09

    tward09 Member

    Joined:
    Dec 9, 2009
    Messages:
    22
    Likes Received:
    1
    Does anyone have the mac version?
     
  13. marker580

    marker580 Member This Topic's Starter

    Joined:
    Jan 1, 2011
    Messages:
    5
    Likes Received:
    3

Share This Page

Loading...