Root Unrevoked fails with "failed to get root. is your firmware too new?"

Discussion in 'Android Devices' started by Dataflashsabot, Aug 24, 2011.

  1. Dataflashsabot

    Dataflashsabot New Member
    5

    Aug 24, 2011
    2
    0
    5
    EDIT: Damn it, I was certain I'd posted in All Things Root. Sorry!

    I've got an unbranded UK HTC Desire, PVT4 (but erasesize 20000), hboot 0.93.0001. I used an app called "Visionary" to get temproot, it worked fine so I decided I'd grab unrevoked (3.32) and do it that way.

    It all works fine until it sticks on "getting root", then fails with "failed to get root. is your firmware too new?" and reboots the phone. I'd removed the temproot before trying. Booting into recovery just loads the stock "red triangle", not CWM.

    I did use the "adb shell pm setInstallLocation 2" trick to force apps to the SD card. Googling revealed that can interfere so I ran "adb shell pm setInstallLocation 0" to undo it; didn't seem to make a difference. I also uninstalled a bunch of apps that used the temproot in case they were interfering, but no dice. Ideas? I'd rather avoid a factory reset if possible.
     

    Advertisement
  2. SUroot

    SUroot Well-Known Member
    1,113

    May 25, 2010
    23,925
    5,304
    1,113
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Theres my rooting FAQ in the root sub forum. You need unrevoked 3.21

    Possibly the googling about the setinstalllocation brought you to my FAQ or one that was based on it. We (the collective) at AF discovered this ;)
     
  3. Kelmar

    Kelmar Done by choice
    VIP Member
    813

    Nov 28, 2009
    11,820
    4,751
    813
    Moved to ATR :)
     
    SUroot likes this.
  4. SUroot

    SUroot Well-Known Member
    1,113

    May 25, 2010
    23,925
    5,304
    1,113
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Cheers dude!
     
  5. Dataflashsabot

    Dataflashsabot New Member
    5

    Aug 24, 2011
    2
    0
    5
    Worked perfectly, posting from my now-rooted phone. Thanks!
    (Of course, it seems backwards to need to downgrade. I'm guessing Unrevoked's developers already know about this bug.)

    And thanks Kelmar for fixing my silliness.
     
Tags:

Share This Page

Loading...