Unrevoked3: complete Evo/Windows instructions

Last Updated:

  1. mikeyandroid

    mikeyandroid Active Member

    All the instructions I've found for using unrevoked3 to root an Evo on a Windows PC seem to be piecemeal (all over the place and incomplete), so I thought I'd give a rundown of what worked for me. Some of these steps may be unnecessary but doing all of them should result in a "safe" root. This is written for those with little to no knowledge of rooting but with basic Windows/PC skills and knowledge of how to navigate the Evo interface:


    Before beginning the process, I would recommend doing the following to your phone:

    (1) If you have the original unrevoked root installed, uninstall it by using "Menu", "Settings", "Applications", "Manage Applications" and scrolling to "Unrevoked" at the bottom. Tap it, click "Force Stop" at the bottom and then "Uninstall", "OK" to uninstall it. Then power off/on your phone just to be sure.

    (2) If you haven't already installed the OTA 1.47 update, do it now: "Menu", "Settings", "System Updates", and "HTC software update" at the bottom, then click "Check Now" to get the 1.47 update. If you do this update, it takes up to 10 minutes so be patient and let the phone reboot (a few times) until it is done. Then once the update is done, power off/on one last time to get a clean start.

    (3) Set your phone to "Charge Only": "Menu", "Settings", "Connect to PC", tap "Default connection type" and select "Charge Only".

    (4) Enable USB debugging: "Menu", "Settings", "Applications", "Development", and put a check in "USB debugging".

    The root process

    (1) Go to Control Panel on your system and uninstall any "HTC" software such as "HTC Sync".

    (2) Download the unrevoked3 install package: Go to
    unrevoked3 recovery reflash tool, v3.0 and click "Download for Windows". Save the "Reflash-bundle.exe" file somewhere that you can find it on your system.

    (3) Using Explorer, run the "Reflash-bundle.exe" file you just downloaded. It'll ask where to install it. Don't just accept the default: change the install location to a folder you can remember: it's just going to unzip some files there: it isn't really a software installer.

    (4) Once the files have unzipped, go to the folder you chose in the above step. You should find an "hboot driver.htm" file in that folder: double click on that to open the html instructions on how to install the drivers. Follow the instructions in the html file starting with downloading the actual driver files at the very top. When you download those driver files and unzip those, those are the files (the folder) you'll point to in subsequent steps in those instructions. When done with the html instructions, you should have drivers installed and shouldn't have to come back to this step.

    (5) At this point, if you needed to install the drivers, you are probably still sitting at a boot menu on your phone. UNPLUG the phone from USB and select "Fastboot" and then "Reboot" to reboot the phone to restart it. Before the next step, your phone should be on and booted up in its normal operating state (not some boot menu).

    (6) If you are running anti-virus software, turn it OFF or disable it now.

    (7) Now go to the folder where you unzipped the reflash bundle (step 3 above). In XP or older systems, just double click the "Reflash.exe" file. On Vista and Win7 systems, I'd recommend right clicking on "Reflash.exe" and selecting "Run as Administrator". While this may not be necessary, I know that some USB drivers get really mad if you try to access the USB port without admin privileges (sorry, I'm a coder so I run into that stuff and warn you so you don't have to) so I did it as a precaution.

    (8) You should get a window with "Unrevoked 3" on it (on the computer of course). Just follow the instructions in smaller font below "Unrevoked 3" to finish rooting. Note that when it says "Waiting for device", it wants you to plug your Evo into the computer via the USB cable. Note that it wants the Evo to be fully booted normally (not in the Hboot or recovery menus). The prompts at this point are very specific so no need to repeat them. If all works as it is supposed to, the only thing you really have to do is scroll to an item on the phone and select it when instructed. The rest is automated and should result in a "Done" message. The whole thing at this point took maybe one minute so it isn't something you have to wait for or stare at for a long time so if something gets "stuck" for a while... there's likely a problem.

    (9) Don't forget to turn your anti-virus software back ON.

    Now, when I followed these steps on my Win7 x64 system, reflash.exe detected the phone and started working (we're in step 8 here) but about 4 messages into the process I got the "communications lost... try again" message that unrevoked refers to on today's Twitter. Some say that (contrary to step 1) installing HTC sync actually solves the problem. I didn't try that. After about 6 tries on my Win7 system and even pulling some "tricks" to try to pause reflash.exe at certain points, I gave up and simply booted my old XP laptop and repeated the above steps and it worked perfectly the first time. At the point of the failure, you hear the two tone usb-device-disconnected sound followed by a use-device-connected sound about 20 seconds later. Somewhere in between is where the "communications lost" message appears so it looks like some sort of USB ack/nack issue. Hopefully it'll be resolved soon. My best advice if you get that error: try a new machine. The XP machine that worked perfectly for me had never seen any HTC software. Maybe that helped. And maybe after I uninstalled the HTC software on my Win7 x64 system (the one that didn't work) I should have rebooted before continuing: I didn't because it didn't prompt for a restart and I couldn't find anything "HTC" running in task manager.

    Feel free to copy this text, post on other forums, modify it, mutilate it, whatever. I don't want any "credit"... just trying to help.


  2. Nitraine21

    Nitraine21 Well-Known Member

    I see that this is a great way for windows, but does anyone know of way to do unrevoked through a Mac?

    Never mind....It was actually a lot easier then all those above steps for Windows!
  3. rtmeikle

    rtmeikle Well-Known Member

    So just to clarify, this method doesn't change anything on the phone except that it will let me download a wireless tether app from Market and it will work on my phone?

    Does it affect 4G or anything else on the phone?

  4. Nitraine21

    Nitraine21 Well-Known Member

    According to their website, this is their changelog:

    So for version 2.1 and up, you can apparently you flash custom roms......?
  5. Daft Punk

    Daft Punk Well-Known Member

    i just flashed the FPS fix on my EVO, installed UR3 this morning.

  6. DucatiDude

    DucatiDude Well-Known Member

    How did you accomplish this on the Mac? Thanks.
  7. mikeyandroid

    mikeyandroid Active Member

    I did the PC instructions as I don't have a Mac, hoping that someone would start another thread "Unrevoked3: complete Evo/Mac instructions". I can only do the PC side. Hopefully someone with a Mac side will chime in with similarly detailed instructions. Other than maybe installing the drivers though, I bet the instructions are quite similar.

  8. lnong

    lnong Member

    Based on what other ppl claimed, and what I saw after rooting, the phone settings/apps/etc all remained the same. The ONLY difference I saw was in the Market, there's a new app called "SuperUser Permissions". that was it.

    I dont have 4G in my area so i didnt enable it. So i dunno if/how it affects 4G.
  9. Nitraine21

    Nitraine21 Well-Known Member

    Go to the link listed in the first thread, and you have the option to download for mac.

    Once download, run the .dmg file and install it into your applications.

    Afterwards, connect your phone via usb into your mac, place it in debug mode (instructions above also) then click on the application to run it, and it will walk you through...easy as pie, and a lot easier than windows...

    So glad I am on a mac :D
  10. Nitraine21

    Nitraine21 Well-Known Member

    Did you use unrevoked to apply this? If so, how did you go about doing this? When it comes to flashing roms, I am a noob.

    Thanks in advanced
  11. Daft Punk

    Daft Punk Well-Known Member

    well after you root via unrevoked. Simply go to

    [Kernel]FPS 'fix' for Epson AND Nova screens (No need for evo switch!) Version 3.6.2 - xda-developers

    download the 3.6.2 .zip for both screens.

    then put it on the root directory of your phone via connection to computer.

    power off.

    hit power and only hold down button.

    follow instructions on screen to flash .zip using power as ENTER button and up/down arrows to navigate.

    once flashed, reboot, done.
    skpd and Nitraine21 like this.
  12. Nitraine21

    Nitraine21 Well-Known Member

    Thanks man!

    Does it wipe your phone when you do this or is it all good?
  13. Daft Punk

    Daft Punk Well-Known Member

    Mine was all good.
  14. rtmeikle

    rtmeikle Well-Known Member

    This is great! I'm a total newb to Android, but following your instructions was able to root my phone in just a few minutes. I downloaded the wireless tether for rooted users app, and it's working!

  15. bobodobo

    bobodobo Active Member

    Super thanks to Mikey! After completing the OTC update, first I confirmed that 4G was still working - it was, with typical speeds. I turned off 4G, got much lower speeds, turned on 4G again, got the higher speed. So 4G was definitely working before installing unrevoked3. After the install, I tested it again – same result. I also checked WiFi tethering – still worked just as it did before the OTC update and installation of unrevoked3. ShootMe (screen shot program requiring root) works too. All data was preserved in the update/rooting process. Life is good!

    For the "Prep" I did steps 1 - 4 exactly as Mikey suggested. For the root itself, I used a MacBook Pro. I didn’t have to do anything like steps 1 – 7 under “The root process” in Mikey’s original post. There were a lot of apps from HTC on the EVO but not a sync app. In fact I didn’t uninstall anything other than the original unrevoked app. On the Mac side all I did was install the unrevoked3 .dmg file, double clicked to mount the virtual disk, clicked again to open, plugged in the USB cable, and followed the simple directions on the unrevoked screen (on the Mac). It couldn’t have been easier. The hardest part was reading the tiny font on the EVO when in the “debug mode” or whatever you call that when its working.

    Now to see if the OTC update actually helps with anything (e.g. battery life) which was the whole purpose of doing the update…

    BTW the unrevoked team is so cool, and their program is free, I suggest you donate something to the cause they recommend (Electronic Frontier Foundation). I did.

    I posted this via the MacBook using the WiFi tethered EVO.
  16. boofa75

    boofa75 Member

    I installed Unrevoked3 without any problems. I was able to download the WiFi Tether app and it worked great.

    Only one problem, when I turn on wifi and try to connect to my network here at home...it sees it, but doesn't connect to it.

    Any thoughts?
  17. DucatiDude

    DucatiDude Well-Known Member

    I am rooted (UnrEVOked2) and not on the newest update and using WiFi Tether. Before I do this should I
    a) uninstall urEVOked?
    b) Run the new update?
    c) THEN follow these instructions?

  18. mikeyandroid

    mikeyandroid Active Member

    Logic would dictate that your a,b,c is correct because that should put you in a stock after-OTA 1.47 state. Should work since that's the state I started with. Anyone disagree?

  19. j3cubcapt

    j3cubcapt Member

    Man I LOVE MACS!

    OK, I downloaded the dmg from unrevoked3 recovery reflash tool, v3.0 launched the app, plugged in my phone and within 1 minute, ROOT!

    Does anyone know if there is a donation link for the Unrevoked crew?

    Dallas Texas
  20. AliasMangler

    AliasMangler Member

    I went through this successfully at work in about 6 minutes, only that long cause Unrevoked 3 was opening behind an active window and didn't show up on my tool bar!!!:D

    Thanks guys
  21. brian23la

    brian23la Member

    my phone wont find the ota update, i use to have the update, then did the simple 4 click root. then my tether wouldnt work so i used the original unrEVOked and my wireless tether worked, i just uninstalled unrEVOked and i still cant find the ota update when i check for it...help?
  22. mikebgb4

    mikebgb4 Active Member

    followed steps -- not working
  23. brian23la

    brian23la Member

    anyone? why wont my "simple root" evo find the new ota update...i want to use unrevoked 3 but i cant update my phone now it just says its up to date but i know its not.
  24. Daft Punk

    Daft Punk Well-Known Member

    i think you need to unroot.
  25. nizmoz

    nizmoz Well-Known Member

    Mine froze up on the flashing the recovery image. Not sure why.

Share This Page