Unrevoked3: Is your firmware too new?

Last Updated:

  1. TeamTJ

    TeamTJ Well-Known Member

    I was attempting to root my phone using the instructions found here http://androidforums.com/evo-4g-all-things-root/194918-rooting-dummies-extras-18.html

    When I run reflash_package.exe everything goes well until it says "Running Root..." After a while I get the following error:
    Now I am at a loss as to what I need to do/know so I can complete the root successfully.

    Anyone able to help?


  2. ovrrdrive

    ovrrdrive Well-Known Member

    I got the same error the first time I ran unrevoked too. I did a little reading and figured out I had to do a factory reset first. I did that and took the fresh phone and ran unrevoked again and it went right in.
    TeamTJ likes this.
  3. TeamTJ

    TeamTJ Well-Known Member

    Ok, I was hoping to avoid that, but I'll give it a go.

  4. ovrrdrive

    ovrrdrive Well-Known Member

    haha I was too!

    I wanted a nandroid of how everything was so I tried to do it first without a reset but got the same error you did. You might possibly be able to try uninstalling apps first to see if you can figure out what's causing it but I got impatient and did the reset. I can go from fresh rom to fully configured in about 30 minutes anyway so I figured I didn't have thta much to lose.

    I read about the error on the unrevoked faq on the wiki page.
  5. TeamTJ

    TeamTJ Well-Known Member

    That did it.

    I am now rooted!!
  6. ovrrdrive

    ovrrdrive Well-Known Member


    Now it's fun time...
  7. heythatsv

    heythatsv New Member

    I got the same error message, but I did a factory data reset right before I tried it.

    Any suggestions?

  8. Mr. Ed

    Mr. Ed Well-Known Member

    Perform another reset and try again
    heythatsv likes this.
  9. omegasoul

    omegasoul New Member

    I saw the same error. After I removed the one app I downloaded and tried again I received the success message. Not sure if removing the app or just simply trying a second resolved the issue but figured I should mention my experience.
  10. akazabam

    akazabam Well-Known Member

    What app was it?
  11. Hunterbeav

    Hunterbeav Well-Known Member

    I got the same error message the first time I tried unrevoked...I'm sorry I can't remember who told me to do this..I apologize to this person now please forgive me. But he told me to install htc sync to my P.C. then after installing to go into control panel and uninstall htc sync leaving the htc drivers alone that install with the sync program...I did this then reattempted the unrevoke and it installed flawlessly
  12. ovrrdrive

    ovrrdrive Well-Known Member

    I thought having or installing htc sync was a bad thing if you're planning on rooting. I had it on my pc and uninstalled it, then updated to the hboot usb driver from unrevoked to get rid of all of the htc stuff and got the error when I tried running unrevoked. A reset took care of it for me and things have been great since.
  13. Hunterbeav

    Hunterbeav Well-Known Member

    Don't know, but thats what I did and it worked..I did the hboot drivers also..but did install htc sync then uninstalled leaving the htc driver there and it worked:)
  14. Hunterbeav

    Hunterbeav Well-Known Member

    This came from rooting for dummies thread:NOTE: Communication Error
    Some say HTC Sync actually solves the communication error message. I never had HTC Sync installed, which might be why the error never arose. If you have to uninstall HTC Sync, you may get the error, and you may not. Try it both ways to see if it works.)
  15. omegasoul

    omegasoul New Member

    app list backup (Zemna version)
  16. akazabam

    akazabam Well-Known Member

    I don't see how that particular app would cause a problem. Basically this error is kind of generic, and is potentially fixed by doing one or more different things. Some people need to install HTC sync, then uninstall it. It can't be installed because it will interfere, but something it adds (drivers?) needs to be installed somehow in order for it to work. Some people still get the error though, most likely caused by something on the phone that is interfering. That's why wiping data is recommended in that case.
  17. omegasoul

    omegasoul New Member

    I only mentioned this because it is mentioned as a common problem on the unrevoked site:

    The program says
  18. bribri301

    bribri301 Member

    I had this problem. I uninstalled the antivirus app from the phone. worked okay then.
  19. jerryr88

    jerryr88 Active Member

    i had this problem..i uninstalled the antivirus and also wheni connected the usb i put i was told by someone to put it in disk drive instead of charge only and it worked :D
  20. blkhwk

    blkhwk Member

    putting phone into disk mode worked for me! thanks for the suggestion
  21. surfologist87

    surfologist87 Well-Known Member

    This looks like a good idea..

    Ive rooted a couple friends evos with them. I always disable/turn off task killers and antivirus.
    On ones ive done with it, its never caused a problem, but just in case, i dont want to cause any ruckus so i just shut it down :)
  22. kasl33

    kasl33 Member

    I just had the same error. All I did was run Unrevoked again and then it was able to flash Clockworkmod successfully. Unrevoked says "Done."

    FINALLY! It wouldn't work last month so apparently this latest Unrevoked update is golden.
  23. jerryr88

    jerryr88 Active Member

    no problem :D
  24. hellbrandt

    hellbrandt New Member

    I had this problem and tried everything suggested above, but none of it worked.

    In the end the solution that worked for me was to use the earlier unrevoked 3.21. Worked with no problems at all, really straight forward.

    I downloaded it from here Download unrEVOked 3.21.exe from Sendspace.com - send big files the easy way (got the link from xda-dev forum, but can't remember the exact page and who to credit for it).
    ksk and sunnyb like this.
  25. surfologist87

    surfologist87 Well-Known Member

    I got this on a friends evo recently, and i just ran it a second time and it seemed to work.
    If the issue comes up for anyone, try to turn off all things running, do a reboot, and then trying again.

Share This Page