1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

unroot?


Last Updated:

  1. kbeefy

    kbeefy Member This Topic's Starter

    Joined:
    Feb 11, 2012
    Messages:
    11
    Likes Received:
    0
    I cant get TiB to restore anything, Im thinking about exhanging this phone for an unmolested one @ verizon. How do I unroot it?
     

    Advertisement
  2. zeroibis

    zeroibis Active Member

    Joined:
    Jun 11, 2011
    Messages:
    43
    Likes Received:
    7
    I would recommend sending an e-mail to dan about it as he is the one that developed the root method for this phone. ;)
     
  3. kbeefy

    kbeefy Member This Topic's Starter

    Joined:
    Feb 11, 2012
    Messages:
    11
    Likes Received:
    0
    Emailed Dan, he responded in about 3 seconds. Waiting on a response from TiBackup, failing that heres the unroot instructions if anyones interested...

     
  4. RideZeLitenin

    RideZeLitenin Well-Known Member

    Joined:
    Jan 11, 2011
    Messages:
    114
    Likes Received:
    9
    So basically those of us who have held off on rooting yet should still wait for a more "compatible/working" root? Seeing as wifi tethering and titanium root refuse to cooperate.

    Curious, has anyone gotten around to overclocking the Droid 4 yet? Or does OC'ing not work yet either?
     
  5. myfishbear

    myfishbear Well-Known Member

    Joined:
    Sep 5, 2010
    Messages:
    299
    Likes Received:
    62
    no some people dont reailse you also have to install busybox after you root to use ti backup... mine works fine .... got it running like cyanogen... just used some older gb apps and its great! i got setcpu limiting it to 1 ghz anf min 600 mhz
     
  6. kbeefy

    kbeefy Member This Topic's Starter

    Joined:
    Feb 11, 2012
    Messages:
    11
    Likes Received:
    0
    Will yours restore?

    I realize now I should have frozen instead of uninstalled... I have installed busybox 1.19.3 as well as Titanium Backup PRO, tried with app processing mode in direct, indirect, classic, as well as 'forcing Busybox'. I still can't restore.
     
  7. zombie673

    zombie673 Member

    Joined:
    Apr 6, 2010
    Messages:
    9
    Likes Received:
    0
    Root works fine. Wifi Tether is now working...

    http://androidforums.com/droid-4-all-things-root/498603-wifi-tethering-barnacle.html

    Haven't looked into overclocking because the things is REALLY fast to begin with. I wouldn't see any reason to decrease battery life to improve something that is already impressive.
     
  8. kbeefy

    kbeefy Member This Topic's Starter

    Joined:
    Feb 11, 2012
    Messages:
    11
    Likes Received:
    0
    So, I tried unrooting and it keeps saying 'rm failed for /system/app/superuser.apk, read only file system'

    Any suggestions?
     
  9. myfishbear

    myfishbear Well-Known Member

    Joined:
    Sep 5, 2010
    Messages:
    299
    Likes Received:
    62
    delete it with root explorer
     
  10. kbeefy

    kbeefy Member This Topic's Starter

    Joined:
    Feb 11, 2012
    Messages:
    11
    Likes Received:
    0
    emailed Dan again...

     
  11. gremor

    gremor Member

    Joined:
    Jun 8, 2010
    Messages:
    9
    Likes Received:
    0

    So (for a nooB) what would the entire input string be?

    Thx.
     
  12. myfishbear

    myfishbear Well-Known Member

    Joined:
    Sep 5, 2010
    Messages:
    299
    Likes Received:
    62
    $ su
    # mount -o rw,remount /dev/block/system /system
    # rm /system/app/Superuser.apk
    # rm /system/xbin/su
    # rm /system/bin/su
     
    gremor likes this.
  13. kbeefy

    kbeefy Member This Topic's Starter

    Joined:
    Feb 11, 2012
    Messages:
    11
    Likes Received:
    0
    ^^ yeah, that.

    Which worked for me except rm superuser.... it then said 'file doesn't exist', but I still had superuser on my phone. I wound up downloading and running the Droid 4 Utility, rooting and unrooting through it, then Superuser was gone.
     

Share This Page

Loading...