unroot


  1. pbanj

    pbanj New Member

    just wondering how one would go about unrooting this phone

    Advertisement
    :
  2. avelis26

    avelis26 Well-Known Member

    I figured out how to COMPLETELY return to stock, un-root, and un-brick the phone :)

    The night started with me wanting to remove the stock lock screen and replace it with the new ICS lock screen... well I got it working, sorta. It worked once then every time I tried to unlock the phone after that, the backlight would turn on but no screen, no lock screen, nothing... just back light.

    I rebooted into recovery with ADB and formatted /system, /data, /sdcard, /_ExternalSD, /persist, and /cache. I'm thinking one of those steps was bad because then I tried to push my img file to _ExternalSD and after waiting over an hour it was still going. So I pulled the battery and obviously from this point on I would not be able to boot to system.

    I returned to recovery holding down VOLDOWN + POWER for 5 seconds until the factory reset screen came up. I hit POWER twice and that brought me to recovery. I used adb shell to try and push the img again only to find out I couldn't mount /sdcard anymore and by extention /_ExternalSD. Don't ask me why... not sure. I pulled the external SD out and reformatted in windows and put the img file on manually.

    Back to recovery but no matter what I did... I couldn't get internal or external storage to mount. I tried
    Code (Text):
    adb shell dd if=C:\vs840_files\lucid.img of=/dev/block/mmcblk0p26
    but ADB didn't like that.

    So at this point I had a semi working recovery that couldn't repair system, and a system that wouldn't boot because I wiped /system. So now I begin hours of research trying to find the proper software to re-install firmware via download mode. I've used the LG Mobile Support Tool before with other LG phones but not for download mode... only type of phone I've ever been able to use "Download Mode" is Samsung phones and ODIN.

    I tried it anyway and it WORKED... the LG Mobile Support Tool connected to my LG Lucid in Download Mode, completely fixed my phone :)... un-root, stock, complete factory reset.

    I will say blumeany that after doing this, I checked for OTA and my phone is all ready up to date, so I'm not sure if it will fix your issue but its certainly worth a shot :)

    Here is the link to the driver and tool I used to fix my phone:
    LG LGVS840 Support: Find Manuals & Warranty Info | LG USA
    Make sure to click on the "SOFTWARE UPDATE" tab.

    Anyway, feel free to PM me or gmail, or gtalk, or IRC if you want more info (although after this book I wrote, I think you should have all the info you need lol)

    graham.pinkston@gmail.com
    mrryanthai, meggaplex and blumeany like this.
  3. blumeany

    blumeany Well-Known Member

    INTERESTING. :) I had actually tried that LG tool myself a while back and it just ended up erroring out on me. From then on it insisted that my phone software was already up to date.

    Let me give this a shot again. Maybe uninstalling/reinstalling the software would help.
  4. blumeany

    blumeany Well-Known Member

    Wow. That actually worked this time around!

    To clarify, this is what I did.

    1. Phone was already rooted, had my info on it, etc. I didn't delete anything or do a factory reset.
    2. Launched the LG Mobile Support tool (make sure to install drivers first (it's in the support tool)
    3. Now, because I had ran this before and it failed, it was giving me an error when I tried the update option because it thought my firmware was already up to date (v5) when the phone was still showing v3. Instead, I went to the Customer Support > Recovery Phone option. I entered in the serial and imei and clicked on check.
    4. Before you run this, you'll need to put the usb debugging mode option on Ethernet. I had actually started this process while the phone was rebooting, it still worked to a point and then it said it lost connection to the phone (this was because the phone had booted back up and was in usb mass storage mode). I changed it to ethernet and click on restart and it continued the update process.

    5. The program downloads the image file first, then reboots the phone and performs the update process.

    6. My phone eventually booted back up - complete with all of my previous settings/programs. I checked the software version and it showed v5! However, it was still nagging me to install the update. I did so. Phone rebooted and performed the update successfully (it was failing in the past). Phone rebooted a few more times and then came back up UNrooted and with the OTA installed.

    Now, in the past I've made different changes and thought things were fine, only to shut down the phone and it wouldn't come back up (bootloop, or some other error). As a test, I went ahead and pulled the battery and popped it back in. Phone started up just fine.

    So, my advice is that for anyone who wants to unroot to either update or just wait for a solid ROM to be created, to try this method. If it fails the first time and then continues to tell you that the phone is already up to date, try what I did - rebooting the phone and starting the recovery/update process while the phone is booting.

    If someone is willing, they can probably unroot, do a factory reset, then pull the fresh image for experimental purposes.

    For anyone who's 'bricked' their phone, I would try running this program to see if it can maybe latch onto the phone long enough to initiate the upgrade process. The LG program seems to be able to resume the process if it loses connection, so maybe rebooting again and again will allow it to finally re-image the phone. Worth a try.

    FOLLOW UP: For those that are curious, I was able to successfully re-root after this whole process. All of my existing apps that required root still work, and I was able to successfully re-flash CWM through ROM Manager, boot into CWM and run a backup. Also shut down and powered back on to ensure everything was working, and it was. No more ##@$@# OTA nag. :D
    avelis26 likes this.
  5. kaihamilton

    kaihamilton New Member

    Hello hellooo?? Hi, I am ashamed to admit that I am one of those unfortunate individuals who happen to be sitting behind a bad NAT router. I don't think my router supports UPNp or anything. But what this has to do with this page is that LG's download for the "LG Mobile Support Tool" uses ports. My router has very strict port settings that I am unable to change at the moment, and so I can not get the download. :( If either of you on this forum would lend me a mediafire or dropbox link to the file I would appreciate it soooo much!!!!
  6. blumeany

    blumeany Well-Known Member

    meggaplex and kaihamilton like this.
  7. avelis26

    avelis26 Well-Known Member

  8. kaihamilton

    kaihamilton New Member

    Oooops! Well thanx for posting it here for me as well :). I managed to get another version of the file from Softpedia.com before you posted but it stops loading so I thought it was a fake. Using the link you provided it still wont run all the way through. I have tried everything, don't know what to do... :C
    [​IMG]
    ^---- This is where it keeps on stopping.
    Sorry to bug you any further, but I have one last question I think you may know the answer to...
    Is there a way to update my phone while it is rooted without the tool? The update thing has been harassing me and I want to make sure I get the update to IceCreamSandwhich when it comes.
  9. avelis26

    avelis26 Well-Known Member

    I think the pic you posted is no longer there. Anyway honestly the best thing to do is use the tool and go back to full stock. Doing so will update your phone so you won't be asked for OTA update. Then reroot your phone and make it cool again.

    Anyway about your issues returning to stock... I'm not sure if your PC is the issue but assuming it isn't:
    make sure you have the drivers installed
    assuming you have cwm installed, reboot to recovery
    Launch the LG mobile support tool and connect your phone
    Start the update and wait for it to bitch about communicating with your phone in the second half of the program
    Dissconnect your phone and pull the battery
    Connect USB, hold VOLDOWN + VOLUP + POWER, and reinsert battery to get to download mode
    Continue the update and everything should be fine

    Gtalk me if you want help walking through it
    graham.pinkston@gmail.com
  10. avelis26

    avelis26 Well-Known Member

    That part about connect USB, hold volDOWN + volUP + power, and reinsert battery...
    I meant to say IN THAT ORDER!! LOL
  11. sallev1

    sallev1 Member

    Thank you, this has been most helpful and actually worked from me. One thing though; after the completed download from LG and upon rebooting the phone went into bootloop. I was able to stop it though a battery pull and rebooting into factory reset (volume down and power). Then the phone rebooted correctly. But it was with great pleasure to find out that we have the ability to put the phone into "Download" and repair a Lucid bricking through the tool offered by LG.
    By the way, I had rooted the phone and added cwm recovery, which was no problem, but the bricking was caused by attempting to flash the rom (connect) which is offered as working for the Lucid. BEWARE of that ROM. Right now, I think it is the only one offered. Better to wait for Ice Cream Sandwich ota.
  12. scars

    scars New Member

    If you are looking to only unroot and you still have stock rom installed. One Click Tool worked for me.
  13. Dtb1987

    Dtb1987 Member

    Ginger brake will do it too
  14. mrryanthai

    mrryanthai Well-Known Member

    Can anyone show me how to use oneclicktool or gingerbrake?
  15. johnsi02

    johnsi02 New Member

    Gingerbreak is pretty straight forward, and phone-centric (no computer required).
    1. Download it. It is an apk, so just do that with your phone. You can get it from xda if you're a member, or google for gingerbreak 1.2.
    2. Install it. Since you downloaded it to the phone, just navigate to the file and run it. You will need non-market apps enabled (Settings > Applications > Checkmark in Unknown sources)
    3. Run the program. Icon should be in the Downloads section of your App screen.
    4. It asks you to make sure an SD card is mounted (internal one counts, so no worries there) and debugging is enabled (Settings > Applications > Development > Checkmark in USB debugging)
    5. Click on Unroot. It should reboot in a couple of seconds, and you are good to go. If you are selling or returning the phone, you could uninstall Gingerbreak. Otherwise, you're free and clear.
    JS
    mrryanthai likes this.
  16. mrryanthai

    mrryanthai Well-Known Member

    Thank you sir!Just wanted to see if it worked out of curiosity.Can I just reroot my phone through Gingerbreak as well?Or do I have to manually reroot it through my computer?
  17. bdk123

    bdk123 Member

    Hi, I was hoping someone would be able to help me out here. i shut my phone off last night and when i woke up this morning it said security error when i tried to boot it up. i followed the instructions on how to un brick my lucid, but it keeps say that the doftware is up to date already. Any ideas on how i can fix my phone?
  18. mrryanthai

    mrryanthai Well-Known Member

    Did you change/remove any system files?
Loading...

Share This Page