Unrooted Galaxy S in bootloopSupport


Last Updated:

  1. sqrnookle

    sqrnookle New Member

    So I've had my Galaxy S for a year and a bit now, and it's essentially stock from the provider - unrooted, and has been updated to 2.3(.3, I think. Maybe .4). Then about a week ago I pulled it out of my pocket and it had begun - completely of its own accord - a bootloop I haven't been able to break it out of since. I hadn't done anything to it that day - I know I had fetched it out of my pocket a few hours earlier to check the time, and it had been left on since then; the only thing I'd done in the past week was install a couple of games, but that was all, system wise.

    When I try and boot it, all it does is the initial startup screen, then the twisty S logo (with music), and then after about 20 seconds loops the twisty S logo animation but without music. From there, the only way out is to pull the battery. Booting while attached to the computer likewise yields no results.

    I *can* get into Recovery and Download modes. In Recovery mode I've tried wiping the cache to no avail, though there is one interesting bit: in the yellow text there's a typo ('Successfully copied meida files') and under 'Installing Multi-CSC' it reads 'Can't access to '/system/csc/XSA/system'.', though I've no idea what that means (googling it has provided no answers).

    Worst of all, I've been slack and not backed up data from the phone for a few months, and as such would really like to avoid wiping it, like the phone carrier is likely to automatically do if I send it to them for repair.

    I've tried draining the battery, fully charging the battery, letting the bootloop run overnight, left it off for a few days, even the old 'bag of rice' trick, even though it hasn't been submersed. So can anyone help me out with a few suggestions of what to do, or at least to be able to get the data off the phone before factory resetting it?

    Thanks in advance...

    Advertisement
  2. xsenman

    xsenman Well-Known Member

    you could try going into download mode and flash a CSC file for XSA

    https://play.google.com/store/apps/details?id=com.manniakk.cscselector

    WARNING: Changing CSC will wipe your phone.


    or refer here [UPDATED] JPY XSA (Australia Unbranded) Firmware - xda-developers

    http://forum.xda-developers.com/showthread.php?t=787163
  3. sqrnookle

    sqrnookle New Member

    Thanks very much for that! I should add - in Recovery mode, after that error line, it does read 'Successfully applied multi-CSC.'.

    So I guess my other questions before I attempt that are whether it's possible to get the data off of the phone whilst it's still in this state? Is there any way of using download mode to retrieve things, rather than just sending? Or is it possible maybe to flash a new CSC and wipe the phone but then use data recovery software to recover some/most of what was there?

    (And a slightly daft question: how is the internal storage implemented in the SGS - is it a board-based chip, or is there an internal microSD or somesuch?)
  4. xsenman

    xsenman Well-Known Member

    Whatever is in your external SD card you can save by just removing SD card, whats in your Internal SD card will be lost IF it did a full format, but in a factory reset, you can chose not to erase Images etc, ...so correct me if I am wrong...have you done a factory reset?

    meaning touch menu > settings > privacy > factory data reset

    Here you have options to save some data but it will boot you phone to initial state, like when you first got your phone.

    You cannot recover wiped data by recovery or download modes, what can be done is install apps like this https://play.google.com/store/apps/...sImNvbS5oZXhhbW9iLmhleGFtb2JyZWNvdmVyeXBybyJd

    to recover files IF they have not been overwritten

    yes internal is an on-board chip


    My suggest here would be to do a factory reset, if this has not been tried yet
  5. sqrnookle

    sqrnookle New Member

    Just realised I should add to this in case other people have this problem - a factory reset from the Recovery mode did get the phone working again. Photos, videos and some app data survived (things like the memo notepad files didn't, sadly). Thanks to all for help.

Share This Page