Update script not working for me


Last Updated: 2011-05-02 13:34:16
  1. Hey all!

    Just wiped/formatted and reinstalled velocity 1.

    But it's not letting me update my scripts. Keeps telling me I have the latest, but i still have the old first version. I am running su.

    Any ideas, mates? Trying to figure out what i'm doing wrong, or if there is a work around.

    Thanks!

    P.S. Velocity is still rocking my socks on a daily basis =D

    Advertisement
  2. dautley

    dautley VIP Member VIP Member

    I guess that you have internet access to your phone when your running terminal emulator? Are you running any kind of firewall that may be blocking a connection? I'm at version25 just fyi.
    If you go to (1)cosmetic changes and (3)change theme, does it fetch the online manifest?

    If none of this helps try posting at http://androidforums.com/velocity/287300-velocity-script.html
    savoxis is pretty good about answering questions about his scripts in this thread.
    drewsephvladmir likes this.
  3. tigersfan1

    tigersfan1 Well-Known Member

    I'm getting this error when I enter Terminal Emulator:
    /cache/velocity/intro.txt: No such file or directory
    It shows up when it tries to fetch the online manifest
  4. savoxis

    savoxis Well-Known Member Developer

    Force an update manually.
    Make sure you have at least a 3g connection
    Open a terminal
    Type the Following:

    Code (Text):
    1.  
    2. su
    3. wget -O /system/bin/velocity http://184.106.76.138/velocity/scripts/velocity
    4. chmod 777 /system/bin/velocity
    5.  
  5. tigersfan1

    tigersfan1 Well-Known Member


    Wait you want me to do that or the other person
    johnjjbsu likes this.
  6. Thanks dautley and savoxis! Scripts are working perfectly now, manual update script fixed everything.

    Cheers!
  7. I was also unable to update scripts after reinstalling Velocity 1.0 (greatest ROM for any phone ever) and after trying your manual update command discovered my System partition was set to read-only. I'm sure there's an easier command to mount it as read-write, but I used Root Explorer and then it worked great. Thank you!

    Also, some of the main menu lines are kind of awkward when I'm with my girlfriend, are they written out in a place I can edit them on my phone?
  8. savoxis

    savoxis Well-Known Member Developer

    Hrm, Ill take a guess that an application had set your system to ro after boot, you can remount easilly in a rooted terminal by
    Code (Text):
    1. busybox mount -o remount,rw /system
    SmallQuadruped likes this.
  9. azuma73

    azuma73 Well-Known Member

    If , for some reason, I should need to re-flash again, am I gonna have to do this again?
    Code:
    suwget -O /system/bin/velocity http://184.106.76.138/velocity/scripts/velocitychmod 777 /system/bin/velocity

    No big deal if I do, was just wonderin' cuz I may have forgotten to wipe something!?!
  10. admn81

    admn81 Well-Known Member

    After I had to reflash Velocity I am having issues with this...when I type in the code in terminal emulator, I get a message saying "wget:invalid option". What am I not doing right? Any help would be appreciated. Thanx
  11. tron101

    tron101 Member

    Im having the same problem , ok got it -O not -o........
    admn81 likes this.
  12. ndrew2505

    ndrew2505 Active Member

    use a capital o instead of a zero
    admn81 likes this.
  13. admn81

    admn81 Well-Known Member

    Sweet...I tried it as capital O before but wasn't including a space in between velocity and chmod...Thanks for the help!
  14. Cl8rs

    Cl8rs Well-Known Member

    I tried this and it still isn't working. Help?
  15. azuma73

    azuma73 Well-Known Member

    If you're runnin' Frunisher, I don't know if Velocity scripts will work? But hey, I could be wrong?
  16. Cl8rs

    Cl8rs Well-Known Member

    I'm on velocity 1.0
  17. azuma73

    azuma73 Well-Known Member

    Did you get it to work??

    Keep trying, it fully worked for me a short while back! thanks again to Savoxis, like a ninja!
  18. savoxis

    savoxis Well-Known Member Developer

    2 things:

    The only way this would fail to work is if your not typing the commands correctly. Or if you have no connection to the net.

    The script (if you ran the manual command) would "install" to Frunisher, but it does have a few dependencies, so alot of the features would be broken and there is a fairly high likelyhood of you throwing your phone for a loop
  19. Cl8rs

    Cl8rs Well-Known Member

    I got it working :) Thanks guys :)
  20. afastyzfr1

    afastyzfr1 Well-Known Member

    Posted in other thread

Share This Page