Update Security Settings with Exchange 2010Support


Last Updated: 2012-06-29 00:14:58
  1. mattbooty

    mattbooty Active Member

    My company is upgrading to exchange 2010 (from 2003) and ever since I moved my mailbox to 2010, every time I reboot I get a notification prompt to "Update Security Settings". This happens every time I reboot no matter how many times I accept it. I've tried deleting and re-adding the account, and it continues to come back every time I reboot.

    The annoying part is that it doesn't seem to sync properly until a few minutes AFTER I've accepted these changes. It doesn't seem like this should be happening.

    Anyone else seeing this? And if so how did you fix?

    Thanks

    Advertisement
  2. SirVilhelm

    SirVilhelm Well-Known Member

    Have you tried Touchdown? I know this doesn't answer your question but until Google implements real exchange support it's the best option we have. Once you use it you'll wonder how you ever got by without it.
  3. GideonX

    GideonX Guest

    You'll probably end up using Touchdown (in the market) to get around this.

    edit: got beaten to the punch with the TD recommendation ;)
  4. mattbooty

    mattbooty Active Member

    I tried a trial of touchdown last year when I first got my droid and I didn't really find it to be worth the money. Beyond that though, thats not really an answer for my users at work, I need to be able to just have a remote user who is in another state go buy a droid and start getting emails, which up until now hasn't been a problem at all, and still works other than this "Update Security Settings" issue.

    I appreciate your suggestions, I'm hoping someone else on the forums may have been able to solve this particular issue, or may know what is causing it. It may just be a bug in the android software and there may be no way around it, but one can hope!
  5. Highland Ranger

    Highland Ranger Well-Known Member

    i have the same thing happening - seemed like it started whet i upgraded to 2.2 and rooted-may have coincided with a server upgrade but not sure
  6. mattbooty

    mattbooty Active Member

    I'm rooted as well, I'm not sure if that has any affect on it or not, but it only seems to affect 2.2 and exchange 2010 (possibly 2007 as well, but not 2003). Another member of the IT staff has a captivate which is still on 2.1 and he does not appear to have this problem after moving his mailbox.

    The message itself doesn't bother me, but the fact that I have to accept it every time I reboot my phone does. I can handle the hassle but I'm concerned non-tech users will have issues with it.
  7. Fifty9Dunes

    Fifty9Dunes Member

    experiencing the same thing - after a reboot (FRG22D) - it says exchange needs to update security settings.

    after about a minute or two it begins to push again.

    must be a slight delay on either the host/client end with transmission of data as when we have to change our password (every 30 days) i experience the same lag (as reboot security cert.) in actually establishing push.
  8. Highland Ranger

    Highland Ranger Well-Known Member

    But the message is meaningless - I believe it asks you to lock your handset but if you don't, you just dismiss the warning and it works fine. So a security issue for you guys administering corporate mail - if the phone is lost, and not wiped after a certain number of bad entries, you could have someone gain access to the mail account
  9. phantom6294

    phantom6294 Active Member

    Another "me too" post. After the FRG22D update, my phone began enforcing the security policy of having either a password or PIN to unlock the device. I was using 1&1's Hosted Exchange and was able to have 1&1 disable that security setting for my and my wife's account. However, on every reboot (and at least once at random) the phone would fail to sync saying I had to update the security settings. I would have to add a PIN... get things working again and then I could disable the PIN and continue normally; until of course I rebooted. Even tried doing a full factory reset after the FRG22D update and the security settings were disabled on the server side... to no avail.

    It was annoying enough for me to get rid of my Hosted Exchange accounts and move my domain to Google Apps personal. I miss the Exchange based account but Google Apps has treated me very well and am happy I switched. Obviously, I understand that's probably not much a solution possibility for the OP.
  10. mattbooty

    mattbooty Active Member

    Well, my main concern was that it was stopping push functionality after a reboot, but it does seem like that re-establishes automatically after a few minutes, so it may not be much more than a nuisance after all. That said if anyone does find a solution I'd be all ears!

    thanks!
  11. mattbooty

    mattbooty Active Member

    FYI to anyone else with this problem, I am rooted and recently updated to a new ROM built on FRG83 and this problem went away. So a fix is on its way (or already available if you are rooted).
  12. mswhite60

    mswhite60 Well-Known Member

    Another +1 for Touchdown. Worth every penny.

    Sorry - I know this does not address the issue, directly.
  13. ISLOCK

    ISLOCK New Member

    To correct the "Please Update User Settings" error on Android 2.1 or higher, have your Exchange 2007/2010 administrator run this command:


    In Exchange 2007/2010 Management Shell paste the following command:

    Set-ActiveSyncMailboxPolicy “Default” -IsDefaultPolicy $False


    ISLOCK.COM
    Sundown likes this.
  14. jaideepc

    jaideepc New Member

  15. jaideepc

    jaideepc New Member

  16. Sundown

    Sundown Member

    Ladybug2659 likes this.
  17. Ladybug2659

    Ladybug2659 New Member

    I wasted the better part of the morning trying to get this resolved. This forum helped. For those of you who have a Samsung Fascinate and have tried to add a corporate email only to get to the "Please Update Security Setting" or the "Please Update User Settings" errors -- you can solve it one of two ways:

    To correct the error on Android 2.1 or higher, have your Exchange 2007/2010 administrator run this command:

    In Exchange 2007/2010 Management Shell paste the following command:

    Set-ActiveSyncMailboxPolicy
  18. Uhprentis

    Uhprentis New Member

Share This Page