[UPDATED 8/8/12]Breath of fresh air....an update


  1. death2all110

    death2all110 VIP Member VIP Member


    Advertisement
    :
    johnsonwcjw, iskios, cac2us and 16 others like this.
  2. steamer86

    steamer86 Well-Known Member

    Progress!
  3. badrsj

    badrsj Well-Known Member

    Thank you :)
  4. ups2525

    ups2525 Well-Known Member

    I'm starting to stick back a few bones for a donation now...THANKS FOR THE UPDATE and I really appreciate your hard work guys! :D
  5. Staticaxe

    Staticaxe Well-Known Member

    Thank you!
  6. kfj001

    kfj001 Member

    Is there an official forum, or other place you're discussing your methodology of porting CM9 to this device? I'm curious how you've gone about developing it for the Spectrum.
  7. jeshbeast

    jeshbeast Well-Known Member

    I believe they aren't doing a port...creating it from the ground up.
  8. admn81

    admn81 Well-Known Member

    You are correct they have been building entirely from source and they have spent the past few months working nearly every nite on it. I hope you guys show them some donation love when they get it going cause the total numbers of hours spent working on this is crazy!

    Hey d2a so if I ask for an ETA in irc tonite does that count? Lol :) u know I wouldn't do that!
  9. Lightswarm

    Lightswarm Well-Known Member

    Oh? Seems like another option will be available. Thank you for your support on the LG Spectrum and we definitely don't have the right to ask anything extra from you, its a privilege to be flashing any Dev's ROM.
  10. jeshbeast

    jeshbeast Well-Known Member

    Now wouldn't that be a crack up if these two beat the OTA of ICS being held for ransom by Verizon? Just think what poor publicity VW would get. It seems that these forums are being watched so word would get out. :D. Good job devs. Keep up the good work.
  11. mercury88

    mercury88 Member

    WooHoo!!! CM9!!! I love AOSP so glad this may eventually be possible. Manufacturer skins suck!! I used to love HTC sense till I realized 90% of it is bloat and the other 10% you like you can get as apps. I haven't tried an AOKP ROM yet but till I see what the fuss there is, I am an AOSP man. Thanks so much for busting your balls on this guys!!!
  12. death2all110

    death2all110 VIP Member VIP Member

    [​IMG]

    Good news!

    ADB is working again!

    Now I'm off to figure out why this hangs on the boot animation!
    MrDangerous likes this.
  13. MrDangerous

    MrDangerous Well-Known Member

    EDIT: I posted this before seeing D2A's latest post so much of this may not apply any more.

    Sounds like we have genuine mystery!

    I used to play around with taking ROMs and trying to load them in the android simulator, they never worked but a freezing boot animation was common, but normally in those cases ADB was working and it was just looping on something.

    Does ADB work from CWM? I wonder if it's dumping something that could be found.

    Here are some things that popped into my head, they may be way off but just what I might try.
    Since it's loading the animation we know that it was able to mount part of the file system to read the animation file. Is there a way to tell if all the partitions mounted, I can't remember if when a partition is mounted it leaves some kind of trace that it worked. Or I wonder if the animation will keep running if it fails to mount a partition and just sit there indefinitely looping.

    Some crazy ideas...

    Does the freeze occur at exactly the same time? Where if you timed it with a stopwatch it always freezes at say 37 seconds consistently. I was thinking if somehow the the cpu clock just went out of control and ran too fast it would crash sooner and sooner each time you rebooted.

    Also maybe the animation didn't actually freeze but the video driver failed to initialize the screen when switching to the gui, that would mean maybe you'd have to wait a while while the dalvik cache builds up, but hopefully ADB would be working at that time.

    Hmm. Or it could just be a genuine kernel panic or lock-up.
  14. death2all110

    death2all110 VIP Member VIP Member

  15. MrB206

    MrB206 Well-Known Member

    Nice one... looks like you guys got a bit further than I was able to with cm7 on this device. My guess is we either need to use the ICS 'stock' kernel for the hardware integration OR another kernel (or HALs if you guys can write them) to get the hardware working with the software. What's baffled me is how we can have GB currently on the phone, but none of the kernels will get cm7 to boot. It's too bad there isn't some analysis tool to see what the phone is doing and what's failing, other than ADB...
  16. death2all110

    death2all110 VIP Member VIP Member

    There really is no kernel requirement for ICS. I backported genlock to MT's kernel base, and that helped alot.
  17. kfj001

    kfj001 Member

    It looks like the Input manager is locking up during the boot?
  18. MrDangerous

    MrDangerous Well-Known Member

    I googled it and found someone elses logcat, assuming things are in the same order, bluetooth is next.

    I think input manager has something to do with the touch screen so maybe there's something there going on.

  19. kfj001

    kfj001 Member

    Well, I guess it's time to debug like a kid again: add log dumps into the input manager at every function/method call...
  20. death2all110

    death2all110 VIP Member VIP Member

    Their is a name for that ;)

    strace

    I plan on using strace on SystemServer AND InputManager just to see whats going on.

    But its too late for that and i have to be up at 6 for work so.....

    And after work depends on what I have going on.
  21. megaghostgamer

    megaghostgamer Well-Known Member

    If you need anything let me know, If you could hand me over the Rom ill pass it through BigSplit on XDA, he's really great at fixing things like this, just to give you an idea of what he does, he can find and fix the error in the logcat super quick, he's made a chinese Rom ( MokeeOS ) that doesn't have 4G run 4G. I'll be sure to run this logcat by him tomorrow ( of course when we all wake up ;) ) . Thanks for the great work and whenever your done could I use your rom as a base to port over paranoid , aokp and aosp? Only if you don't mind of course :) Let me know if you need anything and have a great day! :)
    Thanks for your contributes! :)

    P.S. By looking at the video, I can see that its a super easy fix! Its got to be an easy fix! Also, I think I might can port over the LG UI if you get this working, cause I already have the ICS System dump. I've been trying to port it to my Evo Shift but no luck with some apps but, it should be WAY easier porting it to a device it was meant for :)

    Another P.S. I'm looking through your CM9 with renamed sensors and the following line I've found have issues,
    719,721, and lots of permission problems after that. ( what it looks like to me ) I'm not the best with logcats. Thats why I've got BigSplit lol :) Also I'm currently trying to port Jelly Bean to the Evo Shift with a very very simple method ( which takes over 15GB out my 110GB HARD DRIVE!! ) that ports it over. All I would need is a ICS Base :)

    Thanks again! :)
  22. sonicmerlin

    sonicmerlin Active Member

    Wow nice. Quick question though.. Will this make porting CM10 easier? Or will that require a separate and equivalently herculean effort?
  23. hollywoods14

    hollywoods14 Well-Known Member

    kick ass ... never used CM, love the boot animation.
  24. death2all110

    death2all110 VIP Member VIP Member

    Unknown and its not in our focus right now, but we will look into it once this is stable.

    The Device/Vendor trees are on github.

    Same place they have been since i originally started.

    the package manager permission warnings are nothing. its because i didnt flash GAPPS. no point when we cant get past the boot ani

    as for the dex-opt magic number error:
    AKA also not a big deal
  25. death2all110

    death2all110 VIP Member VIP Member

    Just a heads up, still hanging on input manager.....

    Stracing the zygote didn't help much....

    The issue is

    poll_delay with the sensors
    and input manager hanging up on us.

    Input manager might be hanging because of the poll_delay issues.

    Man I could really use some help.... just sucks when me and Playfulgod are at a loss....
Loading...

Share This Page