[UPDATED] How to install Froyo on your Transform [UPDATED]Tips


  1. [TheAndroid]

    [TheAndroid] Well-Known Member

    Luckily I applied this fix and still had it hanging around on my computer. I just uploaded the file now.

    Camera-Flash-Fix.zip
    bryanaz likes this.
  2. enmityxero

    enmityxero New Member

    EDIT: Sorry, I missed a portion of the tutorial...

    Great tutorial, but I would recommend not having multiple Step 1's...
  3. [TheAndroid]

    [TheAndroid] Well-Known Member

    I just have it there so people understand they have to root their phone and if they don't have root, they can just keep reading the guide to root and apply Froyo. It's kinda for simplicity, I just hope people don't get confused... Did you at all get confused with having 2 step ones?
  4. enmityxero

    enmityxero New Member

    So I rooted my phone, but when I connected it to my computer via usb, the phone is no longer recognized. Any clue how I can fix the usb storage?
  5. bryanaz

    bryanaz New Member

    I just used the microSD to SD converter that came with the Transform. Seems to be much easier if you have a card reader?
  6. twistedsense

    twistedsense Well-Known Member

    I flashed vampirefo's kernel and recovery a week or two ago so I could root my phone for titanium backup and now after reading and rereading and reading some more i think i feel ready to flash froyo. Can I reflash the kernel and ext4 recovery without bricking my phone? I used the regular recovery file the first time. I want to follow the directions to a t but i've already flashed and don't want to mess up.
  7. flug

    flug New Member

    One step that many of us might have to complete--right after rooting the phone and doing the backups, when I followed the step "connect your Transform to your computer and enable USB Storage" Transform wasn't showing that it was connected to USB (or giving me the option to mount the sdcard) and so SDCard wasn't showing up on my computer in Explorer.

    The solution is to install the Samsung USB drivers, which can be found at:

    Samsung downloads (click on 'software')

    After installing those and plugging in the USB cable, then I received the notification on the Transform about the USB, I selected the option to mount the sdcard. Then the Transform showed up in Explorer and I was able to proceed.

    Also:

    Step 10.5, the when you type ext4 in console it should be lower case--ext4 rather than EXT4.

    (I thought I saw an error or two when it was running ext4, but they flashed by so fast I couldn't tell if it was anything serious or not.)

    And:

    It was a bit confusing that the first few steps mention the SW Updater and Kernel/Recovery file, but they are not linked. As the next message mentions, the links can be found on the thread at the SDX Developers forums. Note that you must register at those forums to download the SW Updater file. (It only takes about 2 minutes, no big deal.

    And:

    After complete the process and rebooting:

    1. Go to Market. As you do so it will ask you for your google account login info, which will start the process of restoring your contacts & email.

    2. Install Titanium Backup. Start it up and get all its little issues solved.

    3. Click on backup/restore and go through any applications you want to restore (click on the name, then 'restore'). You may not be able to restore all of them (apparently because they don't have Froyo compatible versions?). The ones you can restore are marked with "M".

    With those minor adjustments and additions, it seems to have worked! I'm booted up into Froyo with ext4 (at least, I think it is with ext4--not sure how to check if that part really worked) and so far it's working fine.

    It takes it about 45 seconds to boot up, which is quite a bit quicker than it used to be.
  8. flug

    flug New Member

    In addition, the Fn + c (which should give =) gives .com instead.

    The smiley face button (next to Fn, Sym, and @) doesn't seem to do anything at all.

    That's all I've noticed so far. Have to switch to a soft keyboard to type -,_, or =, I suppose.
  9. [TheAndroid]

    [TheAndroid] Well-Known Member

    Yes, well most of this guide comes from a guy named NYCE here on Android Forums who copied the rooting and guide to going Froyo from SDX Dev. I've done just a few minor changes here and there, not very much to be completely honest. I'm just trying to keep the guide simple and up to date. Now that you've made some good feedback, Ill be sure to change the guide to make it more simple to understand, follow, and easier access links. Thanks for the feedback again. As for the key problems, they're being fixed on SDX and will probably be fixed in the release of RC3.

    As for typing EXT4 instead of ext4, I did it in caps just because of my MSDOS training. In DOS you can do either lower case or uppercase when typing something into the prompt. I know this is Linux, but I'm pretty sure it follows the same basic structure.
  10. twistedsense

    twistedsense Well-Known Member

    Ok I installed Froyo. That was the easy part. Now I am trying to restore my files from Titanium Backup Pro. It is not seeing any of my backup data from the SD card. How do I restore backups I cant see? And I installed Froyo with the ext4 recovery file it that matters.

    UPDATE:
    My titanium backup folder was erased! I can only imagine that when i reinstalled it the program for some reason erased the files. Thankfully I downloaded Dropbox and copied everything to my computer. Now my question is should I just restore my apps but no system data? Or would it simply prevent me from restoring 2.1 system data over the 2.2 data?
  11. [TheAndroid]

    [TheAndroid] Well-Known Member

    Go and open up Titanium Backup, then press the menu button. Press 'batch' now look at all the different types of things you can restore like 'apps only' or 'system data' ect. Pick the one that best suits you and your wants... Make sure you backed up whatever data your restoring as well. Run the batch file and keep your phone by you. Since you probably don't have Pro like I do, when its dnew downloading an app, youhave to press okay for tthe batch file to continue processing unlike in pro where you grab a coffee and come back to find your phone is almost done re-downloading all ofit's apps. Anyhow I hope this worksfor you. Any more issues feel free to post them below. Ill answer them tomorrow morning/afternoon.

    Edit: Okay Dropbox saves a life. Haha, you can restore system data as well. The real changes with 2.2 arn't very systematic, the update consists mostly of advanced drivers and cleaner software. System settings I would restore, it shouldn't give you any issues.
    twistedsense likes this.
  12. twistedsense

    twistedsense Well-Known Member

    Okay I got it restored. Whew! That's a load off. Might be good to mention that to get TBPro to see the files, if anyone runs into the same problem as me, that you need to reboot the phone. After I had redownloaded TBPro it would not see my previous backups until I rebooted. Thanks TheAndroid for your help. If this goes well I might be doing all this to my wifes phone.

    One last question, is there any advantage to ext4 for my sd card?
  13. [TheAndroid]

    [TheAndroid] Well-Known Member

    Well ext4 is a Linux native file coding system, and since Android is based of a Linux kernel, it makes your phone have the ability to access things much quicker than with other formating styles like rfs which is insanely slow... Basically ext4 = speed :)
  14. twistedsense

    twistedsense Well-Known Member

    Since I am doing this on a Windows XP machine I'm assuming I'll need some kind of third party software to do it. Also will I be able to just transfer over music from my computer, which is obviously NTFS to my sd card still? Would windows still recognize the sd card?
  15. [TheAndroid]

    [TheAndroid] Well-Known Member

    To do what? And for transferring music, just mount your SD card to your computer, it'll transfer fine.
  16. twistedsense

    twistedsense Well-Known Member

    Will I have to have a program to format my sd card to ext4? Its not exactly a choice on XP
  17. [TheAndroid]

    [TheAndroid] Well-Known Member

    Haha not at all! Your SD card doesn't need to be formated
  18. twistedsense

    twistedsense Well-Known Member

    Okay, I wasn't sure if I formatted my SD card to ext4 if the phone would be able to read the card faster too.

    I've been reading about partioning the sd card into 3 different areas with 3 different formats. anyone ever tried it? seen any performance?
  19. shahhere

    shahhere Member

    The Android please put the "Updated" date in the title for ease of use when accessing this thread.

    Shahhere
  20. [TheAndroid]

    [TheAndroid] Well-Known Member

    I currently do not have the ability to do that.
  21. mbaldwin622

    mbaldwin622 New Member

    Does anyone know how to revert your Transform back to stock 2.1 after installing the froyo 2.2 update found on this site?
  22. [TheAndroid]

    [TheAndroid] Well-Known Member

    Check your thread.
  23. [TheAndroid]

    [TheAndroid] Well-Known Member

    Bump.

    Just keeping the guide easy to find for everyone.
  24. Cooper271

    Cooper271 Well-Known Member

    One problem I'm having: I plug my phone in, and when USB debugging is enabled it says "USB device not recognized". When it is disabled it will go through all the drivers fine, but then when I mount the SD card the removable drive in my computer is completely empty.....

    I'm not so worried about that, more about it not registering with my computer when the debugging is enabled.

    Although, my laptop is giving an error about a USB power surge.....

    EDIT: Downloaded PDAnet, now the only time it gives an error and makes me search for new drivers is when I get to the step in SW Upgrade where you connect your phone to your computer the first time...
  25. Cooper271

    Cooper271 Well-Known Member

    Ok, so I got it to work by switching to a desktop. The camera fix put me into a boot loop though. I took my battery out, and it started up but then the android system kept crashing. Going to restore to the backup.


    EDIT: Restored from backup, reinstalled everything, and reinstalled camera fix. Works now! Thanks TheAndroid!
Loading...

Share This Page