[updated] Root T-Mobile LG L9 (P769)


Last Updated:

  1. mingkee

    mingkee Active Member This Topic's Starter

    Joined:
    Jul 29, 2010
    Messages:
    33
    Likes Received:
    5
    Prerequisite:
    • You must install LG United Driver (simply change the phone USB mode to LG mode and install PC Suite).
    • You must enable USB debug mode (in developers option) and "unknown sources" (in security option).
    • Download and unpack Root and Restore.
      http://forum.xda-developers.com/showthread.php?t=1886460
    • Download the attached RunMe_L9.txt and change the extension to .bat, and put it to where the unpacked folder is.


    Are you ready? Here it goes:
    • Hook up your phone and choose USB LG mode. Make sure you see a bug on the top-left of screen.
    • Open Root and Restore folder->run RunMe_L9.bat
    • You will be prompted to restore data. Look at the phone screen and choose "restore my data" when prompted, and press any key after the restore has finished.
    • The phone will reboot. Check the terminal window and check for "(are you rooted?)" error. If there's no error, check the phone to see "Android is updating". If so, the phone should be rooted.
    • Download and install busybox and SuperSU.
    • Done.

    Happy Rooting!
     

    Attached Files:


    Advertisement
  2. cacau

    cacau New Member

    Joined:
    Dec 30, 2010
    Messages:
    1
    Likes Received:
    0
    It works just fine!(L9 P760 EUR). One or two things you have to pay attention:
    - Root BEFORE the OTA update, most have the 10a firmware version, it's still doubtful if this method works 100% with later fw.
    - After rooting install Voodoo Root Keeper so you can preserve root after update.
     
  3. ethyr2000

    ethyr2000 Member

    Joined:
    Nov 5, 2008
    Messages:
    7
    Likes Received:
    1
    Just checked my version. Has anyone tried?
     
    BIONICLE38 likes this.
  4. Beermantm

    Beermantm New Member

    Joined:
    Aug 2, 2009
    Messages:
    1
    Likes Received:
    0
    it works
     
  5. djru5h

    djru5h New Member

    Joined:
    Nov 29, 2012
    Messages:
    4
    Likes Received:
    0
    doesnt work for me.. how do i verify which firmware ver i have? did not see it under hardware or software settings
     
  6. K01N

    K01N New Member

    Joined:
    Dec 9, 2012
    Messages:
    4
    Likes Received:
    0
    I have, with couple different root versions multiple times. My 10e phone just won't take it, and I didn't even get a chance to try a 10a-d version as they are selling them with 10e installed now.



    Nevermind- this version DID work for me. The other versions I tried did not fully stop the restore tool thus restarting too early before the files could copy.

    This version worked perfectly though, even on 10e. Thanks to all who worked on this. I hope this phone becomes very popular because it's been great so far! Can't wait to clean it up and see how it shines.:D
     
  7. carmine92207

    carmine92207 Member

    Joined:
    Sep 9, 2011
    Messages:
    13
    Likes Received:
    0
    Help us all that have this phone. Is there a root for the 10e and if not how do we roll back to 10a.

    Also this phone is great but i have 32 gb sd card thats useless cuz can move anything on to sd please help.
     
  8. waramey25

    waramey25 New Member

    Joined:
    Dec 18, 2012
    Messages:
    1
    Likes Received:
    0
    Worked for me on 10E P769!! Rooted!!
     
  9. carmine92207

    carmine92207 Member

    Joined:
    Sep 9, 2011
    Messages:
    13
    Likes Received:
    0
    Finally rooted now need custom roms lol
     
  10. Supamike88

    Supamike88 New Member

    Joined:
    Dec 20, 2012
    Messages:
    2
    Likes Received:
    0
    the drivers dont seem to be installing for me
     
  11. saltydogtony

    saltydogtony Member

    Joined:
    Mar 15, 2012
    Messages:
    5
    Likes Received:
    0
    So, i renamed the file like i was suppose to but it didnt change the format to a .bat i had to open the .txt and edit and re save it as a .bat and it worked! i ran the .bat and wahlah! my phone became rooted. I am having trouble with the pc suite seeing my phone. and I still do not know how to save any apps to sd card. and that was my main goal in rooting. maybe i need more practice.
     
  12. Supamike88

    Supamike88 New Member

    Joined:
    Dec 20, 2012
    Messages:
    2
    Likes Received:
    0
    All rooted now. Thanks guys
     
  13. carmine92207

    carmine92207 Member

    Joined:
    Sep 9, 2011
    Messages:
    13
    Likes Received:
    0
    So any recovery rom
     
  14. jims89

    jims89 New Member

    Joined:
    Nov 30, 2011
    Messages:
    2
    Likes Received:
    0
    I got the PC suite installed, but when I try to connect my phone in LG Software mode, it keeps disconnecting and reconnecting constantly (seriously once every 5-45 seconds), and meanwhile PC suite tells me it failed to connect to the phone. Windows 7 / P76910e. Anyone else have this problem and get it fixed?
     
  15. aequitas3

    aequitas3 Well-Known Member

    Joined:
    Mar 22, 2010
    Messages:
    184
    Likes Received:
    44
    jims89 - try a different USB port. If that doesn't work, do a google search for lg optimus l9 drivers and go to the link to LG mobile support (should be the second link after search)

    carmine92207 - no recovery rom in the works for this phone...as of right now. locked bootloader and no devs working on figuring out how to unlock the bootloader that I have been able to find out.
     
    carmine92207 likes this.
  16. steamingbiscui

    steamingbiscui New Member

    Joined:
    Dec 25, 2012
    Messages:
    4
    Likes Received:
    0
    Worked perfectly, now to figure out which apps are removable.
     
  17. wilwarin

    wilwarin Member

    Joined:
    Sep 19, 2011
    Messages:
    10
    Likes Received:
    1
    Just ignore this, you don't really need to connect your phone to the program. Its the drivers the programs installs that you actually use to root. My phone did the same thing and it rooted just fine.
     
  18. carmine92207

    carmine92207 Member

    Joined:
    Sep 9, 2011
    Messages:
    13
    Likes Received:
    0
  19. Sesameopen

    Sesameopen New Member

    Joined:
    Dec 30, 2012
    Messages:
    1
    Likes Received:
    0
    I followed all your directions, but it keeps getting stuck at ======================================================================
    = This script will root your Android phone with adb restore function =
    = Script by Bin4ry (thanks to Goroh_kun and tkymgr for the idea) =
    = Idea for Tablet S from Fi01_IS01 =
    = (13.10.2012) v15 =
    ======================================================================

    Device type:
    1) Normal
    2) Special (for example: Sony Tablet S, Medion Lifetab)

    x) Unroot

    Make a choice: 1
    Checking if i should run in Normal Mode or special Sony Mode
    Please connect your device with USB-Debugging enabled now

    And I put it into usb debugging mode. HELP??
     
  20. carmine92207

    carmine92207 Member

    Joined:
    Sep 9, 2011
    Messages:
    13
    Likes Received:
    0
    Just keep trying it took me a week
     
  21. aequitas3

    aequitas3 Well-Known Member

    Joined:
    Mar 22, 2010
    Messages:
    184
    Likes Received:
    44
    Sesameopen - if you're asking if you should run in normal or special, you should do normal. You shouldn't run into any problems if you're running the newest script.
     
  22. ahmedalhalabi

    ahmedalhalabi New Member

    Joined:
    Jan 5, 2013
    Messages:
    1
    Likes Received:
    0
    Hi,

    I am getting to the process until it says:
    ----------
    Please look at your device and click RESTORE!
    If all is successful i will tell you, if not this shell will run forever.
    Running ..
    =========

    my device prompts me to restore. when I click on "restore my device", I get a "restore starting" message and then "restore ended", and the command prompt gets stuck at this point (running).

    any suggestions?
     
  23. Unitzero1

    Unitzero1 New Member

    Joined:
    May 2, 2012
    Messages:
    2
    Likes Received:
    0
    This same thing happens to me ONLY on my Win XP PC. I cant copy to my phone, but I can copy from. Now on my Win 7 laptop, all I need is the phone drivers, I dont even need the Suite and it still works (copy and paste to/from the phone)
     
  24. mjb1994

    mjb1994 Member

    Joined:
    Jan 19, 2013
    Messages:
    5
    Likes Received:
    3
    after rooting with this method i keep getting the low on space message, anyone else getting this?
     
  25. WaltW

    WaltW New Member

    Joined:
    Feb 22, 2011
    Messages:
    1
    Likes Received:
    0
    I have TM P769 with "e" firmware. I am getting "The system cannot find the path specified" messages when the script tries to push the files (busybox, su, Superuser. etc.). The script has "/data/local/tmp/." for the destination directory. I see this directory structure on the phone -- "Computer\LG-P769\Internal storage" -- and no data subdirectory. I am guessing that is why the script cannot find the path. I am running the script from a folder on the Windows 7 Desktop. I am using the new, renamed L9 bat file.

    EDIT: I think I am OK now. After reading another post I opened the "stuff" directory on the PC and ran the adb.exe file. It opened a window, ran a quick script and closed. After that the L9 bat file ran with no "path not found" messages -- and the SuperSU app was installed.
     

Share This Page

Loading...