[updated] Root T-Mobile LG L9 (P769)


  1. xandroiduser

    xandroiduser Member

    Okay, I have been at this all day, so I'm just going to break this down for you guys:

    *I am a beginner, but I have a little experience (if this makes any sense).*

    Goal - root phone, remove pre-installed bloatware, and download and use the free WiFi tether (that requires the phone to be rooted, of course). [Side note] If there are any custom ROMs available for my device (the LG Optimus L9 [T-Mobile prepaid]) then I may try those, too, but I'm cool with the phone as it is; I just need to tether my 4G to do homework on my computer.

    Now, my device automatically installed its drivers onto my Windows 8 computer after connecting it and selecting the "LG mode", so I have that down pat, I believe. I have also downloaded the RunMe_L9.txt file, opened it, saved as ".bat" (literally just .bat; nothing else), and ran the file as an administrator, but all I get is a bunch of "path cannot be found" followed by "press any key to continue", ending with "after your phone reboots, you will be rooted. Enjoy." The problem is: my phone didn't reboot, I am still not rooted, and I'm certainly NOT enjoying it.

    So, I'm thinking it isn't working because I don't have that Root and Restore file downloaded and extracted, but it just seems null at this point since I'll only be opening the RunMe file, right? Also, if that's not the case, how am I supposed to download the required files with NO internet? I downloaded them on my phone and transferred them to my computer, but, for some odd reason, the Root and Restore file isn't something I can "extract" and/or "unpack". So, what am I to do? Does anyone have any suggestions? Please respond as soon as possible, but at your earliest convenience.

    Thanks in advance,
    D.
  2. croakthedj

    croakthedj New Member

    so I ran the runme.bat then it went through all the steps it said my phone was going to restart and it never it. I am restarted and tried 8 times so far. I know I may be a noob but can I have some help.
  3. croakthedj

    croakthedj New Member

    ======================================================================
    = This script will root your Android phone with adb restore function =
    = Script by Bin4ry (thanks to Goroh_kun and tkymgr for the idea) =
    = Idea for Tablet S from Fi01_IS01 =
    = (13.10.2012) v15 =
    ======================================================================

    Device type:
    1) Normal
    2) Special (for example: Sony Tablet S, Medion Lifetab)

    x) Unroot

    Make a choice: 1
    Checking if i should run in Normal Mode or special Sony Mode
    Please connect your device with USB-Debugging enabled now
    The system cannot find the path specified.
    The system cannot find the path specified.
    The system cannot find the path specified.
    .
    .

    Normal Mode enabled!
    .

    The system cannot find the path specified.
    Pushing busybox....
    The system cannot find the path specified.
    Pushing su binary ....
    The system cannot find the path specified.
    Pushing Superuser app
    The system cannot find the path specified.
    Making busybox runable ...
    The system cannot find the path specified.
    .
    The system cannot find the path specified.
    Please look at your device and click RESTORE!
    If all is successful i will tell you, if not this shell will run forever.
    Running ...
    The system cannot find the path specified.
    Press a key to reboot the phone
    after restore has finished
    Press any key to continue . . .
    The system cannot find the path specified.
    Waiting for device to show up again....
    The system cannot find the path specified.
    Going to copy files to it's place
    The system cannot find the path specified.
    You can close all open command-prompts now!
    After reboot all is done! Have fun!
    Bin4ry
    Press any key to continue . . .
  4. xandroiduser

    xandroiduser Member

    This is the same message I am getting, too. What are we doing wrong? I know someone has the answer!
  5. rbraswell8

    rbraswell8 Member

    are you on the new 10g firmware? if so we haven't found a root method as of yet, so hang in there.
  6. xandroiduser

    xandroiduser Member

    How am I to know that? I guess it's the new firmware, though, because I've been fervently trying...
  7. rbraswell8

    rbraswell8 Member

    alright, go into settings, about phone, software information, the software version should read something like p76910g. if it's anything before 10g, you should be able to root it.
  8. DatNexus

    DatNexus Member

    How risky is this method? I have no money left to replace it if I brick it. Yes, I am a tad paranoid about new devices.
  9. rbraswell8

    rbraswell8 Member

    all you really risk is a minor waste of time. if it doesn't work, it does absolutely nothing to the phone.
  10. DatNexus

    DatNexus Member

    Just making sure. I'll give this a shot.

    EDIT: Root achieved! Thank you all. How might I go about deleting T-Mobile crapware? On my triumph I flashed CM9 right after I rooted and installed recovery, so I never had to learn how.

    EDIT 2: nvm link2sd has an uninstall option. All who are rooted give this a try:
    http://forum.xda-developers.com/showthread.php?t=1987032
    It made a modest difference for me.
  11. xandroiduser

    xandroiduser Member

    Okay, it's showing as P76910e. What do I do from here? In fact, can anyone with the exact steps (with the exact software version) even attest to rooting their phone with this process? If so, can you please give me a detailed step-by-step run-down of how exactly to do it? I really, really need to utilize the Free WiFi Tether (for root) app so I can get my classwork done by the 30th!

    Remember, I have fulfilled all of these prerequisites, so I am going to need either a new method or someone needs to explain what it is I am doing wrong by detailing exactly how it is supposed to go.

    Thanks in advance,
    D

    *Edit* IT WORKS!
    I guess the problem was that when I downloaded the prerequisite files from my phone and then transferred them to my computer, it was incomplete in some way. I was able to extract and run them appropriately when connected to my neighbor's Wi-Fi (shh). Thanks, guys!
  12. mihaianti

    mihaianti New Member

    i have a phone from orange romania lg p760 with software ver 10f , this method of rooting did not worked for me.
  13. jshx2

    jshx2 Member

    Thank you this worked great for me on 1st try and took about 10 minutes. My phone is L9 p769bk with 10e. Follow step exactly and make sure lookout is disabled, sometimes peploe don't know to check that.
  14. ethyr2000

    ethyr2000 Member

    Do updates remove root? I haven't installed yet.
  15. jshx2

    jshx2 Member

    To remove bloatware get Titanium Back up. If you are torrent friendly then you can find the pro version online in apk format for free. That allows you to freeze programs from starting and there is no need to remove them.
  16. d1same

    d1same New Member

    I purchased two phones for my parents. 10e worked perfectly. but one of the got updated to 10g and this method didn't work.
  17. jshx2

    jshx2 Member

    This worked great for 10e but now 3 days later my phone wants to update to 10g. I know this will kill my root and possibly my chances to root again. I cant seem to find a safe way to block the ota updates. Any idea that is not a real brick risk? Thanks for the help:)
  18. mjb1994

    mjb1994 Member

    I was able to keep my root after doing the OTA update to 10g, all I did was before I updated installed voodoo root keeper, backup my root with it, then updated to 10g, after the update I went back in with voodoo and chose to restore root then VOILA i am now rooted on 10g with my p769
    aequitas3 and jshx2 like this.
  19. jshx2

    jshx2 Member

    This sounds good and I will try. Do I need to do the temp unroot right before I do the actual update?
  20. mjb1994

    mjb1994 Member

    I did not select temp unroot when i did it. Just make sure it has the backup of your root! When it reboots after updating, head on over to VooDoo RootKeeper and select Restore Root. Congrats your on 10g and rooted!!!!
    jshx2 likes this.
  21. jshx2

    jshx2 Member

    Thanks for all your help mjb1994. It did not update but I do not get the ota update promts anymore. When I tryed update after backing up the root it gave me an error about google something. I realized that I had to probably unfreeze all google stuff(which stilled showed frozen with titanium pro during supposed unroot) and tryed to update through the phone. My phone said it was up to date and is oddly still on 10e. The update prompts that shwed up every 30 min have not shown up almost a day later. I am happy with this so thanks!
  22. aequitas3

    aequitas3 Well-Known Member

    Just saying that the Voodoo OTA Rootkeeper app on the play store does indeed allow you to keep root after the 10e to 10g update.
  23. xandroiduser

    xandroiduser Member

    I wonder what I'm doing wrong then...
    I am rooted and my root is backed up on voodoo ota root keeper, but, yesterday, when trying to restart and install the update, I was presented with an upside down android with a red triangle hovering above him.

    I did some scouring online to see if anyone else had this issue and I found nothing. I did find that it's people with other phones were having similar issues, though, and it is/was because they didn't have a system/custom recovery. I don't even know how to access the recovery (boot into it), nor do I know how to obtain the update again.

    I'm currently running v10e, and this version doesn't allow me to tether my 4G (meaning I have no internet access on my laptop, and everything I have to do online has to be done from my phone--including homework [which sucks]). The v10g update resolves this issue, but I can't access it!

    Does anyone know what I should do?
  24. quicke

    quicke New Member

    I stupidly hit the update button before reading this thread didnt have voodo installed and no more root access. any other work around? I've been seaching my a## off and nothing. I woldnt have to root if they didn't take away the capability to run files from sd. Well thats a lie, I'd probably root anyway. lol
  25. niufei8888

    niufei8888 New Member

    It doesn't work for me. The console shows "Are you root?" ERROR. Could anyone help me on this? Thanks
Loading...

Share This Page