Updated to Jelly Bean - unable to send SMSSupport


  1. I updated an unlocked S2 GTi9100M to Jelly Bean and it relocked to Bell Canada. $40 dollars solved that but now it will not send a text, receives OK. Am with Rogers, Canada.

    Have tried a Factory Reset, no success. Is there an easy fix?

    Many thanks.

    Advertisement
  2. kelis32

    kelis32 Well-Known Member


    Sounds like you have lost your message centre settings, SMS Screen -> Menu Soft Button -> Settings

    not much help on their website tho

    I
  3. Took a look at the Settings and all in order, Rogers Tech agreed. Spent an hour with Rogers Tech after trying different SIM cards, and the original SIM in a different phone. Definitely a phone problem rather than a SIM.
    A test text to Rogers Tech did go through but a text to another cell phone did not. Back at square one.

    Thank for the advise but still waiting for a solution.
  4. kelis32

    kelis32 Well-Known Member


    Are you using the stock messaging app, if so it may be worth trying a market app like go sms to see if that helps
  5. Problem solved.

    Somewhere in the process of downloading Jelly Bean, being locked back to Bell, and unlocking, the phone decided to place the person who sends most of the texts to me into SPAM. I finally checked that, should have been the first item to check.

    Hopefully this will help someone else.
  6. kelis32

    kelis32 Well-Known Member


    Glad its sorted, if you are rooted you can back up your EFS folder so that you can flash back if you run across any problems when updating again.

    Its a common problem with unlocked phones getting relocked after an update so paying out $40 a time is not the way to go
    michaelzrymiak likes this.

Share This Page