Updates failing with (403) errorSupport


Last Updated:

  1. Mahalo

    Mahalo Well-Known Member

    Man, I am getting seriously chapped... these failed updates and/or downloads from Google Play (asinine name that it is if they want to try and make it in the business market...) for not only apps that are free but ones I have paid for are killing me...

    I've tried using wifi, 4g, 3g, push from play.google.com and am unable to update my dang phone.

    I've factory reset, I've tried new ROMs, new kernels, tried flashing the google play cache... I'm at my wit's end! Anyone else have the same issue who was able to resolve it? Gahhhhh! I have not being able to get something I paid for! App Developers tell me it is googles problem... I explained to them that it isn't their problem, it is my problem, but it may be googles fault.
    /vent

    Advertisement
  2. OfTheDamned

    OfTheDamned The Friendly Undead VIP Member

    I ran into this exact same problem and tried multiple things. The only thing that worked for me was to go into settings > apps > all apps and find the play market then uninstall updates. This reverted back to the old Android Market and I was able to update everything that needed updating. After I did that I hit the home button and left it alone for about 15 minutes. When I opened it back up the update to Google Play was there and once I updated everything was normal again.
    Mahalo likes this.
  3. Mahalo

    Mahalo Well-Known Member


    Grrr.... the ROM I'm on had GAPPS built in so wasn't updated. Time to test a new ROM again. Thank you for the advice!
  4. OfTheDamned

    OfTheDamned The Friendly Undead VIP Member

    Just for the record, I'm on the 4.0.4 update
  5. Mahalo

    Mahalo Well-Known Member

    Looks like it could have been the market installation.... or "Play" installation. I'll notify the ROM Devs.
  6. stpbby

    stpbby Well-Known Member

    I had this same issue. Reinstalled the latest Gapps from the AOKP thread on Rootzwiki and it resolved it.
  7. Roseg7068

    Roseg7068 New Member

    I have a Samsung Galaxy SII and I have a Samsung Galaxy Tab 10.1 with wi fi only. I have noticed I get this error when I update apps or download new apps over WI FI. I am able to download my apps updates or new apps via 3G without a problem, I have to Tether my Galaxy Tab to my mobile phone 3G to be able to update apps or download new ones, otherwise I get error 403 over WIFI. I believe its a Google Playshop issue and WIFI. I have tried all suggestions, ie clearing cache, etc etc nothing works. I am very happy with Android and apps but this error or issue is disheartening.

    PS My Samsung Galaxy Tab and My Samsung SII rocks love'em
  8. Roseg7068

    Roseg7068 New Member


    I hear you my friend ! I tried all sorts of stuff but Play Store and WiFi just dont work, my next thing that I will be looking at to resolve is my router to see if there is a block there, again updated my tab today via 3G without a drama ! its definitely a PlayStore issue and WiFi not our issue, hello google fix it ! now !
    Mahalo likes this.
  9. Mahalo

    Mahalo Well-Known Member

    It happened again on another ROM, this time I cleared the cache in Google Play Store under All apps in Settings and it appears to be working so far (WiFi and 4G)

    I'll post again if I have more problems.

    Thanks for the sympathy and advice, all!
  10. GWOOD

    GWOOD Member

    A fix that worked on my home wireless network was to review filters that were set on my Linksys/Cisco Router. I unchecked "Proxy" filter and re-tried Google Play and now everything (updates, apps, music, etc) works on all devices.
  11. tecknopuppy

    tecknopuppy New Member

    I just bought a Nexus 7 as a gift for my dad for Christmas and I too was getting these 403 errors for all updates and downloads (free or paid).

    I called Google Play Application support and they told me to reboot, clear the cache, and also told me that the app server was down and to wait 24-48 hours...

    ...after I read this thread, I thought it made sense that the router had some strange security settings...

    The fix for me was to reset the router to factory defaults and re-setup without crazy security settings. I think my updates and downloads would have worked on another random router.

    Just thought I would let people know. :)
  12. Petrah

    Petrah Psychotic Female Guide

    I got this error earlier while we were out and about when I was trying to download an app to my boyfriends G-Nex. Putting the phone in airplane mode and back to 4G a few times seemed to fix it. I've never seen this on my own G-Nex though.
    tube517 likes this.
  13. heartswarm

    heartswarm Member

    The same thing happened to me a couple of days ago. I was able to correct it by removing my google account and adding the same account again.

    settings>accounts>google>accounts>remove account

Share This Page