UpdatesGeneral


Last Updated: 2012-07-19 21:46:20
  1. KimB

    KimB Member

    Does anyone know if the X2 is getting any updates? I'm 2.3.5 and getting close to upgrade time. Thanks.

    Advertisement
  2. Scur

    Scur Well-Known Member

    If there are any more, they will only be 2.3.x since the X2 isn't on the official list to get ICS. So odds are that you'll never see anymore updates that will really change your phone that you can notice.
    Ronk2010 likes this.
  3. KimB

    KimB Member

    Thanks for the info. I kind of suspected as much but was hoping for something else!
  4. coolpoete

    coolpoete Well-Known Member

    Custom ROMS are the way to go. The famous DragonZKiller is working on porting jellybean over to this phone. I really admire the guy's enthusiasm.
  5. Scur

    Scur Well-Known Member

    True, and I'll stick with my X2 for as long as I can, but if it's upgrade time, there definitively are bigger and better out there now. The X2 is coming close to the end of how far it can be pushed.
  6. coolpoete

    coolpoete Well-Known Member

    Indeed! I am starting to believe now (in cm9 as a daily driver) as dzk is working on kexec and as a result will eventually be able to work in a new kernel. Can you believe they got JB on a HD2?! (although limited) crazy stuff!
  7. Scur

    Scur Well-Known Member

    Yeah, my phone's messed up though. Can't flash any custom ROMs on it anymore.
  8. coolpoete

    coolpoete Well-Known Member

    Whaat?? How did that happen? Can't SBF either?
  9. Scur

    Scur Well-Known Member

    I think that CM7 had something to do with it. I've flashed it twice before. The first time was hell coming back to stock, I thought my phone was bricked for about an hour. It took multiple boot attempts, battery pulls, and button mashing before I finally could get back to RSD mode to flash a SBF.

    Everything seemed fine for a couple months, until I tried CM7 once again. When I tried to come back off of it the second time, RSD gave it a PASS at the end instead of hanging on REBOOT PHONE MANUALLY like it always did before. Now I can still flash a SBF and update an OTA (but only after doing a *228 to download and install it, can't flash an OTA file from recovery), but if I try to flash any ROM (and I've tried a half dozen of them) while using any root method, I get an error while flashing, and have to wipe everything possible to be able to SBF back to stock. Something got messed up, somewhere in an area that both RSD and recovery don't touch. Or at least that's the only thing I can come up with.

    I'm getting ready to try to flash a 2.3.4 SBF using the ezSBF tool. As far as I know so far, this will be the last option I have to straightening things back out, though I'm doubtful it will work.
  10. coolpoete

    coolpoete Well-Known Member

    that's very strange. The only thing I can think of is if you did anything out of the ordinary in terms of using a different RSD program, 2.3.4 SBF (bad download), possibly even a different cable. Are you wiping cache and dalvik cache? Man, that sucks. I hope you get it working again.
  11. Scur

    Scur Well-Known Member

    I've tried 3 versions of RSD, used all 3 SBF files, tried 2.3.4 from a different source, used the same stock moto cable I've always used and another one besides. I can be on rooted stock, but that's it. So it works, all my apps work, but I can't flash a custom ROM. I'd like to be on Eclipse at least for the toggles, but I'm settling for a working phone atm. If anyone needed an unlocked bootloader right now, it's me.
  12. coolpoete

    coolpoete Well-Known Member

    I'm a bit confused..
    Are you having problems rooting or flashing specifically? If you for instance SBF'ed to 2.3.4 and applied the rootkeeper you should still be able to accept the OTA 2.3.5 and get eclipse.
  13. Scur

    Scur Well-Known Member

    Roots fine. I can't *228 anymore (dropped service a month ago), so I can't install an OTA through the menu, and it won't let me flash an OTA. Since I can't live without root, I'm stuck at 2.3.4 now. And when I could, I couldn't flash Eclipse either. I think I tried close to a dozen times. I get an error with every ROM, and I always tried flashing correctly. At first, anyway, since after it always failed I started to vary what I did.
  14. coolpoete

    coolpoete Well-Known Member

    Good luck with the other method, let us know if you get it working!

Share This Page