Upgrade Android 2.1 (Eclair) to 2.2 (Froyo) on your Samsung GT I5800 in 7 EASY steps!Tips


  1. haree

    haree Active Member

    hi
    yes u can use backup pro or titanium backup for the same
    both paid and free version available in the Market:D
    ebt4ever likes this.
  2. engel001

    engel001 New Member

    Hey guys, i installed android 2.2, this is amazing. But when im trying to use websites with adobe flash player, it says i dont have it. I cant seem to download it from market for the this phone
  3. bose2216

    bose2216 New Member

    Please tell me how to install adobe flashplayer in my galaxi GT i5801
  4. ebt4ever

    ebt4ever New Member

    Hi All,

    @haree, thanks for the tip, I've successfully backup and restored my settings/programs with backup pro. It worked almost perfectly

    Now playing with JPF version....great!

    Thanks,

    Ebt
  5. Craig12

    Craig12 Well-Known Member



    i would also like to know how to install flash player
  6. j0nb0y

    j0nb0y Active Member

    my understanding is that it's not just 2.2 you need for full flash, but there is a hardware requirement as well. i think the galaxy 3 will only ever support flash lite.
  7. j0nb0y

    j0nb0y Active Member

    though if you want flash mainly for youtube, then if you have 2.2 you can download the new youtube app which will give you a better experience to that of the youtube app that was pre installed on the phone
  8. sted

    sted Member

    done this and now messaging just crashes when i try to send any text messages any ideas?
  9. j0nb0y

    j0nb0y Active Member

    So after much frustration with Samsung I've finally given up and installed the latest version of froyo from samfirmware (european jpe at time of writing).

    Bit of a newb at this but thanks to instructions on this thread, fairly straight forward. No longer tars and single install files though but rars which you have to extract the contents of and then specify the pda, boot, phone and csc yourself. other than that...thanks samfirmware and android forums!

    o.k. initial impressions. at first it didn't feel like i was getting a speed boost, but then i never felt it was running slow on 2.1.

    gps fix much improved, tethering works as does install to sd. the three major reasons for me to ugrade, so far so good.

    a couple of minor things..

    1. the language defaulted to non english, no probs there i can just switch. however the android market seems to think i'm now in another country (currency dkm ?). Not sure how to tell it otherwise or of the implications of leaving it. Bought Moodagent and it recognised my credit card as being from the UK and did a currency conversion on the fly, but does this mean i might not be able to download some apps that might at the moment only be released in certain countries??

    2. In application management a lot of the apps are showing a zero bytes in size

    3. I now have demo versions of Assasins Creed and Tetris that i son't want and can't remove...thanks Samsung!

    4. The camera crashes after taking a picture

    5. The gallery can't seem to show any of the photos on my SD card even though the music app can find and play the mp3s

    Update.

    I had to reformat my SD card. A bit of a pain as it wiped all my files but i have them all backed up so not too much of an issue. However this has fixed the camera crash and the gallery photo problem (must have been some weird permissions issues) and bizarely it's made my phone run a little bit faster.

    I'll add more as i find it.
  10. j0nb0y

    j0nb0y Active Member

    I wonder if the sd card issues are because I followed the advise of removing it whilst flashing? Perhaps the upgrade process needs to adjust permissions on the sd card? Not to worry, it feels good to have an empty phone again! :)
  11. merlin1976uk

    merlin1976uk Active Member

    has anyone carried out this upgrade on an apollo i5801...NOT the i5800 not sure what the difference is with these two different models lol...hope to upgrade mine soon...but dubious thats all...i want froyo and well samsung are dragging their butts more than a dog with an itchy butt...:D
  12. bjlabuk

    bjlabuk Well-Known Member

  13. Beplexor

    Beplexor Active Member

    Alright guys, since i'm tired of waiting for the official update here in New Zealand, I'll update this and get back to you guys; an extra opinion always helps!
  14. Beplexor

    Beplexor Active Member

    Works beautifully. Thanks for the guide. Love the subtle new layout; I also love how the phone itself works generally faster.
  15. pranay224

    pranay224 New Member

    hi buddy ,just wana ask when i am extracting my .rar file to get the tar file its regularly asking me the password but if i am providing a blank default password then its sasying either password wrong or corrupt file.plz help stucked hear,or just tell me how to getr my .tar file
  16. bjlabuk

    bjlabuk Well-Known Member

    Pranay224,

    If you are downloading from
    www.samfirmware.com the passwords are indicated by the # or ## at the end of the firmware :

    ## - Password is samfirmware.com
    # - Password is samsung-firmwares.com
    * - file is not complete

    Eg
    if you download the firmware
    I5800XXJF8 # then the password is samsung-firmware.com

    Hope that helps.

    bjlabuk
  17. wat143

    wat143 Member

    I followed this to update my UK unbranded I5800XXJG3 to I5800XWJPF as I got fed up waiting!
    All seems well... thank you!!
  18. bjlabuk

    bjlabuk Well-Known Member

    Yes, download Titanium Backup or Mybackup from the market.

    bjlabuk
  19. stik3nd

    stik3nd New Member

    Hi guys, I read this tutorial and another thousand carefuly, followed all the steps perfectly, and still, I got the same error every time I try to flash.
    My screen looks like this (everything seems fine, right? The .tar is there, the .ops is there, the port is recognized...):
    [​IMG]
    Then I click on "Start" and this happens:
    [​IMG]

    What am I doing wrong?
    I have a Galaxy I5800L, with this version: I5800LVIJG7.
    I was trying to update to I5800LVIJG8 (I downloaded this firmware directly from samfirmware), and then if that worked I was going to update to froyo.

    Does anyone have an idea of what might be happening? I lost hours on this shit and couldn't figure it out.
    Tip: I can't get my phone connected with Kies, but I guess my drivers are ok since Odin recognized the port.

    Edit: Nevermind, did it from work PC and it worked flawlessly. I guess I've messed up my drivers at my home PC.
  20. bjlabuk

    bjlabuk Well-Known Member

    Or you might have a faulty USB port ?

    bjlabuk
  21. stik3nd

    stik3nd New Member

    Maybe, but this port never let me down. I guess I could give it a try on another port. When I get home I'll check this, or I'll leave it alone forever, yeah, probably the second option.
  22. andy1974

    andy1974 New Member

    I've followed this thread and got the JPF firmware to download to the phone however when it reboots it hangs at :


    -- Delete App data..
    Delete files. please wait.

    so far i have tried 2 firm wares and tried 3 times also tried pressin HOME ->UP>Power instead of Home>Down>Power

    Any suggestions on how to Unbrick this phone ?
  23. bjlabuk

    bjlabuk Well-Known Member

    Have you tried flashing a stock 2.1 firmware first, say I5800XXJK1 ? I know I had problems the first time I tried upgrading to 2.2. However I follow the steps in the guide exactly every time, particularly the hard resets before and after flashing etc, and don't have any problems.

    Somebody is asking exactly the same question on xda forums

    [Q] 5800 fails to Update during flash - I.e. Bricked - xda-developers

    bjlabuk

  24. harrydahiya

    harrydahiya New Member

    Hi
    I am new to this forum, but found it really good after reading all the steps and question answer on this tech forum.
    I have a GalaxyI5800 phone which i want to upgrade to Froyo 2.2.But i am a little confused as the firmware name of my phone does not match with your ones i the post.
    my phone details are:
    baseband version: I5800XXJG3
    build: ECLAIR.XXJG7
    FIRMWARE:2.1-update1

    I have already downloaded following files:
    I5800_Odin_Multi_Downloader_v4.252.exe
    Odin_with_OPS.zip
    I5800XXJPB.rar
    apollo_0531.zip
    I5800XXJG3_XXJG7_OXXJG5.rar

    Can you help me to understand which files i need to use and what is the exact steps i need to follow.
  25. harrydahiya

    harrydahiya New Member

    and also the process to revert back if upgrade is unsucessfull.
Loading...

Share This Page