Root URGENT: Really Serious Bug in Galaxo 1.5 (probably in android)

Discussion in 'Android Devices' started by atbeyi, Feb 28, 2010.

  1. atbeyi

    atbeyi Well-Known Member
    36

    Jan 12, 2010
    119
    9
    36
    I am using GalaxHero today i tried to fastboot the 4.6.1 recovery, but i just forgot to plug in the cable so in a few seconds the phone booted up, after than i realised that the phone did not ask me for pin, i tried it several times and it never asked me my pin.

    steps to see how it happens:
    1- shut down your phone in any way (by removing the battery/long press the right call button (end button)/ adb shell restart)
    2- boot the phone with fastboot option (long press the two call buttons at the same time)
    3- don't plug in cable if plugged in remove it
    4- wait for a few seconds the usual booting routine will go on (android and theme splashes)
    5- you will see that it does not ask you to enter your pin. but you may make calls, connect to internet as usual.

    can anyone else confirm this? or is it only me?
     

    Advertisement
  2. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    asks me for pin every time, cannot replicate it and im using galaxhero ii5 recovery 4.4
    and yes im doing fastboot each time
     
  3. NoUse4aNick

    NoUse4aNick Well-Known Member
    16

    Sep 16, 2009
    56
    3
    16
    Yeap, I can replicate this scenario also in 1.6. No PIN number asked!

    I7500XXJB2 (official 1.6)
    Recovery 4.6.1
     
  4. davyu

    davyu Well-Known Member
    16

    Dec 19, 2009
    92
    3
    16
    I've flashed my phone like 20 times, cable or not, never asked me for pin... both 1.5 and 1.6. Never realised it was a problem, now that you mention it, yikes!
     
  5. atbeyi

    atbeyi Well-Known Member
    36

    Jan 12, 2010
    119
    9
    36
    last night i talked with drakaz in dev irc channel, he and Willd said that it happens sometimes. as i see not so much person cares about this issue but this is the worst bug i've ever seen in a phone.

    * drakaz said that this maybe a samsung bug. cause it can be redone without galaxo/galaxhero.
     
  6. atbeyi

    atbeyi Well-Known Member
    36

    Jan 12, 2010
    119
    9
    36
    while you normally boot does it ask you your pin? i mean does your pin lock is enabled?
     
  7. NoUse4aNick

    NoUse4aNick Well-Known Member
    16

    Sep 16, 2009
    56
    3
    16
    Of course it is enabled! That is the reason of this whole conversation :)
     
  8. Cougar

    Cougar Well-Known Member
    38

    Aug 28, 2009
    420
    16
    38
    Geek
    Lancashire, England
    Stock 1.6 here, works as intended for me. Switched off the phone, fastbooted, waited for it to time out and reboot, booted to the PIN screen.
     
  9. Cougar

    Cougar Well-Known Member
    38

    Aug 28, 2009
    420
    16
    38
    Geek
    Lancashire, England
    Is it an application causing it maybe? Do you still get the issue after a factory reset?
     
  10. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    since seeing other people can replicate this ive tried over and over.
    i cannot replicate it :( although now i have 50% battery from too many attempts
     
  11. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    Yes it does that for me too, on GalaxHero 1.1.1 (ii5).

    I would guess it's a firmware issue.
     
  12. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    but im on 1.1.1 ii5 !!!!

    could it be to do with providers simcard recognition?
    im with o2uk i cannot bypass pin at all
     
  13. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    I'm O2UK too...
     
  14. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    lol wtf then
    is your sim 8944110063 or 8944110064?
     
  15. eatsleeprepeat

    15

    Sep 28, 2009
    12
    0
    15
    rofl this works for me on stock 1.6 with only spare parts installed. O2UK. Way to go samsung!
     
  16. atbeyi

    atbeyi Well-Known Member
    36

    Jan 12, 2010
    119
    9
    36
    I have tried it with 3 different sim cards
    1- Avea (TR)
    2- Turkcell (TR)
    3- Cosmophone (Macedonia)

    all gives the same with even a factory reseted phone.
     
  17. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    odd

    EDIT

    try this, put sim card into an old phone like a nokia etc and enable sim pin security on that phone then put it back in the galaxy and see if it does the same

    i have a feeling that maybe the galaxy doesnt enable sim security properly thus it having this affect on some of you and not all of us

    i had my sim pin enabled from 3 phones ago and i cannot bypass it at all.

    would suggest its still a bug with galaxy as it means it cannot secure the sim correctly
     
  18. kam187

    kam187 Well-Known Member
    118

    Aug 3, 2009
    1,320
    46
    118
    UK
    Its not possible to use a sim card without entering the PIN unless there is a problem with the SIM's personalisations.

    The phone should never (and I cant beleive it does) cache the SIM pin.

    If we are talking about the android lock screen, thats different. There are loads of ways to bypass that :)

    I expect in this case one of the following is happening

    - Personalisations on the SIM are broken
    - Pin was never set in the first place - but then why ever ask for it?
    - SIM interface was never restarted (but shouldnt happen from cold boot)

    I'm inclined to think this cant be happening from a cold boot
     
  19. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    well i was thinking of this scenario KAM

    sim didnt have pin function enabled on it prior to being placed on handheld
    user sets sim pin security on the galaxy
    galaxy doesnt write to the sim security section correctly
    fastboot some how reads past the corrupt security section on sim

    while im inclined to believe you KAM there are too many people here replicating it
     
  20. kam187

    kam187 Well-Known Member
    118

    Aug 3, 2009
    1,320
    46
    118
    UK
    Yeah, the only plausible explanation is what you're saying - the PIN was never actually set. I assumed that people set the pin, and cold boot and get a PIN prompt first. Which makes you wonder why would it ask for a pin then.

    OR the SIM card is provisioned incorectly and isnt locking the correct fields (highly unlikely).

    We're definatly talking about a SIM pin and not the phone pattern lock right :-/ ?
     
  21. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    let me just fastboot again i thought mine asked for pattern lock aswell
    EDIT

    fastbooted, asked for pin 1st then pattern lock
     
  22. Cougar

    Cougar Well-Known Member
    38

    Aug 28, 2009
    420
    16
    38
    Geek
    Lancashire, England
    That's a point. I was talking about the pattern, I've never used a SIM lock.
     
  23. kam187

    kam187 Well-Known Member
    118

    Aug 3, 2009
    1,320
    46
    118
    UK
    Ok.. Pattern lock is flaky. Its just a system process and blocks input to the rest of the UI. If you could background it for example you could still access everything.

    There's ALOT of ways to bypass pattern lock
     
  24. atbeyi

    atbeyi Well-Known Member
    36

    Jan 12, 2010
    119
    9
    36
    and as i've mentioned before i may make calls, connect to internet over 3g and/or edge (which one is avaliable at that moment)

    last night i have talked drakaz and willdd in the dev irc channel (i am sure you know but : irc.freenode.net / #i7500) and he said that this happens sometimes.

    there are different people who says that this can be reproduced by themselves too.

    and also there are some other turkish guys who says that after my mentioning of the problem they have tried and they lived the same problem.

    thats not about screen lock thats about sim lock.
     
  25. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    can you do what i asked please i understand what you are saying but like kam said:
    sim security is locked to the sim itself so the only common thing that could be happening is that pin is being set on the galaxy rather than another phone and the galaxy cannot write it properly
     

Share This Page

Loading...