USB bricked cant fix...Tried everything please help


  1. caramac79

    caramac79 Member

    HTC Desire Orange UK
    HBoot - 0.91.0001
    Radio -5.10.05.30
    Android Version 2.2
    Kernel 2.6.32.15-g29e526b
    Software 2.17.61.3

    While attempting to root my phone i did something wrong and now i have a USB brick i think :S

    Could not get unrevoked3 to work so tried a factory reset before trying again and everything went wrong with my phone. I could get no signal at all and it was not allowing me to connect to any network (orange or orange t-mobile) just said network not available with this sim

    Could not connect to phone through usb when in android just shows up as qualcomm device and no SD card registered even though it was plugged in.

    Looked around forums and spend HOURS trying to get phone working and now phone is working to a point but not fully, cant make a call without going into hand free mode.

    CAN

    Can connect phone in FBoot mode and it it recognised in Device Manger as Android 1.0 device .

    Load android and view SD card in ASTRO

    CAN'T


    • Connect to PC in android does not register, have unistalled HTC sync and reinstalled it but still no luck just shows as qualcomm. Does not show up so even though can enter usb debugging mode on phone it does not register with PC.
    • Make calls as when the screen blanks (next to ear) signal shuts off (tried all sorts of apps to keep screen on during calls but still happens)
    Tried


    • making goldcard but don't know how to judge if it have been a success because nothing else seems to work
    • Loading update.zip by going into recovery
    • PB99IMG.zip
    PLEASE HELP

    Advertisement
  2. SUroot

    SUroot Well-Known Member Developer

    I was going to suggest PB99img.zip. so what happens when you do that?
  3. caramac79

    caramac79 Member

    well i tried it and it would start to load and then just stop and i'd get an error message, this was about 4am when i was trying every possible fix/soulution known to man :(

    i've tried it again put the PB99IMG.zip file on memory card and it does not even recognise it just loads as normal when i boot into hboot.

    really stuck :(
  4. Hadron

    Hadron Well-Known Member Contributor

    With a Orange handset you'll need a goldcard. Unfortunately the only way to tell whether that has worked is if it lets you run an RUU/PB99IMG.

    What is the name of the PB99IMG file on your sd? It must be just PB99IMG.zip, nothing more, so rename it if the name is different. It will be case-sensitive too (everything is in Linux).

    If you can get it to the point of giving the error message again, tell us what it is - that may give someone a clue.
  5. SUroot

    SUroot Well-Known Member Developer

    Yes we need a message if there is one.

    Once you get into Hboot, there should be green text looking for PB99IMG.zip but ti wont find it if the name is different.

    Do you see this text? It normally comes up for me when I'm trying to press vol down to get to recovery option
  6. caramac79

    caramac79 Member

    I've named the file PB99IMG.zip so should i try with the PB99img.zip?

    I had it working before, will it only run if there is a goldcard or will it only work successfully if there is a goldcard?

    I have tried running RUU from windows (when i was trying everything i could find) but tht didnt work as can't get into usb debugging mode.

    can anyone point me towards a working version of the PB99IMG.zip file so I can use that as the one i have i was told to rename it from a long filename to that.

    thanks for help so far will try with the PB99IMG.zip when I get home from work.
  7. Hadron

    Hadron Well-Known Member Contributor

    There's a PB99IMG.zip in the dropbox thread, linked from our sigs. You will have to rename it, and "PB99IMG.zip" is the correct case - renaming should not be a problem, and they tend to come with long names so that you can tell what they contain.

    Since my phone was never branded I've not got direct experience of how a PB99IMG fails if the goldcard is not present. But the bootloader will refuse to run it, rather than it running unsuccessfully, at least as I'd define those terms.

    Edit: This is a bit late now, since I can't think of any other way of getting your phone back, but you do know that there's no way of returning an Orange UK handset to its original software? That's a particular feature of Orange phones - no RUU for Orange software has leaked.
  8. Rastaman-FB

    Rastaman-FB Well-Known Member

    pb99img.zip doesnt fix misc apparently. ive seen too many people ruu/pb99img their devices and it still doesnt work.

    the only way to fix it is by doing the usb brick fix
    things are a little easier as you can root the phone with visionary+
    please check this thread

    http://androidforums.com/desire-all...rning-do-not-use-rom-manager.html#post2843048

    the 1st link the guy fixed it without root (using temp root via visionary)
    you will need to do the fastboot command to enable the sdcard
    you will need to get an mtd0 img from the second link

    it will work
  9. Hadron

    Hadron Well-Known Member Contributor

    Ignore this post - read Rastaman's above.
  10. InfernalByte

    InfernalByte Well-Known Member

    Wont pushing the Alpharev down grader SPL be an easier fix? Its supposed to negate the need for a gold card and allows you to do a regular RUU.

    It worked for me when I bricked USB bricked the other day.
  11. Rastaman-FB

    Rastaman-FB Well-Known Member

    well he cant s-off atm as im not going to get him to use alpharev-x as its in beta
    hes not got root as unrevoked failed and borked it (not aware unrevoked causes usb brick but none the less for this user it seems it has)
  12. caramac79

    caramac79 Member

    I dont think unrevoked USB briked it i think it was a combination of things really coz the unrevoked went quite far before failing and failed at different points after a few tries... was the factory reset that really killed it.

    Have already done the fastboot command and have access to SD card when in android because i have navigated using Astro. So i have acess to SD card or will i have to fastboot again?

    Will try visionary+ though

    is this the fix you were mentioned?

  13. Rastaman-FB

    Rastaman-FB Well-Known Member

    yep thats the one, you will need to get the mtd0.img from that link below. you need to submit the cid and software version

    to get the carrier cid use fastboot oem
  14. caramac79

    caramac79 Member

    Got my CID using 'CID Getter' from the marketplace

    Got mtd0.img file and added my CID to it using 'Desire mt0d Creator' from Desire mtd0.img creator

    My CID was ORANG001 & rOM vERSION: 2.6.32.15. (kernel version)
    (TRIED 2.17.61.3 which is my Software number)

    Found Visionary+ and Root Explorer and have the apk to install using Astro

    Just this bit I'm not sure about and want to be 100% before I start is :

    is this the correct way:

    The update files image_flash &mtd0.img both go in the /data/data folder and image_flash is set to r/w and mtd0.img set to exe?

    thanks again for all the help so far....almost there (i hope)
  15. SUroot

    SUroot Well-Known Member Developer

    When you long press a file in root explorer, a menu appears and in that menu are permissions. Select that and in there you can set read, write and execute permission
  16. caramac79

    caramac79 Member

    Just want to know if i was right in what i asked

    if that is the right way to do it and id those are the correct settings to apply to each file.

    Still not attempted yet want to make sure I have it all correct before I start :D
  17. Rastaman-FB

    Rastaman-FB Well-Known Member

    yes its correct.
    but both those is the /data/data/
    set the permissions to read write and execute on both files

    then use android terminal and do the final commands
  18. caramac79

    caramac79 Member

    Ok sounds good just one last thing before i hopefully sort my phone out

    Does the mt0d.img look ok? worried becuase when i tried the software number i had an error coz it should be 10 characters long but using the kernal version worked (only coz of the . after the last number)

    Thanks
  19. SUroot

    SUroot Well-Known Member Developer

    It cant be kernel.

    Other software versions are x.xx.xxx.x but yours is x.xx.xx.x (missing an x) so not sure why yours is like that!

    Which PB99IMG.zip did you use? Or did you not in the end?
  20. Rastaman-FB

    Rastaman-FB Well-Known Member

    check the software information in settings>about
  21. SUroot

    SUroot Well-Known Member Developer

    If the orange software version is indeed correct, it is a digit shorter than all others.

    So we would need to PB99IMG.zip it to Unbranded with a gold card. But is that going to be possible in this current state?
  22. Rastaman-FB

    Rastaman-FB Well-Known Member

    i think the sw info in the mtd0 creator is a bit of a redherring tbh as if you open it with a hexeditor it doesnt really need anything other than the cid which is replaced at the top line


    all brick fix guides just tell you to get the mtd0 from an unbranded device and use a hex editor to change the cid

    so theoretically it shouldnt be a problem

    EDIT:
    it appears this version does add the sw info to the file
    If that mtd0.img doesnt work you can try this one as i have modified it to show your correct version

    Attached Files:

    caramac79 and SUroot like this.
  23. Rastaman-FB

    Rastaman-FB Well-Known Member

    major edit :p
  24. caramac79

    caramac79 Member

    so i'm good to go with the files i have atm then guys?

    I will have a go and let you know how I get on thanks for all the help and enthusiasm so far.

    :D
  25. SUroot

    SUroot Well-Known Member Developer

    Try with your mtd file but if that fails try Rasta's :)

Share This Page