USB Charge and Data Transfer IssuesSupport


Last Updated:

  1. Magres

    Magres Member

    Hello,
    I got a Tmobile Samsung Galaxy S2 a week ago second hand (android 2.6.35.11, build gingerbread.uvlde). I wiped it to the tmobile default install since I am new to this and not comfortable rooting. The phone is acting like there is a strange software/firmware issue with USB charging and data transfer.
    The phone sometimes will not recognize that the charger is plugged in the USB port. To get it to recognize the charger I have to:
    1. Power down and remove the battery
    2. plug in the charger
    3. put battery back in
    This works everytime, but only lasts for about a day, I am able to plug in and remove the charger with it working everytime when it is working (aka, it does not appear to be a dirty USB with a bad connection).
    I have not been able to use the USB for data transfer. When I plug it in the phone is able to be charged but the computer do not even realize that a device is connected, regardless of specifically recognizing it as what it is (I have tried on 4 windows 7 x64 machines and know of the issue, but thought it would at least recognize something in the system panel). I have tried everything I have found by googling it, changing from pda to the other mode, and turning on developer mode.
    Does anyone know if this is an issue that is fixable or does the phone need to be sent to Samsung?
    Thanks

    Advertisement
  2. Magres

    Magres Member

    To follow up, the problem was the USB port on the phone. Replacing the USB port fixed the problem.
  3. Atma

    Atma Well-Known Member

    Hi Magres and a late welcome to the forums. :shakehands:


    I'm glad you got your issue fixed and thanks for reporting back what it was. It may help someone in the future. :)

Share This Page