USB Connection Problem with PCSupport


Last Updated: 2013-09-20 20:43:57
  1. ag2000ir

    ag2000ir Member

    Recently I am having a problem when I want to connect my Exhibit II to PC. I get this page after connecting the cable, and the phone memory drives never show up
    [​IMG]
    It happens both in debugging and non-debugging modes.
    I have no idea where this page comes from!!

    Thanks

    Advertisement
  2. surgerush

    surgerush Well-Known Member

    I believe that's the docking screen, it thinks you're plugging your phone into a dock (I think, I could be completely wrong)

    BEFORE you plug your phone into the computer go into Menu>Settings>Wireless and network>USB utilities and select "Connect storage to PC". Then connect it to your PC, that SHOULD work.
  3. ag2000ir

    ag2000ir Member


    Didn't work.
    Looks HW or cable issue, will try another cable.
  4. zcarman

    zcarman Well-Known Member

    I've had nothing but issues using anything but Samsung Cables with Samsung Devices... I'm willing to bet you are right with it being a cable issue. I just tried with a generic and a Samsung and the generic did not work - the Samsung did.
  5. olc

    olc Active Member


    Doesn't work correctly. This method does put two new removable drives on Explorer (I assume the phone and the sd card), but neither is accessible. Choose to open either one and it says to insert a disk in the removable drive.
  6. surgerush

    surgerush Well-Known Member


    I don't know, it works for me
  7. ag2000ir

    ag2000ir Member

    Yes It was cable. it works fine with another cable.

    Thanks
  8. physicsguy

    physicsguy New Member

    There is something mysterious about the Samsung cable. I posted this in a rooting forum:
    "To anyone having trouble getting the pc to recognize that the Samsung Exhibit II is connected:
    Use only the Samsung data cable. A generic one won't work. I had the same problem using a usb data cable from an old LG on my Samsung. It would charge the battery but that was all. Once I switched to the Samsung cable that came with my phone, everything went fine. (Of course, you still need to install the Exhibit drivers; works with Exhibit II)

    BTW, works fine on Mac with VMWare running Win XP."
  9. ag2000ir

    ag2000ir Member

    That might be correct, but mine was the original Samsung cable that failed to connect. However, a generic worked.
  10. dannycoll

    dannycoll New Member

    I have a similar problem with de docking screen. it keeps popping without any cable connected and when i connect the charger it prevents from charging my phone. please help
  11. maryamzolnoori

    maryamzolnoori New Member

    This was my problem, I searched in google and saw this question and answer. It was very helpful.
  12. CECollier89

    CECollier89 New Member

    I've had the same issues with my Exhibit II. This is my third one in a year and a half. After a while, they just lose functionability which sucks because I'm planning a wedding next month and traveling for Christmas so I can't afford to upgrade until tax return season.

    Anyhoosies, today I was trying to move some music from my PC to my phone. The USB wouldn't connect at first (as in my laptop didn't recognize that the device was connected; it just charged the phone) and I am using the Samsung USB cord from the charger that came with the lastest phone T-Mobile has given me. So I rebooted the phone, clicked Settings, then Wireless and Networks, then USB Capabilities BEFORE plugging the cord into my laptop. I clicked Connect USB and while still on that screen, plugged the cord in to my USB port and when the screen changed, I immediately clicked Connect Storage to PC. And it worked! The Autoplay automatically opens both the phone storage file and my SD card file. Good luck with your Exhibit II problems but just know, these phones are cheap and you get what you pay for. Don't plan on having it long.

Share This Page