USB debugging automatically comes on (mac and win users)Support


  1. henryronny

    henryronny Active Member

    hi so every time i plug the htc one into the macbook usb debugging comes on by default. its a simple tap on the notification to turn it off, but is there a way to turn it off?

    I've tried the developers options menu then turn off usb debugging, but this doesn't make a difference, and also tried turning off the developers options completely with the slider at the top of the menu, but this also doesn't help

    thanks

    Advertisement
    :
  2. EarlyMon

    EarlyMon The PearlyMon Moderator

    Do you have Android.com - Android File Transfer installed on your Mac?

    Which revision of OS X are you running?

    My bet is that the phone has sensed data lines connected, could not find an MTP interface (as provided by Android File Transfer) and then ran home to momma with a usb debugging setup.

    MTP - mass transport protocol - a Windows protocol that you requires that add-on for a Mac.

    Due to later OS X updates, AFT now doesn't see every Android on every Mac, but it's your best bet.
    marctronixx likes this.
  3. Samcanadian

    Samcanadian Well-Known Member

    I get this with my Dell laptop too, and can't seem to get the HTC Sync desktop tool to see any of the information I have on my phone, regardless of what I do. Is this somehow related?
  4. EarlyMon

    EarlyMon The PearlyMon Moderator

    If my guess stated above is correct, yes.

    Let's look at this way - with Jellybean and no sd card, gone are the days of a selection for charge only or usb mass storage mode.

    That basically leaves only the default media sync/transfer mode when the data lines go hot.

    When the software doesn
    marctronixx likes this.
  5. EarlyMon

    EarlyMon The PearlyMon Moderator

    BTW - AirDroid is free and secure on your home network.

    If you don't mind wifi, or need a workaround right away, it's a great solution and easy to use.
    marctronixx and toad6386 like this.
  6. toad6386

    toad6386 Well-Known Member

    Once again, Early to the rescue.. :congrats: I've been using WiFi File Explorer Pro (FAOTD) for quick up/downloads (1 or two files) and suffered because I couldn't efficiently upload my audio books, so I had to use USB to upload them to my 3VO. Airdroid seems loads faster than even USB, and MUCH better than Wifi Pro. Thanks loads! :D
    EarlyMon and marctronixx like this.
  7. LoyalServant

    LoyalServant Well-Known Member

    I have noticed this as well but I assumed it's because I have the Android toolchain installed on my machine since I dabble on occasion writing little apps.

    If I kill debugging on the phone it drops into file transfer mode on it's own.
    I do have to do this every time I plug it in and I figured that was a new feature geared towards developers. :D
  8. henryronny

    henryronny Active Member

    Hi EarlyMon

    Thanks for the advice, yes I do have AFT on the Mac, and I've used it for a few years with my GS2

    The Mac is OS X 10.8.2.

    If I uninstall AFT, will it be problem solved?
  9. EarlyMon

    EarlyMon The PearlyMon Moderator

    Just to make sure I'm clear - AFT is working with your SGS2 but not your One?

    If that's the case, you're in the group where, for unknown reasons, that rev of OS X, AFT and your Android don't get along.

    I've seen that more and more without an easy solution because Google isn't updating AFT or because Apple updated OS X.

    I really hate to send you for a paid solution, but you might want to look into this - http://www.sync-mac.com/android-sync.html

    I haven't used that, so see if they have a demo or something you can try if you're interested.


    BTW - have you installed HTC Sync Manager, and it so, is it working?
  10. emf1138

    emf1138 Well-Known Member

    Is there a way to NOT have Sync Manager pop up every time I plug in my phone to my Mac? Don't see any settings or prefs. to this effect.
  11. Slug

    Slug Check six! Moderator

    I've merged your question into this topic as it appears related. Hopefully the answer lies in previous posts; failing that I'm sure you'll get advice.
    emf1138, marctronixx and EarlyMon like this.
  12. EarlyMon

    EarlyMon The PearlyMon Moderator

    The only way that I know how to suppress that requires root.
    marctronixx likes this.
  13. henryronny

    henryronny Active Member


    Hi again
    AFT is working for both phones (although the usb port on my gs2 is haggard and doesn't always play nice)

    Sync manager pops up in a window every time I plug the One in, but I haven't set it up/installed it
Loading...

Share This Page