"USB device has malfunctioned" please help, can't connect!

Discussion in 'Android Devices' started by Victory, Aug 11, 2010.

  1. Victory

    Victory New Member
    5

    Aug 11, 2010
    3
    0
    5
    I've done a search and there are threads similar to my problem, except they can transfer data. When I plug my phone in it wont give me access to the SD card? Wont even act as a removeable storage device, what's going on?

    I've tried using the sync program that i downloaded but nothings working. I tried following the tips to get it synced but the problem seems to be with windows not recognising the device.

    Got my Desire today and i love it, but i'd rather it wasn't broken... :/

    Running Windows XP fully up to date.

    cheers.

    EDIT: Fixed it, thank you! :)
     

    Advertisement
  2. Podivin

    Podivin VIP Member
    VIP Member
    213

    Nov 29, 2009
    3,679
    881
    213
    Jacksonville, Fl
    You might try a different cable, to see if the fault is in the cable rather than the phone or pc.
     
    Victory likes this.
  3. Victory

    Victory New Member
    5

    Aug 11, 2010
    3
    0
    5
    Thanks for the reply, I've got 6 USB ports I tried the final one I haven't done and it worked grrr, obviously my computer being stupid. :/

    I'd delete the thread if I could!
     
  4. charlies99

    charlies99 Well-Known Member
    18

    Jul 28, 2010
    46
    10
    18
    Have you tried tapping the usb symbol in the top left hand corner (Notification bar) and then changing it to mount as disk drive ?
     
    Victory likes this.
  5. Victory

    Victory New Member
    5

    Aug 11, 2010
    3
    0
    5
    yeah i tried that thanks, turns out it's just being temperamental only works in one of my 6 usb ports... hmm
     
  6. Tonco

    Tonco Active Member
    16

    May 10, 2010
    26
    3
    16
    Today my Desire wont communicate with the PC. It has, without problem for several months acted as a disk drive but today it is as though the pc does not recognise it as the HTC desire.
    There is no drive icon on the phone. I changed the default to 'ask me' and it doesn't. I've tried more than one USB port. I've tried rebooting both PC and phone.
    I've uninstalled the HTC driver on the PC and it recognised and reinstalled the HTC Desire driver when I plugged the phone in but it still won't communicate. Drive D does appear on my list when I plug the phone in but when I click on Drive D it just gives me 'Put a disk in drive D'
    I think it's a windows pc problem rather than the phone.

    Can anyone help please?
     
  7. T.I.

    T.I. Active Member
    16

    Aug 11, 2010
    39
    7
    16
    P$C
    take ur memory card and put it back in..see if that works... and doess ur phone recognize the memory card?
     
Tags:

Share This Page

Loading...