USB device not recognized by windows


Last Updated:

  1. Jenna918

    Jenna918 New Member This Topic's Starter

    Joined:
    Mar 2, 2013
    Messages:
    2
    Likes Received:
    0
    Hey! So, I've had my Samsung Galaxy S2 for about 6 months. Since I've gotten it, I've been able to plug the USB into my computer (Acer Aspire 5741, 64-bit), turn mass storage on, and away I go. Today though, I went to plug my phone into my laptop and it said something like "USB device not recognized by Windows". I've got the latest version of Kies as well, so that's not the issue. any ideas or advice? Ps.. I'm pretty tech-slow, so try to keep things simple and step-by-step. Thanks!

    Ps... Yes. I have tried turning it off and on again :p
     

    Advertisement
  2. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    30,287
    Likes Received:
    22,263
    Did you update anything recently? Many times it's just a matter of trying a different USB port or cable. Samsung phones are VERY fussy when it comes to cables.
     
  3. Jenna918

    Jenna918 New Member This Topic's Starter

    Joined:
    Mar 2, 2013
    Messages:
    2
    Likes Received:
    0
    I've tried every port on my computer. Every time it says "one of the USB devices connected to your computer has malfunctioned and Windows cannot recognize it"
     
  4. chanchan05

    chanchan05 The Doctor Guide

    Joined:
    Jun 30, 2011
    Messages:
    14,013
    Likes Received:
    3,976
    Try updating the drivers via Kies. Open the program. It should be under tools.
     
  5. argedion

    argedion The TechnoFrog Moderator

    Joined:
    Jun 20, 2011
    Messages:
    6,358
    Likes Received:
    6,254
    have you tried different cable?
     
  6. jefboyardee

    jefboyardee Well-Known Member

    Joined:
    Jan 18, 2011
    Messages:
    5,182
    Likes Received:
    1,497
    +1 that. It happened to me and took me forever to figure it out.
     
  7. Clementine_3

    Clementine_3 Well-Known Member

    Joined:
    Nov 16, 2009
    Messages:
    4,020
    Likes Received:
    2,978
    Oddly enough, my sister has an Acer and couldn't connect her phone yesterday. She went and got a new cable but still couldn't get it to recognize the phone, she was getting the same type error messages. Not sure if she got it working or not, strange though.
     

Share This Page

Loading...