1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support USB device not recognized!


  1. Sambo59

    Sambo59 New Member

    Hi everyone im hoping someone can help me out here.
    I have scanned through just about every forum trying to solve this problem but as yet nothing works!:mad:

    Ok so my samsung Galaxy S2 was working fine, i had if for about 4 months and i had connectivity with my laptop running windows vista home premium. However last week i updated the software and was trying to update the firmware via Kies when i got the error -

    USB DEVICE NOT RECOGNIZED
    One of the usb devices attached to this computer has malfunctioned, and windows does not recognize it...............................

    On the phone the MTP initialisation appears then shortly says connected afterwards. However windows cant see the phone.

    I believe i have tried everything to resolve this, i have;

    a) Done a factory reset on the phone.
    b) Re-installed the latest version of Kies and drivers ensuring everything , including drivers and associated files were wiped from my computer
    c)Tried different USB cables including the OEM cable and various aftermarket ones.
    d)Tried all the USB ports on my laptop.
    e)Tried other Laptops and desktops.
    f) Tried de-bugging mode.

    I'm sure there is a g) and an h) but can't think at the min:confused:

    So does anyone have and ideas?? I'm starting to think the phone is faulty and send it back.

    Many thanks in advance for any suggestions.

    Advertisement
  2. Sambo59

    Sambo59 New Member

    Also forgot to add the phone charges fine via the usb cable
  3. Russell Ng

    Russell Ng Well-Known Member

    Tried cleaning the USB port on the phone? A lot of recommendations for that in a lot of threads when facing your type of problems.
  4. Sambo59

    Sambo59 New Member

    @ Russell Ng thanks for the response, ive not heard that one before. None the less I tried - and failed!
  5. Russell Ng

    Russell Ng Well-Known Member

  6. dax01

    dax01 Active Member

    My friend have the exact same problem but when (with same setup) replace her phone by mine (same model) - mine is detected.
  7. evicius

    evicius New Member

    hi, i have same problem and so far no solution :( Thanks in advance
  8. vickey883

    vickey883 New Member

    Same problem with me

    one of the usb devices attached to this computer has malfunctioned and windows does not recognize it
    Please if any one find solutions for this let us know



    TAhnsks
  9. Sweegy

    Sweegy New Member

    Same problem here, Tried everything and no luck..
  10. nickst2

    nickst2 Well-Known Member

    same here
  11. dibdabdob

    dibdabdob New Member

    I have the same problem and I tried a few things today. my usb was only working as a charging device. At least I know the USB was working i double check it with a printer and a mouse and found...... it was something wrong with the driver not the phone or the cable
  12. dibdabdob

    dibdabdob New Member

    USB Problems
    I had problems connecting the USB to the computer as the cable allowed the phone to charge, but kies would not recognise it nor would the computer accept it as a USB device.

    I had the luxury of trying it on a computer that had never had a USB phone connected to it and it worked first time. First problem eliminated----the cable second problem eliminated the phone

    Next the USB driver on the computer... what to do I seached the microsoft sites and found the following on how to reset the USB controllers and devices on the computer:

    http://support.microsoft.com/kb/310575

    So I deleted all the devices and then uninstalled Kies and rebooted the PC.

    when the computer (laptop) was on and all the main usb drivers had reinstalled, I rebooted again. On the second reboot I just plugged the phone into a usb port and it began to install the samsung galaxy usb drivers including the modem.

    I then downloaded the latest kies from the samsung galaxy website and reinstalled it.

    and it has not stopped working. I do believe that the phone is not at fault, more the software and the chance of corrupting the drivers.

    The download of the new firmware worked immediately and I really had nothing to do on the phone.

    I hope someone can find this process of use ​
    Punsak and Russell Ng like this.
  13. Russell Ng

    Russell Ng Well-Known Member

    Sometimes its the PC usb port causing the issue. That's why a lot of advice is to try another usb port or another pc (not Mac), to see if can eliminate some of the causes. Luckily Kies still works for me, although sometimes have to try reconnecting a few times and/or reboot phone/pc.

    But good idea for getting the USB driver if necessary.

    Cheers
  14. Martimus

    Martimus One bite at a time... Moderator

    For what its worth... it is rarely a good idea of publically post an email address on a public forum. Unfortunately the Internet is crawling with software programs that harvest email addresses from web pages. These addresses can then be sold to spammers... and we know what they do! :rolleyes:

    Email address harvesting - Wikipedia, the free encyclopedia
  15. bkelsey

    bkelsey New Member

    im under the same boat, but my phone wont connect to my charger or my computer using the same USB cord!!! i have had so many problems with broken chargers, usb cords not working, etc. this is really pissing me off. i got the ZERO charger from AT&T 2 weeks ago and its already not working!!!! i mean its trying to, but its not!!!! WHAT DO I DO!!!????!?!?!?!?!?!
  16. dibdabdob

    dibdabdob New Member

    I have also had the problem with the USB port bleeping and not charging for that I went to an independant and had the USB port changed (resoldered) on my phone. i then changed to an HTC charger as the samsung galaxy charger is so thin that taking it out at speed sometimes you can "feel a bend" on the usb port.

    since then ( five months) since I had the problem. I have had no problems.

    It did cost about 20 pounds to repair, but I got it back on the day
  17. saison

    saison New Member

    just go to setting > application uncheck Unknown sources
    then go to settings > application > Development and uncheck usb debugging and allow mock location .. finally reconnect ur S2 ..

    Hope i solved ur problem :)
  18. Punsak

    Punsak New Member

    Dibdabdod's solution worked for me after a day of trying everything else. (I.e., uninstalling all USB Controllers). Yet, interestingly, the error message returns when I run Klies, and disappears when I go off Klies.
  19. Mr8Bit

    Mr8Bit New Member

    did this and now i get the usb icon on my phone but my computer (mac) still doesn't recognize my phone
  20. Russell Ng

    Russell Ng Well-Known Member

    Have you tried connecting via USB storage mode?

    Its in the settings / wireless&network / USB utilities....
  21. Mr8Bit

    Mr8Bit New Member


    yeah, but phone is not recognizing it at all when ever i go to mass storage mode (it only shows "MTP connected" when im on my home screen
  22. Russell Ng

    Russell Ng Well-Known Member

    Try this,

    Go to Settings/Applications/Development
    And make sure USB debugging is untick.

    Withoug USB connected, then go to Settings/Wireless & Network/USB Utilities
    Tap on the Connect Storage to PC, and then follow onscreen instructions.
  23. merchantm

    merchantm Member

    ok but how do you do this?

    I go to settings/applications and there isn't a further option

    EDIT: It's in settings/developer options
  24. Russell Ng

    Russell Ng Well-Known Member

    Mine seems to be in a different place than yours.... You using ICS?

    Anyway, did it work now? Connecting via USB mass storage mode...
  25. nofear

    nofear Well-Known Member

    Are you using the official Samsung cable? I was having the same problem when trying to use my old HTC usb lead.

Share This Page