1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support usb drive


  1. crow11ad

    crow11ad Well-Known Member

    Hey guys am I missing something? How do I make it where the laptop will see the moment? I don't see a place for mounting the sd card, only unmounting?

    Advertisement
  2. Gremlyn1

    Gremlyn1 Well-Known Member

    Curious on this as well, when I plug the Moment into the computer I don't see the USB icon on the status bar.
  3. Adrift

    Adrift Well-Known Member

    You mount it from the phone, once phone is connected to PC, you need to pull down the status bar on the phone and click ok to mount the card... or something along those lines
  4. Adrift

    Adrift Well-Known Member

    Oh.. hmm... Gremlyn1 You are not getting anything when you plug the phone to the computer? Odd... will look in to this...

    I am running windows 7, when I plug in, my Moment shows USB icon in status bar and say "USB connected. Select to copy files to/from your computer." after selecting I am prompted by phone to mount the SD card.
  5. crow11ad

    crow11ad Well-Known Member

    Same here....hmmmm
  6. Gremlyn1

    Gremlyn1 Well-Known Member

    Well this didn't work on two computers (and three OS's), so I figured it had to be the phone. I turned it off, unplugged it from the USB to make sure it had no power still, pulled the battery and re-inserted the SD Card, turned it back on and voila... it works. Not sure if reseating the SD card did anything... but whatever :)
  7. Silverexpress

    Silverexpress Well-Known Member

    M900_How Do I Access Content On The Memory Card With The SPH-M900 (Moment)?

    At this moment in time, I'm not getting any notification regarding the USB connection, when I connect to my laptop.

    I will try

    Settings -> Application -> SD.... -> Unmount

    Power down the phone and unplug from laptop

    Take out the battery and then the SD Card

    Re install

    Power up

    Re connect USB Cable
  8. crow11ad

    crow11ad Well-Known Member

    would be great except no notification showing usb.
  9. Silverexpress

    Silverexpress Well-Known Member

    Ok, that almost worked. Laptop recognized a new hardware (Moment), but could not find driver.

    So on my end, it looks to be a problem with Win XP not having the correct driver to recognize Moment. Where do I get it?
  10. Silverexpress

    Silverexpress Well-Known Member

    Ok, it seems like Samsung has something equivalent to Palm's Desktop....err in this case a PC based mobile phone manager called "PC studio". I downloaded and installed it, but to no avail. It has 6 folders of USB drivers, none of which seems to work with Android.

    Maybe usb connectivity will be an upcoming update.
  11. Gremlyn1

    Gremlyn1 Well-Known Member

    Do you have the USB Debug turned on? If so, turn it off and try it again, that worked for me.
  12. Adrift

    Adrift Well-Known Member

    PC studio is for older non-smart phones I believe.

    You should try Grymlyn1's advise, unmount the card under settings > Sd card... power down phone, remove battery, remove card, then reassemble and power back and see if that will work.
  13. Silverexpress

    Silverexpress Well-Known Member

    I got it.

    Basically, I've had a multitude of mobile phone drivers installed on my Laptop. From Palm's to Blackberrys. What was happening was that there was a conflict of drivers with the Moment.

    I used a program called USBDView to see what these drivers where, and then one-by-one deleted them.

    I can now see the Moment's SD card as an external drive, and yes I did get the USB Connected notification on top of the Moment's screen. Wooohooo!

    Here is that app for viewing and editing USB drivers on your PC/Laptop....

    USBDeview - View all installed/connected USB devices on your system

    And yes Adrift, you are right PC Studio is an app for the older Samsung phones. It will be uninstalled shortly. Thanks.
  14. Silverexpress

    Silverexpress Well-Known Member

    Note: If you succeed in mounting the Moment to your PC, make sure that you "Unmount" it via the notification drop down menu (you drag it down with your finger) when your done.

    I found that the PC's driver will get corrupt if you don't (by pulling the cable right off - may corrupt your SD card too, especially if you have a file open), and will not recognize the Moment from then on. To recover....

    1. Disconnect USB Cable from Moment
    2. "Unmount" the SD card via Settings menu, but do not physically
    remove.
    3. Power down the Moment by holding down the right hard button (red)
    4. Uninstall the driver on your PC. Use USBDview.exe -works exceptionally
    well
    5. Power up our Moment
    6. Reconnect the USB cable
    7. Your PC should then re-install the driver
    8. USB notification should appear at the top left of your Moment screen
    9. Drag down the Notification window with your finger
    10. Mount the USB card
    11. On your PC, a pop up window should appear with a list of actions.
    Choose "Open Folders" (I think that's what it was called).
    clintatk likes this.
  15. RugbyRef

    RugbyRef Member

    Well....none of the above solutions worked for me. I tried it at home on my Windows 7 based computer, and at work on my XP based computer. I have searched Samsung's and Sprint's support websites and nothing! I suppose I will have to wait for either of the above to come out with a fix.

    Tim :confused:
  16. ha11ster

    ha11ster Member

  17. Silverexpress

    Silverexpress Well-Known Member

    On another thread, a user suggested downloading a newer version of PC Studio.

    It worked, and adds a slew of new drivers. Plus you can use debug mode under settings -> application to see the SD as a harddrive and also run some other unmentionable software.

    Here is the link:

    Samsung's Digital World
  18. crow11ad

    crow11ad Well-Known Member


    Thank you. This worked.
  19. akenis

    akenis Well-Known Member

    Wow...that was a lot of fun. Finally working.

    1. I downloaded the New PC studio software. Long time to run, and install a bunch of drivers (modem, etc) seen in windows device manager.

    2. On Moment: settings, applications, development...must check "usb debuging" to enable the PC to see the device. I think I did a full power down also by holding down the end key for 3 seconds.

    3. Connect to PC.... and then pull down the notification screen and click on USB connected. All the drivers are set up automatically

    4. Now the sd card just shows up as removable device.

    Sow what was all that for? Easier to turn off the phone and remove the card and stick it in you pc's card reader!!! There's no functionality in the Studio software (except for update) for the moment. All the syncing of media, contacts, notes, calendars....all say the moment isn't a supported device????? Not such a smart device. Kind of missing Microsoft Activesync now.

    So how are we supposed to sync files. I've got a bunch of spreadsheets and word docs and reference stuff that I'd like to have on both phone and moment....syncronized. Any way to setup something that will automatically sync a folder from the pc to the card...when it does show up?

    Sticky needed for this stuff pretty soon.
  20. LincKraker

    LincKraker Well-Known Member

    So we have the drivers we NEED. I pulled them out of that huge file and zipped them up into a much smaller file easier to download. These worked for PDAnet and tethering as well Samsung Moment USB Drivers
  21. Gremlyn1

    Gremlyn1 Well-Known Member

    Awesome, thanks!
  22. Thanos24

    Thanos24 New Member

    Thank you LincKraker! My phone is FINALLY recognized. I was able to place files on the memory card. But I still cannot sync contacts. Do have any solutions?
  23. wodin

    wodin Well-Known Member

    Kind of reminds me of what I don't like about Linux, everything is too hard, requires too many steps that are not always intuitive, and if you get it wrong you can break it!
  24. wodin

    wodin Well-Known Member

    Does anyone know what the directory structure should be on the SD card?

    I took a test picture, and found that camera had created a DCIM directory with attendant sub-directories, but I don't know what videos or music should be called.

    I guess I'll try making a short video and see where it puts that.

    OK, it put it in the DCIM>Camera folder, but WMP couldn't play the .3gp file. Quick time could though. Wouldn't you know it! Jobs strikes again! grrr
  25. Don O'Neil

    Don O'Neil New Member

    Ok... I've done everything I can imagine to get my Moment to show up as a drive in Windows XP Sp3....

    1) Instaleld "New PC Studio"
    2) Removed all USB drivers using USBDeview (I had a WinMo phone before)
    3) Rebooted, reset, removed/replaced card/battery
    4) Re-detected device, etc... drivers were re-installed

    and still no drive letter in windows. It loaded the 'usb mass storage driver' for the device when it was detected, but still no drive letter..

    My Device manager shows devices:

    ADB Interface:
    Samsung Android Composite ADB interface
    Disk Drives:
    Android UMS Composite USB device
    Modems:
    SAMSUNG Android USB Modem
    PdaNet Modem
    Storge volume:
    Generic volume (Android)
    Universal Serial Bus Contollers:
    SAMSUNG Android USB Composite Device
    USB Composite Device (Android)
    USB Mass Storage Device (Android)

    It looks like all the drivers are loaded, but when I enable the "USB Storage" from the notifications I still don't get a drive letter. I've tried USB Debug mode on and off, no difference.

    Strange thing is that PDANet installed and runs ok, but I can't access the drive!

    I also found this article, pertaining to general USB mass storage devices:

    http://www.mattcutts.com/blog/fix-usb-drive-in-xp/

    When I went into the disk management my phone shows up, but says it has "No Media".

    Any ideas?

Share This Page