Usb malfunction - samsung galaxy s2 (sgh-t989)Support


  1. VoltronDeluxe

    VoltronDeluxe Member

    When connecting my Galaxy S2 (SGH-T989/TITANIUM[WHITE] VERSION/TMOBILE) I keep getting an error code 29, or device not found, malfunction port. I installed a fresh driver on laptop and still no connection. Is my port on my cell fried? I can still charge through the same port with my usb cord... It worked this morning.... :confused:

    Advertisement
    :
  2. Atma

    Atma Well-Known Member

    Hi Voltron :hello: Welcome to the forums.

    Have you tried another cable ? Do you have another computer you could try it on?
  3. VoltronDeluxe

    VoltronDeluxe Member

    Thanks Atmazzz, I have read a lot of your responses and was hoping you could help me out. I have tried a different cord and diff laptop. (I am working on a HP) and no luck.

    My inclination is that I am still using the GingerBread OS. I read all the reviews of when IceCreamSandwich came out and wasn't willing to upgrade... Now there is JelleyBean... Could it be the OS needs to be upgraded? If so, is it crazy to presume that I could go from GB to JB?

    Just to add a little more info, bc I feel I've searched through PhanDroid thoroughly..
    My phone is:
    Android Version: 2.3.6
    Baseband Verson: t989uvlde
    Kernel: 2.6.35.11
    Build #: Gingerbread.UVLDE

    I have unchecked the usb debugging.

    Thanks in advance.
  4. Atma

    Atma Well-Known Member


    I assume it didn't work with USB debugging checked either?

    I don't think the OS will matter. Try uninstalling all the drivers. Download and install Kies. It will install the latest drivers. Then see if Kies will recognize it. Also try blowing some compressed air in the USB connection. I don't know if it would help, but you might also try a factory reset.
  5. VoltronDeluxe

    VoltronDeluxe Member

    Thanks for the response. :) Correct, it did not work with the USB debugging checked. Also sprayed air into the cord and phone.

    I have uninstalled drivers on my laptop. Installed kies successfully. When it asks me to connect device, I connect and kies does not recognize the device is being connected. I try to troubleshoot and the troubleshoot says it's successfully completed but still no recognition.

    I just got a notification from tmobile about an update from the and it looks like they updated my Kernel : kernel now is...:

    2.6.35.11-1209942
    se.infra@sep-55 #2

    ^^ does this make any sense to you?
    And still not being recognized.

    I beginning to feel that hopefully it could be fixed with a factory reset. Which I'm ok with.

    Part one...I have backed up my contacts to my sim and sd card. Music on sd card and photos saved on dropbox. My apps I'm not really too concerned with, there are some on the sd card but I have a list of the apps I have downloaded to get back once the reset is done.... Am I missing anything?

    Part two.... the phone once the reset is done will still be on GingerBread... I'll probably find out the answer to my question if the reset works, but.... going from gingerbread to jellybean... is it possible? or do I need to go to ICS then to JellyBean?
  6. Atma

    Atma Well-Known Member


    The update I think was just an update for enhanced 911 service.

    Your contacts I would also sync with Google if you haven't already.

    Yes, after a reset you will still be on the same OS you have now. Jellybean isn't available for our phone yet. You would have to update through Kies or you could follow the sticky at the top of the page [HOW TO] Odin any stock rom to update to ICS 4.0.4. However, you can't do either if your USB isn't working.
  7. VoltronDeluxe

    VoltronDeluxe Member

    Welp.... I preformed a factory reset and then tried to connect to my laptop and still no luck. I get a "malfunction with connected device and windows does not recognize it..."

    Any suggestions? :confused:
  8. Atma

    Atma Well-Known Member

    I'm sorry. I'm out of ideas. Is there a warranty on the phone?
  9. VoltronDeluxe

    VoltronDeluxe Member

    I just finished three separate conversations with Samsung Live Chat.
    I first did a factory reset and that didn't fix issue.

    First convo. The had me do a soft reset and reinstall the Kies software and usb drivers software... No dice

    Second convo. They had me do another factory reset... No dice

    Third time out they pretty much said take it to tmobile store and have them send it off to be looked at. They said that it is under warranty just hope that Samsung doesn't say it's not their problem. (I never rooted it, never got it wet, dropped it a couple times but was just from my pocket.)

    I bought the phone in May of last year so I would think they could do something....
    Atma likes this.
  10. Atma

    Atma Well-Known Member

    I'm sure they will fix it. Hopefully it won't take too long. Sorry you had to go through all the trouble but at least it was before your warranty ran out.
  11. VoltronDeluxe

    VoltronDeluxe Member


    HA! Yeah me too, but at least I gained a better understanding of the phone and trouble shooting it.

    This is my first none iphone and I'm still pleased as punch. The phone is overall better for me and you're right the warranty didn't run out and the replacement phone is set to arrive today.

    Thanks for all your help!!!:D
  12. Atma

    Atma Well-Known Member


    You're welcome! :) And that's great news! Didn't take very long at all. :D
  13. kamosman

    kamosman New Member

    If Samsung Kies does not communicate or recognise your galaxy s2 mine had that problem and this is what I did.
    Uninstall Samsung Kies and driver using the uninstall from control panel. You can use Ccleaner if you like
    to make sure nothing is left, restart your PC.
    Go to Samsung website and install the latest Samsung Kies by searching your galaxy model, mine was
    ( SGH-T989D ).
    When the install is done don
  14. Atma

    Atma Well-Known Member

    Welcome to the forums kamosman. :hello: Thanks for posting. :)
Loading...

Share This Page