1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

USB Mass Storage help (issues connecting with devices? )Support


  1. Direct usb
  2. marctronixx

    marctronixx Moderator Moderator

    OK well are you getting an error message? Does the USB icon populate in the notification bar?

    I'm assuming your not rooted.

    What carrier are you using?

    Can you access the phone when it's connected to a laptop or desktop computer?

    Have you tried another cable?
  3. Ok I have no computer that works lol to try this on and yes the usb sign pops up and debugging icon pops up in status bar on phone.

    Phone not rooted yet and on rogers network
  4. marctronixx

    marctronixx Moderator Moderator

    Pull down the notification bar and you should see some options...
  5. triplecore

    triplecore Member

    Hi all i just from an iPhone to htc One. I am very happy with it so far. Since this phone does not have removable storage and when I plug it into my computer I need a password to use it as a MSD do I still need encryption?

    Thanks
  6. marctronixx

    marctronixx Moderator Moderator

    No you DONT need encryption. It's personal choice
  7. I get debugging settings and usb network settings
  8. will7201

    will7201 New Member

    Got my One two days ago and for two days I couldn't get it to mass storage, using the USB wire that came with it. Then I noticed a tiny amount of wiggle inside the phones USB connection. So then I GENTLY lifted the USB wire UP as I kept the phone flat, voila, my Windows 7 laptop gave its customary 'ba-ding' and I was in business!
    Guess the USB tolerances inside my One are a bit out. Hope this helps you guys :)
  9. Ya I'm trying to hookup to a ps3 not a computer this is my problem.
  10. ironman187

    ironman187 Well-Known Member

    You may want to exchange that, it's only gonna get worse.
  11. will7201

    will7201 New Member

    Oh no, that's took the air out of my sails! Really? I've tried it with three different USB cables from two manufacturers and none are 'tight'.
    I'll keep my eye on it and be careful, thanks for the heads up :(
  12. handyandy

    handyandy Member

    Both my Desire & Desire HD had a feature under Settings to set the phone to act as an HDD drive or USB stick to feed the USB port on a TV or car radio etc.

    It is probably straightforward but I can't see how to do this on the One.

    I have contacted HTC support who have tried to help but, because of the language difficulties in Thailand where I currently am, cannot understand the question.

    Can anybody advise?

    Thanks
  13. Tlicious1020

    Tlicious1020 On Probation

    Don't you have to plug in a usb cable and the phone will ask you what do you want to do? Charge, sync, etc...
  14. Hadron

    Hadron Well-Known Member Contributor

    But it won't support usb mass storage, because that was removed in android 4.something. So it will depend on whether these devices support MTP.
  15. handyandy

    handyandy Member

    Thanks for the replies.

    When I plug the phone via a USB cable into my television the phone reports a USB connection and that USB debugging is set. The phone does not display any message asking for further instructions. There must be some option in Settings that I am overlooking.

    I'm surprised that this feature may have been removed from later versions of Android as I would think it is a popular feature.

    Any further guidance welcomed.
  16. Hadron

    Hadron Well-Known Member Contributor

    There need not be something you are missing in settings.

    I've never done this, but I think what you need to investigate is a Media Link HD (MHL) adapter, which will let you connect from microusb to HDMI. That should work for your TV at any rate
    KOLIO likes this.
  17. khanweezy

    khanweezy New Member

    Hey guys. Not the most savvy guy with this stuff. Is there any way I can mount my One as Mass Storage on Mac OSX? Just got the Verizon One and realized today that this feature doesn't seem to work. I've scoured forums to find an answer and haven't found one yet. Is there a USB driver for mac? One of the main reasons I switched back to android after having an iphone for 2 years was the ability to drag and drop from my computer (I despise iTunes, and HTC Sync manager seems even crappier so far).
  18. Hadron

    Hadron Well-Known Member Contributor

    The problem isn't a lack of usb storage drivers for the Mac - OSX works out if the box with devices which support usb mass storage. The problem is that that is deprecated in Android, and its replacement, MTP, is a Microsoft thing, and isn't included with OSX or Linux.

    The answer is to install Google's Android File Transfer tool on the Mac. On my phone so no link, but Google it and it will be the top result.
    khanweezy and marctronixx like this.
  19. Bratone

    Bratone Active Member

    Hi, I have a problem with my HTC One's USB.I want to connect it to my PC so I can transfer music but when I plug the USB into my device nothing happens, instead my phone is trying to charge but again, nothing happens, it just switches between charging/not charging.
    What's wrong with my USB ?
  20. Wilkas

    Wilkas Well-Known Member

    have you got another cable you can try bratone, just to rule out a damaged usb cable.
  21. Bratone

    Bratone Active Member

    It is the same USB Cable frome my Phone Charger and it works perfectly when I charge my phone at a power source.
  22. marctronixx

    marctronixx Moderator Moderator

    try another cable. try another computer.
  23. Bratone

    Bratone Active Member

    How can the cable be the problem if it works with my phone charger ? It is the same one.

    I don't have other computer to use ...
  24. EarlyMon

    EarlyMon The PearlyMon Moderator

    The data lines and power line are separate. A data line can break and the cable will still be good for charging. It's not unheard of around here.

    What's the version of your operating system?
    marctronixx likes this.
  25. Bratone

    Bratone Active Member

    Android 4.1.2

    I just bought the phone 2 weeks ago and now is the first time when I try to copy files from my computer to my phone so I seriously doubt that the USB is broken or something like that.

Share This Page