USB Mass Storage Stopped Working...Support


Last Updated:

  1. perpetualjon

    perpetualjon Active Member This Topic's Starter

    Joined:
    May 26, 2012
    Messages:
    39
    Likes Received:
    4
    *** SOLVED *** <--My last post explains what I did to resolve the problem with everyone's help...

    Ok so yesterday I was able to simply plug my phone via USB cable to my Windows7-64 and see the device as a drive on the PC to transfer files. Today, that doesn't work. I can see that the phone is charging and the MTP service starts but I just can't seem to see the phone as a drive now. I've tried disabling USB Debugging and re-enabling it but to no avail. I've also tried connecting to two different PC's. I've tried the USB Utility "connect storage to PC" option but it is unresponsive. I follow the steps and nothing happens.

    Anyone else having this problem or know a fix?
     

    Advertisement
  2. touringhaggis

    touringhaggis Well-Known Member

    Joined:
    Jan 29, 2012
    Messages:
    435
    Likes Received:
    127
    The only thing that I can suggest is that my phone does not allow access to the files stored on it when the screen is locked. As soon as I unlock the phone I can access the files just fine. If you think about it, this is actually a nice feature.

    Hope this helps...

    Regards,
    Eric Ritchie.
     
  3. perpetualjon

    perpetualjon Active Member This Topic's Starter

    Joined:
    May 26, 2012
    Messages:
    39
    Likes Received:
    4
    Well it was worth a try but I'm still not able to access the files on my phone on my PC anymore...
     
  4. mandr01d

    mandr01d Member

    Joined:
    May 25, 2012
    Messages:
    15
    Likes Received:
    2
    Reload drvers
     
  5. perpetualjon

    perpetualjon Active Member This Topic's Starter

    Joined:
    May 26, 2012
    Messages:
    39
    Likes Received:
    4
    Drivers for what? I've never needed to load drivers on a PC for a USB storage device --and this was no exception. The phone was working properly just a few days ago. Would this be drivers on the phone or PC?
     
  6. mandr01d

    mandr01d Member

    Joined:
    May 25, 2012
    Messages:
    15
    Likes Received:
    2
    Device manager.samsung device.delete.plug in phone reinstall drivers.had the same prob.worked 4 me
     
  7. Luckieg

    Luckieg New Member

    Joined:
    May 28, 2012
    Messages:
    1
    Likes Received:
    0
    On the "NOTE" you must "Unmount" the SD card first (Settings => Storage => Unmount). The back into setting => Wireless => USB Utilities => USB Mass Storage, this will put the phone is the correct mode and Twisted will wrk just fine.
    Enjoy
     
  8. perpetualjon

    perpetualjon Active Member This Topic's Starter

    Joined:
    May 26, 2012
    Messages:
    39
    Likes Received:
    4
    I take it you mean delete the "Samsung device" in my "Device Manager" on my PC. I don't see any Samsung Device listed to delete. Thanks for the attempt though!

    Tried that now with the exact same result. I have to turn off "USB Debugging Mode" as demanded to make the connection, I then plug in as requested in the "Connect storage to PC" button is selected, and absolutely nothing happens...

    Thank you everyone for trying though. Maybe I just have a phone that has gone bad in the first week. This WAS working for me without any problem when I first got it.
     
  9. perpetualjon

    perpetualjon Active Member This Topic's Starter

    Joined:
    May 26, 2012
    Messages:
    39
    Likes Received:
    4
    Ok, so as a last resort, I finally just turned the phone off and pulled the battery. I took out the SD card, re-inserted the battery, and booted it back up. I then put the phone back in "USB Debugging Mode" and connected to a PC. Worked like a charm! I don't know if all your suggestions were necessary for this to finally work but I know I tried them all and now all is good. Thanks everyone for all your help with this!!
     

Share This Page

Loading...