usb mass transfer mode? how to?Support

Last Updated:

  1. lpallard

    lpallard Guest

    ok so I went ahead and connected my Samsung galaxy s3 to my computer via usb to transfer pictures and I was uber-disappointed to see that my computer did not detect the phone as a usb mass storage device.

    so I've searched the web and had the misfortune to discover that apparently it's not possible to connect the galaxy usb mass storage device like a usb stick which most people have these days and which most if not all phones are capable of.

    so how do you enable the usb mass storage transfer mode on the galaxy s3??????


  2. Szadzik

    Szadzik Well-Known Member

    No way to enable it. You can root and enable it for SD card only, if you need it that much.
  3. lpallard

    lpallard Guest

    thanks for replying..

    it's not that I need it "that much" but it's a VERY basic feature and not acceptable that a $700+ device not being able to do.. you get files from email, the web, sms, etc.. you record files ( take pictures, record videos, etc)

    do you expect me to send a 300mb video like via email?

    how do I copy my music files? 16gb+ via email???



    like if I had to open the hood and mess around with the engine to fill up my car..
    SoftDad likes this.
  4. Szadzik

    Szadzik Well-Known Member

    You can still copy stuff over USB, I have no idea what you are talking about. It is just a different mode of connection notUMS but MTP and it still works for copying files.
  5. lpallard

    lpallard Guest

    Sorry I forgot to mention the driver issue.. don't you need a driver to connect as mtp device??

    Sure if I plug the phone the OS doesn't see it as a simple usb mass storage device.

    On my Motorola Razer I had the choice of selecting the usb mode as mtp, mass storage and a third mode I can't remember.
  6. Szadzik

    Szadzik Well-Known Member

    UMS needs drivers too.
  7. lpallard

    lpallard Guest

    On slackware Linux I did not have to install drivers and upon connecting the phone it was automatically mounted as a usb mass storage device. My operating system did not change. As a matter of fact it did not change in years.

    If you run windoze yes you need drivers , but then again you need drivers for everything ... on linux chances they were built as modules or integrated with the kernel

    Thanks for the clarity of your answers. I will root the device. That is if I can find an exploit for the Canadian version of the phone. You seems to know quite a bit about these things, perhaps you could kindly point me to the right place?
  8. Crafty

    Crafty Well-Known Member

    IIRC the support for mass storage was removed from Android.

    You can still copy stuff to the phone, it appears as a MTP device now.
  9. lpallard

    lpallard Guest

    Hey Crafty

    According to several threads ive found you are right about the usb mass storage mode being pulled from ICS. It seems that at some point during the development of ICS Samsung decided to remove it for whatever glorious reason. Go figure..

    Now people are forced to install all kind of custom roms and root their devices hence fragmenting android already more than it is already..

    I will try mtp mode and see if I like , but the usb mass storage mode was so effective and simple.. hey why keeping something simple when you can replace it by something complicated?? I don't appreciate when manufacturers make decisions like these, and I'm sure I'm not the only one. Just my opinion.
  10. Sparrow2012

    Sparrow2012 Well-Known Member

    Edit - Apologies! Sometimes I just talk a load of rubbish!!! ;) It could have been my MP3 that I had to fiddle with. I can't find any settings re USB connection so I have deleted my post.
  11. Szadzik

    Szadzik Well-Known Member

    Samsung did not develop ICS, JB or any version of Android whatsoever. Google did.
  12. waremaster

    waremaster Well-Known Member

    It seems as though Samsung chose not to compile USB mass storage mode as well as apps to sd into the kernel. The option was available it just wasn't used. Motorola on the other hand did indeed compile the kernel right and both of those options are available in ICS.

    I love both the Razr MAXX and the Samsung Galaxy S3 but I do believe this was a serious oversight on Samsung's part.
  13. kasper007

    kasper007 Well-Known Member

    Drives me nuts! Is there a workaround?
  14. valorian

    valorian Well-Known Member

    I really do not miss USB mass storage mode.

    I can still click and drag my music and picture just as good with MTP.
  15. lpallard

    lpallard Guest

    Ok true android is a Google product but you are wrong about the specific device configuration .. like laptops Dell, Lenovo, Compaq , or Acer are all selling with windowze but they are all a bit different due to their different manufacturers..

    So you see people are slowly agreeing .. small basic features such as this usb mode cannot be removed without replacing it with something easier better and more efficient.. it's what we call improvement.

    If Samsung did not chose to compile apps to sd that i don't know cause i haven't tried out yet. However I would not be surprised.... with their own store services , the removal of easy connections to the outside world, I slowly have a feeling your device will be tied to them more and more... kinda why I left apple. Just my opinion. I know there are people out there that are overly sensitive and I don't want to offend anyone. I'm just expressing my gut feelings.

    Anyway I cannot help it but feel regrets to have "upgraded" my Motorola droid razr for the galaxy s3. I am severely disappointed with it. What a shame..

    I will try to play more with it whenever I have some spare time but again I don't get the idea of spending time to make a product work the way it is supposed when it's supposed to be consumer ready.

    Good thing I have a sturdy case on that phone! :D
  16. SUroot

    SUroot Well-Known Member Developer

    Before you do, word of warning... it may be fruitless. Ptp and mtp don't work on my Linux box. Nor does (or did last checked) the root methods of usb mass storage.

    I ended up making ubuntu an ftp server instead
  17. valorian

    valorian Well-Known Member

    I'm confused how you feel you have to "make it work". Even though this phone does not have USB Mass storage mode like my Inc 2 had it still functions the same way on my laptop. After installing the drivers I can click and drag files to the phone just like my Inc 2 did in mass storage mode.
  18. Szadzik

    Szadzik Well-Known Member

    I switched from Razr to S3 too and if you are telling me, that the fact you get no UMS on S3 makes it even or worse than the Razr, you do not know much about this phone and all the tricks it has up its sleeve. Motorola offered nothing in terms of enhancement to Android itself and just added some Blur stuff, that after ICS did not mean much. S3 one the other hand, offers a lot of very innovative features and I can tell you that the lack of UMS is just a 1% negative in a 99% positive overall.
  19. GTWalling

    GTWalling Well-Known Member

    The USB Mass Storage was removed by Google in ICS. You can get it back by rooting the phone and using an App called SGS3 Easy UMS.
  20. lpallard

    lpallard Guest

    Yes, its almost fruitless... I tried installing libmtp, scons, and tried to find a gMTP package for by distro (slackware) and nothing to do, it doesnt work. To transfer music files, I had to disassemble the Otterbox defender case, open the phone, take the SD card out, dock it in my computer then transfer files. Not big of a deal but plugging a USB cable was simpler and faster. Plus, with opening and closing the case like that every tinme I want to modify the content of the SD card, the case will end up wrecked and will not close tightly anymore..

    Sorry but it doesnt even remotely help. I understand what you are saying but do you have a working suggestion? Criticizing what I say is OK (if constructive) and I will be more than happy to learn from you or other knowledgeable members but in the end it is a path leading to a working solution (or workaround) that I am seeking.

    In the end, I am confident this phone has some potential (I hope for the price tag) but nevertheless, the UMS was such a simple, proven, working and stable feature that removing it without any kind of warning or mitigation is just plain ugly. That was simple and worked well. Period.

    I have left Apple because you needed drivers and a bloated complicated piece of software (iTunes) to be able to transfer files to & from the phone. With the need of a driver for MTP and the forced implementation of MTP & PTP, its getting to look more and more like Apple. If in the end Android and Apple are like for like, I will definitely opt for the latest since the overall experience is much better (stability wise, speed, battery life, amount of bugs, features of the phone, quality of the construction, etc).
  21. WAWood8

    WAWood8 Well-Known Member

    From what I've read here -- NO you can't, at least, with the INTERNAL filesystem.

    That is a serious problem for me because I have some corrupted thumbnails that are stored in the ".thumbnails" directory on the INTERNAL file system.

    The rooting and app you talk about, from my understanding, only work on the EXTERNAL drive.

    If someone knows for sure that they work on the INTERNAL drive as well, please correct me -- I'd really like to find a way to get rid of these corrupted files.
  22. lpallard

    lpallard Guest

    Can't you just delete the files using the internal file browser?
  23. GTWalling

    GTWalling Well-Known Member

    UMS is for reading both SD internal and external on a PC, not for reading system files of the phone. I have used it several times with great success. You could download any File Manager App from the market to read the internal system, but you still would have to be rooted to do so.
  24. WAWood8

    WAWood8 Well-Known Member

    Have tried that -- and does not show "hidden" directories -- which applies to ".thumbnails" -- since it begins with a period.

    IF there's some option I can set to see these, please let me know.
  25. WAWood8

    WAWood8 Well-Known Member

    I need to get rid of corrupted thumbnail files stored in the ".thumbnails" directory on the phone -- which could be considered "system files".

    So, you're saying if I rooted the phone, then I could do this?

Share This Page