1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

usb mass transfer mode? how to?Support


Last Updated:

  1. davidmanvell

    davidmanvell Well-Known Member

    OK Lets get a few things straight. The S3 uses MTP which is part of the USB protocol. MTP was added to the USB protocol back in 2005 or 2006 and has been adopted by almost everyone in the industry. All cameras now use it as well as every OS on the market except for Apple (Of course). Apple uses PTP which is similar to MTP.

    So if you have a USB device and you stick a MTP device into it and the USB device was written correctly then it should work. Only cases where it wouldn't is if they didn't do it right or the USB device was made prior to 2005-2006.

    Windows has had MTP support since Vista and Microsoft released drivers for the previous OSs as well. MTP support is built into Android, Amiga, Windows, AROS, Linux, and MorphOS and Symbian OS. Supposedly you may have to add drivers for some of these.

    Now if you own a computer your USB device may not be made by one of these companies (Might be made by Intel or Dell or whomever). So you just plug in the S3 to your computer and if it works, great, and if it doesn't go hunt for a driver from whomever made your USB device or buy a USB device that was made correctly. If it doesn't work when you plug your S3 into your computer, don't blame Samsung or Google, blame whomever made your hardware of your USB device inside of your computer.

    More information here:
    Media Transfer Protocol - Wikipedia, the free encyclopedia
    USB.org - Approved Device Class Document Download
    http://www.usb.org/developers/devclass_docs/MTPv1_1.zip

    Advertisement
  2. lpallard

    lpallard Guest

    Thanks for the usb explanations. Very good to know.

    I assume that by usb device you mean the usb controller on my motherboard. My mobo is an Asus (don't remember the exact model) but it's less than 6months old. According to you is would support the mtg protocol which it does but it's the lack of drivers that makes the deal breaks.

    The linux kernel seems to correctly detect the phone but cannot mount it so it is usable..

    Into linux?? Really? That's not what I've experienced and searching Google for a workaround led me to dozens of forums where people stated that mtp plain simple doesn't work under linux (or is extremely buggy and unstable).

    I am not blaming Google or Samsung for linux not supporting mtp and I understand the support of mtp is sketchy at best under linux but what I am blaming Google or Samsung is the apparent lack of understanding for non windows users.

    Mtp also means that I will have to install a driver on EVERY machine I want to connect my phone to?? What if I want to copy files on or from a computer that doesn't have a web connection? What about if I simply don't want to fiddle with drivers on every machine I will ever want to connect my phone to?

    With UMS I never had to even worry about that. It was really "Plug and play"...

    I guess in the end its just different school of thoughts... I prefer simplicity and ease of use, others prefer complicated stuff that will end up being revised and subject to driver changes every so often..

    I will "hunt" for a driver as you suggested and see how far I get. If someone find a way to circumvent this limitation please let us know.
  3. Patmagroin

    Patmagroin Member

    Can someone please give me step by step instructions on how to use my phone as a usb storage device. I have about 10 gigs of music that I want to puy on my 64 gig card but dont know how to do it. I use windows xp if that helps. I have the att version gs3. I couldnt find the mtp driver. Thanks in advance.
  4. valorian

    valorian Well-Known Member

    You can get the drivers from Samsung's website. Click the link. At the bottom of the page select Manuals and Downloads then select software.

    Support - AT&T Cell Phones SGH-I747 | Samsung Cell Phones
  5. jynxx

    jynxx New Member

    try this on a mac and u quickly find there is no way it comes up as a mass storage device. MTP & PTP Style does not register! I'm using OSX Mountain Lion. Android file transfer does not work either. no easy way to copy 16+ Gb of music (for example) from one to the other...without taking the extSD out of the phone and plugging that str8 into the computer. And what's the deal with android file transfr not werking in the first place? is there an update coming to fix this?!?? so annoying...ugh!
  6. NightHawk877

    NightHawk877 Well-Known Member

    I ended up using Windows to manage my phone and use Linux Mint in a VM.
  7. lpallard

    lpallard Guest

    I have faced the very same problem as you. If you read my previous posts you will see that I tried to transfer several gigabytes of music from my computer and I had to disassemble the case and take the cover off, cover that by the way dear fellow s3 users will end up getting slack and will not close tight anymore. Then copy paste the files and move the sd card to the phone and reassemble the case..... awful if you ask but I did not find anything else and I did not feel wasting 10 hours of my life compiling a driver for linux..

    I feel the only way to stand a change to get things straight again is to complain to Google until they wake up.

    I'd like to point out that accepting a change requiring you to change the way you do things is ok, but it doesn't necessarily means that you have to believe this change is absolutely the best and for the best. I am referring to the drivers required to transfer files...

    Other way I believe is to hack the crap out of the device or root it? The last option was interesting but I did not find a reliable source for a Canadian s3 rooted Rom... last thing I want is to brick this phone and get screwed by my service provider.. if anyone has rooted theirs please post back!!!

    I will look on Google bug reports for enhancement report. I have seen many but I'll try to find the most recent and add myself to the people who wants this to change. Maybe before my 3 year cell phone contract expires I'll be able to use the phone as before?
  8. lpallard

    lpallard Guest

    Linux users look at issue 32933 on Google android bug reports. Lots of valuable info there. I'll try what theysuggest over there and post back my findings here..
  9. Flumme

    Flumme Well-Known Member

    Don't like the move from classic usb mass storage either.

    A few other "solutions", that I are not the solution asked for, but gets your stuff from computer to phone (and back again) without the need to disassemble your case.

    Use either Airdroid from the Play store, or set up your Linux box as a ftp server. It will be a little slow, but it works reliably.
    Dropbox is another alternative.

    But they are bad "solutions" to a problem that I strongly feel shouldn't exist.
  10. lpallard

    lpallard Guest

    I feel the same way. Seems programmers are pushing all kind of immature technologies to consumers without options to opt out if unsatisfied.. very disappointing.

    I am glad you posted the ftp solution. I will try it and post back with some results. Again soooooo complicated for something so simple.

    I will also open complain to Samsung by writing and open a Google report and post back the report number here so if someone wants to add to it they will be.

    Were several folks who don't like what they're doing. Google should know and not ignore they customers. Period.
  11. EarlyMon

    EarlyMon The PearlyMon Moderator

    You may find it easier to make your phone the server using SwiFTP. I set it to the root, or /, I find that preferable. Hope this helps.
  12. SUroot

    SUroot Well-Known Member Developer


    This may be easier. It wouldn't be suitable for me. With Linux, I can browse all my network shares with my Linux box being the FTP server.

    Another benefit of this is, I don't need to be at the computer to do this. I don't even need to be in the same country ;)

    Easier sometimes not always the best ;)

    Plus, no need for an additional app. I can use E strongs file manager to manage the FTP connectivity. As I already use this as my File manager, I manage to cut down on having that extra app.

    I am kind of glad this issue exists as it pushed me to find a solution. My computer being an FTP server is not only the solution for this, but also the solution to many other issues too. Such as access to my LAN shares from other computers too, when I'm not at home :)
    EarlyMon likes this.
  13. EarlyMon

    EarlyMon The PearlyMon Moderator

    Have you tried Solid Explorer on your phone yet? Also not bad. :) I like the two panel option in landscape.
    SUroot likes this.
  14. SUroot

    SUroot Well-Known Member Developer

    Not even heard it but always looking to improve on what I have. Will check it out :) Thanks
    EarlyMon likes this.
  15. rodrick12

    rodrick12 Member

    Galaxy Note 2 and Galaxy S3 users can use the SGS3EasyUMS application that has been created by someone at XDA, I don't remember the name. But, it's very useful. The problem is your device has to be rooted.

    Direct Download Link: http://files.tutznet.com/SGS3EasyUMS.zip

    Thanks,
    Do let me know if you face any problems further.
  16. sherlock5545

    sherlock5545 Well-Known Member

    .thumbnails isn't a system folder, it's just hidden. You can just use the built in file manager, you only need to open it, go to settings, and select "Show hidden files".
  17. bmoliver

    bmoliver Well-Known Member


    I just got my wife a new radio for her car with USB input. The radio will recognize my old Galaxy S when I set the Galaxy S to the USB Mass Storage mode. However, it will NOT recognize my new S3 in either MTP or PTP mode (the only two options for the S3). So, not all newer USB devices will work in MTP/PTP mode!
  18. anonuk

    anonuk New Member

    Do you all have to connect through usb?

    How about accessing your nas/pc through webdav and es file explorer. I only cable my s3 to charge it. wireless networking for everything else. I have my phone shared on my network at home aswell.
  19. phil75231

    phil75231 Well-Known Member


    It is not complicated at all. My seven year old transferred a couple of gig worth of music to my phone via MTP for me while I was taking a shower. It's really not that different than the way it was before Jelly Bean.
  20. SUroot

    SUroot Well-Known Member Developer

    Yeah MTP. Mode is exactly if you attached an mp3 player. It shows up as a device which you double clicks then drag n drop.

    The significance of no USB mass storage is not simplicity. Its other things you can't do. Transferring music and pictures is as easy as it ever was
  21. SoftDad

    SoftDad Member

    Well yeah, the device shows up in Win 7 explorer as a music player with an SD. But so far as I can see, apps on the mother ship have no way to address the SD card (like no drive letter or even a \\server\share location). Please somebody let me know if I'm missing something! If the explorer can do it, why not joe app?

    My good old sync program (with LOADS of files) no longer can sync. And my audio book listener can't see the SD card to store huge amounts of books.

    This is really unacceptable. It's a capability that has been there since phones took SD cards. Now gone. :mad: And it's not like USB is a dying technology.

    Please, Google, listen to your faithful and bring back USB mass storage!
  22. SoftDad

    SoftDad Member

    Wireless is great if you have it. Works (sort of OK) for syncing at home, but my company doesn't let us into their wireless network (security risk - rightfully so). USB has always been reliable & fast. Why take away that capability?
  23. Bramsy

    Bramsy Well-Known Member

    So let me get this straight.

    I just did the JB update. Before the update I could plug in my phone to my windows 7 machine via USB and it would mount as a drive and I could do as I please..

    After I do the update, I get device not recognized, no drivers work and it isn't simple as my previous 5 phones... And this is "normal"?

    If this is how it is, that's a HUGE step backwards for Android!
  24. SUroot

    SUroot Well-Known Member Developer

    It's been like this since ICS. Nothing to do with the JB update. Galaxy s3 on 4.0.4, there wad no UMS mode. Just MTP (makes windows think you connected a media player) or PTP (makes windows think you connected a camera).

    You could still drag n drop files using the photo transfer protocol or media transfer protocol. Its just neither show up as a drive letter.

    You can almost do everything you need on windows. Mac or Linux, not so much but even on windows, you may want to run scripts or software that relies on drive letters...

    Yes its a failure IMHO but its not a new one
    Bramsy likes this.
  25. Bramsy

    Bramsy Well-Known Member

    I had been using my galaxy nexus for transfers and stuff.... Didn't realize my S3 wouldn't work the same :(

Share This Page