'USB Mode' option missing!Support


  1. fikhl

    fikhl New Member

    Hello everyone!

    I noticed that there is no option for changing the USB mode on my Samsung Galaxy Gio.

    I can't remember if it was there when I first got it. Today I wanted to use the Samsung Kies and it says change the USB mode, but it's nowhere to be found!

    Anyone having the same problem? Do you have the USB mode option in the Settings menu?

    Thanks!

    Advertisement
    :
  2. keithnmikkii

    keithnmikkii Member

    Yup this is the problem i have been having for weeks, and nobody seems to know the answer. Not samsung, not developers forum and not this forum, sorry to that i can not help you at this time, i will keep looking though.
    fikhl likes this.
  3. fikhl

    fikhl New Member

    Thanks for the answer!

    Yes that's very annoying, and kinda weird actually! Let's just hope updating it to Gingerbread would finally fix it.
  4. david007

    david007 Member

    I have same problem i can't connect my samsung gio to pc to transfer music to it! when i connect the phone to windows xp it cant find the drivers to recognize it! could you guys tell me how to fix this problem?

    By the way is there any offical tutorial in how to upgrade to Gingerbread?
  5. keithnmikkii

    keithnmikkii Member

    I have the same issue, tried it on 5 different computers now, including Best Buy's Tech computer with no luck. 3 Different OS.

    i have been on the line with customer service for hours about just this issue, they seem bumbfounded!!! Being in the US, and the Gio isn't released here for some months, they wont help me what so ever. I am contemplating whether to send it back to my relatives in Hong Kong so they can take it to the store to see if there is a problem or not?

    Where are you located? I am trying to work out whether the phones and the OS's have some sort of regional differences.
  6. fikhl

    fikhl New Member

    Hi! I don't have that problem with Windows 7, it recognizes it as a mass storage device, so I can easily transfer files. But for now, to transfer music files, I suggest using Winamp (latest version, still in beta) which has wireless syncing. You can also use something like SwiFTP, to wirelessly access the phone's content. Detailed instructions here: Map Android Phone In Windows 7 To Access Root Files Over WiFi
    According to this post from Engadget: Samsung Galaxy Ace, Galaxy Fit, Galaxy Gio and Galaxy mini fill out our Android universe -- Engadget it's unlikely that Samsung would ever release this phone in the US. We better wait for the official Gingerbread update for Gio. I'm really surprised, I read many reviews of Gio online before purchasing this phone and they were generally very positive, but these obvious issues were never addressed in the reviews I read!
  7. Bagbug

    Bagbug Well-Known Member

    I have this phone running on Gingerbread (out of the box0 and I dont have the USB mode.
  8. catterin

    catterin New Member

    Same here, I have Gingerbread straight out of box with no usb mode nor network mode for gsm but everything works just fine. Samsung kies detects it and so does my computer for mass storage use.. Just make sure to have all the correct drivers installed.
  9. asad1912

    asad1912 Member

    guys...im pretty sure it is about
    either turning mass storage on/off
    or
    turning usb debugging mode...

    im not sure...

    because i can toggle these two...
  10. asad1912

    asad1912 Member

    which region you are in...?
    because from what i know...
    gio only has froyo out of the box....well its what i had...and read in ALL reviews..
  11. rayun

    rayun New Member

    Mine came out of the box with GINGERBREAD.
    Also, turning on USB debugging fixed the problem
  12. salsoulrecords

    salsoulrecords New Member

    hello i have windows xp sp3 and now I can connect my Samsung Galaxy Gio via USB.
    So need to do the following: install SAMSUNG_USB_Driver_for_Mobile_Phones_v1.3.400.0
    and then turn off the PC.
    Then connect the USB cable from PC to Samsung Galaxy Gio connect the PC and wait for the system boots finally turn on the cellphone.
    Once you connect the PC will start to find all the relevant drivers.
    I am using the Android version 2.3.4
    I hope it was a good help and my apologies for my English.
    ;)

    To get the drivers just google - SAMSUNG_USB_Driver_for_Mobile_Phones_v1.3.400.0

    Thanks to all
    Reboc43 likes this.
  13. faizanfarhat

    faizanfarhat New Member

    Hi, I think i know solution of this problem

    Connect you GIO to PC/laptop

    install required drivers

    Top Status bar will show USB icon, Slide Status bar

    Here under ONGOING, there will be a notification USB connected

    select it, new window have a button "Connect storage to PC"

    try this, i hope that will solve your problem

    I can access my SD card via that procedure


    I am new to this android thing, bought Samsung GIO a week ago

    San someone tell me benifits of Rooting Samsung gio, and Some Crac**d games for un-rooted GIO?
  14. deadlyrhythm

    deadlyrhythm New Member

    I have this same problem. Heres the info that I have which is also on the forum.xda-developers.com site.

    Samsung Galaxy Gio [Bell] Canada. (locked)
    Device: GT-S5660M
    Android Version: 2.3.4
    Kernel version: 2.6.35.7-perf-CL413839se.infra@SEI-44#1
    Baseband: S5660MUGKG3


    • The device simply wont connect or show up on any PC.

    • Tried installing KIES (lattest - Kies_2.0.3.11082_152_4). Nothing shows up

    • Tried putting the phone in downloading mode and then in KIES selected emergency firmware update mode and still no device.

    • Tried using lattest Samsung USB Drivers (1.3.450.0)

    • Tried putting the phone in downloading mode and connecting it to ODIN which it does not show up in the COM PORT area.

    • Tried dialing : *#7284# to change the SERVICE MODE to either USB, UART
      Including Toggling DBG MSG

    • Tried different USB ports.

    All doing this with USB DEBUGGING ON and tried with it OFF.

    There is no USB Setting in About Phone or in Wireless and Networks settings from the settings menu.

    There are many other people with this issue I found but all possible solutions that I have been able to find are listed and attempted but to no avail.
    Ive read that others are having no problem connecting to their PC seeing as theres modding / custom rom forums all over. So people are able to connect which leads me to think that this is a carrier specific issue.
    THIS IS ONLY MY SPECULATION . NOT 100% SURE

    I thought I could start this thread on here to get some more solid advice and help.
  15. TheoW

    TheoW New Member

    I dont think your having a carrier specific issue, I bought my Galaxy Gio a week ago and since my pc sd card reader is not compatiable with the 16gb sdhc card I upgraded too I tried to transfer files to my phone via usb cord.

    I myself have been searching for a solution to this problem with no success, but something interesting I discovered, I bought a family member the exact same phone a day after I bought mine, I hooked it up to the usb cord and all of a sudden I was able to access there memory card via my pc. The "USB" icon appears on their phone and the drive shows up on my computer, I pull down the menu and connect to the pc with no issues, even with my new sdhc card inserted on their phone. As soon as I unplug their phone and plug mine back in I get no notification of connection and the drive does not show up on the pc.

    So basically with 2 exact phones purchased a day apart , my phone has the missing USB notification and the other has it and both phones are on the same carrier.

    Im wondering if I somehow disabled the feature while learning the phone, anyways If I figure this out I will post back the results here.

    UPDATE:

    I unplugged my USB cord , Shut down my phone and turned it back on again and then plugged my USB cord back in and all of a sudden my USB mass storage option was there in the notification tray. I had done those steps a few times earlier with no results but all of a sudden its working now, not to sure what to make of this.
  16. deadlyrhythm

    deadlyrhythm New Member

    wow. thats good news to hear.
    So one i thing i forgot to mention is that i don't have the original USB cable that came with my phone.
    I have one that came with a different phone but I can't see something as simple as a USB cable causing this issue as it works with and older Android phone.

    Either way its a micro USB cable. They're all the same.
    Could it actually be possible that this might be the case?

    I will try what did in your UPDATE to see if that works and post back.
  17. deadlyrhythm

    deadlyrhythm New Member

    As it turns out it was actually the usb cable.

    I was using a micro usb that came with an LG Eve android phone.
    I borrowed my friends HTC Desire micro usb cable and to my surprise it worked!

    To everyone that has this issue, TRY A DIFFERENT USB CABLE!
    I hope this helps someone else and stumbles on this thread.
  18. pellicle

    pellicle Member

    not mine (win7), it recognises it as a device, loads all the drivers then that's it

    phone fails to appear

    on my XP box it was able to communicate with ODIN but that's all
  19. pellicle

    pellicle Member

    yes, this is now the situation (I tried again after reading your post)

    so I now have USB mass storage on win7
  20. eltres

    eltres New Member

    If you connect the phone to your computer and it starts charging, then your USB Cable is okay.

    You will see a USB connection at the very top left corner of your screen. Touch and drag it down. You will see some information and you will also see ("USB Connected" Select to copy files to/from your computer) you will then get a message and a button "Connect storage to PC" at the next message, touch the "OK" you're done! now your computer will be able to see it as a drive.
  21. pmjzzz

    pmjzzz New Member

    I have a similar problem with aftermarket USB cables. I have an unlocked S5660M in Canada.

    The OEM USB cable works fine - once I had found the correct drivers, and installed them, on two different machines - one on Win2k, the other on XP. One strange behaviour is that the drivers install and uninstall each time the phone is plugged-in (I've monitored this at Device Manager). I also have a Linux Ubuntu netbook, which connects just fine by default.

    I bought a couple of aftermarket USB cables - so I could keep one at each machine, and also 'cos I found the OEM cable to be too short. The new cables always work for recharging, but they've only established USB connections just a couple of times in four months. And amazingly - they both worked, just once, on the same day about 3 weeks ago - on different machines????? They've also never worked with the netbook.

    So it might be that the aftermarket cables are fundamentally deficient. It might be that the length of these cables affects their behaviour - they're about 2 m long compared to about 800 mm for the OEM. Or it might be that the phone doesn't consistently send the right signal to the host machine to "activate" the USB connection. But for them both to work on the same day seems to be pushing coincidence way too far???
  22. moni1

    moni1 New Member

    hi all. can some body help with samsung gt-s5660 i forget the screen key but i haven try because it was with many nubers i try meny times but now it say just 1 time not any more. how can i get my messages from my phone i have have try with usb but it show me everythings just messages i can not get i can not see herecan you help me please respect !
  23. moni1

    moni1 New Member

    hi all. can some body help with samsung gt-s5660 i forget the screen key but i haven`t try because it was with many numbers i try meny times but now it say just 1 time not any more. how can i get my messages from my phone i have have try with usb but it show me everythings just messages i can not get i can not see herecan you help me please respect !
  24. Peteragent5

    Peteragent5 Well-Known Member

    Reply to the general forum topic: Support 'USB Mode' option missing!

    I think if your computer won't recognize the usb the first time then:
    Unplug it and put it back in.
    Just keep doing this either with your phone or with a SD Reader.
    I pretty much worked for my XP (Aggressive with my Gio LOL) :)
    Hope this helps!
  25. javedchano786

    javedchano786 New Member

    Dear,
    For USB connectivity on PC, I think you have to go in settings
    then from settings menu go to
    applications
    then to Development
    then remove check/tick mark from USB debugging then it will appear on ur phn screen for enabling USB..
Loading...

Share This Page