USB mount problemSupport


  1. jondiehl

    jondiehl Active Member

    Just swapped out my wife's Intercept today after 10 days with it (it sucked) and she's much happier with this Transform.

    However, I noticed that when plugging the phone into any of our PC's via the USB cable, the phone doesn't have a USB/Mount type of an indication or anything, and in fact Windows doesn't even find the phone (can't find a driver for it or something)?

    Quite odd, as none of my other Android phones have had an issue with this (Hero, Epid, or her Intercept).

    Could the phone be bad? I can take the memory card out and access the data on it that way, but this is a pain, I'd rather just connect to the phone via USB like I always do.

    Advertisement
    :
  2. tmaxey1

    tmaxey1 Well-Known Member

    I dont have this phone yet. I am considering it for my wifes account.

    Have you checked the owners manual to see if usb sync is an option. I have never heard of an android phone that isnt. Have you tried rebooting your computer and see if it makes a difference. I have that happen once with my EVO.

    Hopefully its not a Samsung bug. They are known for them.
  3. jondiehl

    jondiehl Active Member

    Owners manual says it can mount. I tried 3 different pc's, same result on all 3 (installation of driver failed/not found)
  4. kristv

    kristv Well-Known Member

    You may need to download a driver from Samsung's website, depending on your OS. I know that Epic owners are having to download separate drivers for Windows 7.
  5. Pyrit3Sol

    Pyrit3Sol New Member

    I just bought the Samsung Transform SPH-M920 yesterday. I've had the same issue as you, jondiehl. Samsung's site as of 10/12/2010 7:40 CDT doesn't have any information about the Transform, searches with model number yield no result.
    Win7's device manager recognizes the phone as Samsung_Android, but that's all.
    Oddly while I powercycled my Transform while it was still connected via USB, Win7 gave me a message that a driver downloaded, but my hopes were dashed when it still failed to find a driver for it.
    Maybe samsung will come up with something sometime, this is the Transform's first week available, but still... Jeers to samsung.
  6. jondiehl

    jondiehl Active Member

    I bought an Epic two weeks ago and it plugged right into both my Windows 7 computers, and my Vista laptop without the need of a driver download.

    Still nothing on the wife's Transform though.
  7. berger1980

    berger1980 Active Member

    I am assuming you have it mounted through the phone also? The only other thing could be the cable. You can check the continuity, or purchase one and test it. If it still doesn't work, then I would assume it's the phone :(
  8. jondiehl

    jondiehl Active Member

    Fixed.

    I had USB debugging mode enabled, turned it off and it works fine now.
  9. berger1980

    berger1980 Active Member

    That's really odd. I can still mount my device with debugging on, and even transfer files. I hope these coming from the factory aren't seriously this spotty. Seems there's more that don't work properly, than do.
  10. cstrasbaugh

    cstrasbaugh New Member

    I have been running into the same problem on the Mac side. At home we are having no luck mounting through any means (usb debugging, mounting apps, petting the phone and telling it I love it) on our new iMac i5 quad-core through DoubleTwist. However I just took it to work and plugged it into my newer iMac Core2 Duo and it works fine. Any ideas for the Mac side?
  11. beezie916

    beezie916 Well-Known Member

    Win 7 seems to have issues with the Intercept first and now the Transform....I had a moment originally and didn't need to reload any drivers...but i have noticed sometimes u have to retry a couple times...or make sure phone unlocked....sometimes different usb port....

    make sure you dont have usb debugging enabled....
  12. TheRH

    TheRH Well-Known Member

    It should mount like a thumb drive.
  13. bestoverall

    bestoverall Member

    How do you turn off USD debugging mode?
  14. TheRH

    TheRH Well-Known Member

    Ok follow these steps:

    Menu> Settings> Applications> Development> USB Debugging ( Un-check this)
  15. beezie916

    beezie916 Well-Known Member

    You can also download pdanet which will install drivers that help mount the phone with either debugging checked or not.
  16. bestoverall

    bestoverall Member


    I checked mine and it shows unchecked for USB Debugging. But still no visible driver letter assigned for this USB Mass Storage. The PC recognizes it as android device but does not assign a driver letter in Explorer.
  17. clepe

    clepe New Member

    All,

    I came across this same issue, my laptop is running Windows 7. This is what I did to mount the micro sd card...

    1) After connecting your phone to PC, a USB notification will appear at the top of your screen. Drag the notifications screen down. Click on "USB connected" notification.

    2) A new prompt will appear stating that you have connected your phone to computer via USB. Click the "Mount" button.

    You have now mounted your micro sd card and should be able to access it through your PC. Hope this helps.
  18. bestoverall

    bestoverall Member

    That worked. Thanks.
  19. egkor

    egkor Well-Known Member

    Same issue here (laptop not recognizing Transform connected via USB).

    I have a Samsung Moment, and the Moment is recognized.

    With the Transform I have USB debugging "off", and tell the phone to "mount the SD card" from the phone's drop down menu (just like what works for the Moment).

    My laptop is running Win Vista 64 bit.

    I downloaded the Samsung driver install package from the Samsung web site (link below), but I can't get that installer to run properly.

    Oh well ...

    -Gary K

    Samsung
  20. egkor

    egkor Well-Known Member

    After successfully running the Samsung driver install download from the Samsung web site, I still cannot get the Transform USB port to be properly recognized by my MS-Win Vista 64 Ultimate OS.

    I either get a drive letter (for the Transform) with a "empty" directory, or I get a "USB Device Malfunction, not recognized" message from MS Vista.

    No amount of USB Debug On/Off or USB mount/dismount from the Transform changes anything.

    So I've tried everything I know to try with no luck. And I don't want to remove the microSD card from the Transform and plug it into a SD adapter and into the computer to copy files back and forth.

    Any further help/insights into this appreciated. The next step would be to call Samsung support, but I'm not yet at that point.

    -Gary K
  21. TheRH

    TheRH Well-Known Member

    You may need to install the SDK, after I did that and installed the Samsung driver everything was butter. Now when I select mount it works just like a thumb drive. :)

    Android SDK | Android Developers

    Simply install unpack the SDK. If you have any other question PM me.
  22. nstg8r

    nstg8r Well-Known Member

    When I plug my phone into my computer's (Windows 7) usb port with the supplied samsung usb cable, it works. When I try it with a Rocketfish (Best Buy) usb mini cable with mini-to-micro adapter, it never works. Don't know if that helps.
  23. TheRH

    TheRH Well-Known Member

    I have used both the stock and a Belkin cable, both work, you just need to have the right drivers. That is all I can really tell you.
  24. egkor

    egkor Well-Known Member

    I've been using the supplied Samsung usb cable ...

    It has been working flawlessly with my Samsung Moment, but not working with the Transform.

    I'll try the SDK mentioned above, thanks to all!

    -Gary K
  25. TheRH

    TheRH Well-Known Member

    Make sure you have the current Samsung Driver as well as the SDK. I am running Win 7 Pro 64bit, and it works great.
Loading...

Share This Page